Gauche 0.9.15 fails to build (test failure)

  • Open
  • quality assurance status badge
Details
One participant
  • Antero Mejr
Owner
unassigned
Submitted by
Antero Mejr
Severity
normal
A
A
Antero Mejr wrote on 7 Sep 20:39 +0200
(address . bug-guix@gnu.org)
875xr7e2am.fsf@antr.me
It appears the FFI test is failing (at least for x86_64 target):

```
Testing ffitest ... failed.
9 discrepancies found:
test load-foreign: expects (#t (f_i () i) (f_i_i (i) i)) => got #<<error> ": no matching clause for (.struct _IO_cookie_io_functions_t () ((read (.pointer () (.type cookie_read_function_t () (.function () (.type __ssize_t () (long ())) ((__cookie (.pointer () (void ()))) (__buf (.pointer () (char ()))) (__nbytes (.type size_t () (u-long ())))))))) (write (.pointer () (.type cookie_write_function_t () (.function () (.type __ssize_t () (long ())) ((__cookie (.pointer () (void ()))) (__buf (.pointer () (char (const)))) (__nbytes (.type size_t () (u-long ())))))))) (seek (.pointer () (.type cookie_seek_function_t () (.function () (int ()) ((__cookie (.pointer () (void ()))) (__pos (.pointer () (.type __off64_t () (long ())))) (__w (int ()))))))) (close (.pointer () (.type cookie_close_function_t () (.function () (int ()) ((__cookie (.pointer () (void ()))))))))))">
test call-foreign f_c: expects 9 => got #<<error> "flib is supposed to be of type #<class <foreign-library>>, but got #f">
test call-foreign f_i: expects 42 => got #<<error> "flib is supposed to be of type #<class <foreign-library>>, but got #f">
test call-foreign f_f: expects 1.25 => got #<<error> "flib is supposed to be of type #<class <foreign-library>>, but got #f">
test call-foreign f_d: expects 3.14 => got #<<error> "flib is supposed to be of type #<class <foreign-library>>, but got #f">
test call-foreign f_v: expects #<undef> => got #<<error> "flib is supposed to be of type #<class <foreign-library>>, but got #f">
test call-foreign f_i_i: expects 99 => got #<<error> "flib is supposed to be of type #<class <foreign-library>>, but got #f">
test call-foreign f_f_f: expects 0.125 => got #<<error> "flib is supposed to be of type #<class <foreign-library>>, but got #f">
test call-foreign f_d_d: expects 1.0 => got #<<error> "flib is supposed to be of type #<class <foreign-library>>, but got #f">
```
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 73113@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 73113
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch