(name . Guix Patches)(address . guix-patches@gnu.org)
Hello Guix,
This patch adds a debug output for GSL. Encountered the absence of debug
output while debugging a GSL-reliant program. Tested, produces the
proper debugging file with the right symbols.
From c8e5967de674c5eec61f9686902ea6fe568531bf Mon Sep 17 00:00:00 2001
From: Artyom Bologov <mail@aartaka.me>
Date: Thu, 5 Sep 2024 23:24:28 +0400
Subject: [PATCH] gnu: gsl: Add debug output.
* gnu/packages/maths.scm (gsl)[outputs]: Add "debug".
---
gnu/packages/maths.scm | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
Toggle diff (15 lines)
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 2fe64d4aee..92244ed5f8 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -725,7 +725,7 @@ (define-public gsl
(sha256
(base32
"0jxkxrnpys2j3rh8bzx0bmnh4w6xm28jd57rgxsjp0s863agpc6w"))))
- (outputs '("out" "static"))
+ (outputs '("out" "static" "debug"))
(build-system gnu-build-system)
(arguments
(list ;; FIXME: Setting CFLAGS=-fPIC is not only unnecessary, it's also
--
2.41.0