[PATCH] doc: Explain `git format-patch` revision format

  • Done
  • quality assurance status badge
Details
2 participants
  • Ekaitz Zarraga
  • Maxim Cournoyer
Owner
unassigned
Submitted by
Ekaitz Zarraga
Severity
normal

Debbugs page

Ekaitz Zarraga wrote 6 months ago
(address . guix-patches@gnu.org)(name . Ekaitz Zarraga)(address . ekaitz@elenq.tech)
7098b72d119941801db2c9f38a8a4f2dde03b540.1725562109.git.ekaitz@elenq.tech
* doc/contributing.texi(Sending a Patch Series): Add a note about
`git format-patch` revision format and link to git documentation.

Change-Id: Ie08f85dc19e3804165fb184664b74e85a804d7c4
---
doc/contributing.texi | 12 ++++++++++++
1 file changed, 12 insertions(+)

Toggle diff (27 lines)
diff --git a/doc/contributing.texi b/doc/contributing.texi
index 73f7addbef..d5d63ebdbd 100644
--- a/doc/contributing.texi
+++ b/doc/contributing.texi
@@ -2187,6 +2187,18 @@ Sending a Patch Series
--cover-letter --base=auto
@end example
+@quotation Note
+@code{git format-patch} accepts a wide range of
+@uref{https://git-scm.com/docs/gitrevisions, revision range} specifiers.
+For example, if you are working in a branch, you could select all commits
+in your branch starting at @code{master}.
+
+@example
+$ git format-patch master..@var{MY_BRANCH} -o outgoing \
+ --cover-letter --base=auto
+@end example
+@end quotation
+
We can now send @emph{just} the cover letter to the
@email{guix-patches@@gnu.org} address, which will create an issue
that we can send the rest of the patches to.

base-commit: 7d2ced8d6d9c38327592d312376d59a8c37fc160
--
2.45.2
Maxim Cournoyer wrote 6 months ago
(name . Ekaitz Zarraga)(address . ekaitz@elenq.tech)
87tteqe0fs.fsf@gmail.com
Hi Ekaitz,

Ekaitz Zarraga <ekaitz@elenq.tech> writes:

Toggle quote (26 lines)
> * doc/contributing.texi(Sending a Patch Series): Add a note about
> `git format-patch` revision format and link to git documentation.
>
> Change-Id: Ie08f85dc19e3804165fb184664b74e85a804d7c4
> ---
> doc/contributing.texi | 12 ++++++++++++
> 1 file changed, 12 insertions(+)
>
> diff --git a/doc/contributing.texi b/doc/contributing.texi
> index 73f7addbef..d5d63ebdbd 100644
> --- a/doc/contributing.texi
> +++ b/doc/contributing.texi
> @@ -2187,6 +2187,18 @@ Sending a Patch Series
> --cover-letter --base=auto
> @end example
>
> +@quotation Note
> +@code{git format-patch} accepts a wide range of
> +@uref{https://git-scm.com/docs/gitrevisions, revision range} specifiers.
> +For example, if you are working in a branch, you could select all commits
> +in your branch starting at @code{master}.
> +
> +@example
> +$ git format-patch master..@var{MY_BRANCH} -o outgoing \
> + --cover-letter --base=auto

The --base=auto can be dropped since it's part of our default git
config, which is automatically installed for all of our contributors
(c.f.: etc/git/gitconfig) when they build the Guix source.

Otherwise, LGTM, if others think it has enough value to be added.

--
Thanks,
Maxim
Ekaitz Zarraga wrote 6 months ago
(name . Maxim Cournoyer)(address . maxim.cournoyer@gmail.com)
e547426f-cf19-934d-25e2-cd352e38b78a@elenq.tech
Toggle quote (10 lines)
> The --base=auto can be dropped since it's part of our default git
> config, which is automatically installed for all of our contributors
> (c.f.: etc/git/gitconfig) when they build the Guix source.
>
> Otherwise, LGTM, if others think it has enough value to be added.
>
> --
> Thanks,
> Maxim

Hi!

Should we remove the --base=auto from all the examples or only mine?

Thanks!
Maxim Cournoyer wrote 6 months ago
(name . Ekaitz Zarraga)(address . ekaitz@elenq.tech)
87r09tsfko.fsf@gmail.com
Hi Ekaitz,

Ekaitz Zarraga <ekaitz@elenq.tech> writes:

Toggle quote (12 lines)
>> The --base=auto can be dropped since it's part of our default git
>> config, which is automatically installed for all of our contributors
>> (c.f.: etc/git/gitconfig) when they build the Guix source.
>> Otherwise, LGTM, if others think it has enough value to be added.
>> --
>> Thanks,
>> Maxim
>
> Hi!
>
> Should we remove the --base=auto from all the examples or only mine?

Your commit shouldn't add it, and as an extra, if you don't mind the
extra scope, another commit removing it from all the existing examples
would be nice.

--
Thanks,
Maxim
Ekaitz Zarraga wrote 6 months ago
[PATCH] doc: contributing: Remove --base=auto
(address . 73055@debbugs.gnu.org)(name . Ekaitz Zarraga)(address . ekaitz@elenq.tech)
2b42178552244c7bd2fa4c8b55dd83d1e9549dcd.1725891135.git.ekaitz@elenq.tech
* doc/contributing.texi(Sending a Patch Series): Remove --base=auto from
examples

Change-Id: Idd421f9d6b592d6a314edfaa66404dee4c1b2241
---
doc/contributing.texi | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (27 lines)
diff --git a/doc/contributing.texi b/doc/contributing.texi
index d5d63ebdbd..fe8f4c0113 100644
--- a/doc/contributing.texi
+++ b/doc/contributing.texi
@@ -2184,7 +2184,7 @@ Sending a Patch Series
@example
$ git format-patch -@var{NUMBER_COMMITS} -o outgoing \
- --cover-letter --base=auto
+ --cover-letter
@end example
@quotation Note
@@ -2195,7 +2195,7 @@ Sending a Patch Series
@example
$ git format-patch master..@var{MY_BRANCH} -o outgoing \
- --cover-letter --base=auto
+ --cover-letter
@end example
@end quotation

base-commit: 7d2ced8d6d9c38327592d312376d59a8c37fc160
prerequisite-patch-id: c786a06cb219ebf12546f05af46995498bf6b090
--
2.45.2
Maxim Cournoyer wrote 6 months ago
(name . Ekaitz Zarraga)(address . ekaitz@elenq.tech)
87le006ww4.fsf@gmail.com
Hi,

Ekaitz Zarraga <ekaitz@elenq.tech> writes:

Reviewed-by: Maxim Cournoyer <maxim.cournoyer@gmail>

--
Thanks,
Maxim
Ekaitz Zarraga wrote 3 months ago
Re: [PATCH] doc: Explain `git format-patch` revision format
(address . 73055-done@debbugs.gnu.org)(name . Ekaitz Zarraga)(address . ekaitz@elenq.tech)
8842b8af-6e36-4816-8ac3-08065433b6bd@elenq.tech
Done by 7b46b8db9afac3825518dca10b5ff0eab04f5f08 and
9001514e242ad15c190588439930b0fa4f6782e3
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 73055@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 73055
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help