emacs 30 ssh: couldn't find a proper `ls' command

  • Done
  • quality assurance status badge
Details
2 participants
  • Christopher Howard
  • Jesse Millwood
Owner
unassigned
Submitted by
Christopher Howard
Severity
normal

Debbugs page

Christopher Howard wrote 6 months ago
(address . bug-guix@gnu.org)
87v7za83s2.fsf@librehacker.com
Hi, I've recently started using emacs 30 which I compile from source. Something that broke in the switch from emacs 29->30 is I am not able to use tramp to ssh into any of my guix servers. I get this error

```
Debugger entered--Lisp error: (file-error "Couldn't find a proper `ls' command")
```

I reported this as an Emacs bug - 72861 - and based on the data I provided -- full backtrace, etc. -- they indicated it was a guix bug. They pointed me to guix bug 64534.

However, I tried adding the appropriate directory to tramp-remote-path (/run/current-system/profile/bin) and that did not work.

If I switch back to 29.4 then I can access my servers again normally through tramp.

Here is my system information:

```
christopher@theoden
-------------------
OS: Guix System x86_64
Host: OptiPlex 9020 00
Kernel: 5.15.161-gnu
Uptime: 63 days, 19 hours, 14 mins
Packages: 167 (guix-system), 251 (guix-user)
Shell: bash 5.1.16
Resolution: 1920x1080
DE: GNOME
Theme: Adwaita [GTK2/3]
Icons: Adwaita [GTK2/3]
Terminal: guix
CPU: Intel i5-4570 (4) @ 3.600GHz
GPU: AMD ATI Radeon HD 8490 / R5 235X OEM
GPU: Intel HD Graphics
Memory: 5038MiB / 15914MiB
```

``` guix describe
Generation 143 Sep 03 2024 10:14:51 (current)
guix 82174b2
branch: master
commit: 82174b2742c2a59fd7959ba9acc80edd6f93d9f7
```

The emacs version I am testing is:

GNU Emacs 30.0.90 (build 5, x86_64-pc-linux-gnu, GTK+ Version 3.24.41, cairo version 1.18.0) of 2024-09-03


--
馃摏 Christopher Howard
馃殌 gemini://gem.librehacker.com

讘专讗砖讬转 讘专讗 讗诇讛讬诐 讗转 讛砖诪讬诐 讜讗转 讛讗专抓
Christopher Howard wrote 4 months ago
(address . 73052-done@debbugs.gnu.org)
87cyjf6ily.fsf@librehacker.com
I haven't been struggling with this issue for some months now. I can't remember exactly what I did, but I think the key was this tramp-own-remote-path option:

```
'(tramp-remote-path
'(tramp-own-remote-path tramp-default-remote-path "/bin" "/usr/bin"
"/sbin" "/usr/sbin" "/usr/local/bin"
"/usr/local/sbin" "/local/bin"
"/local/freeware/bin" "/local/gnu/bin"
"/usr/freeware/bin" "/usr/pkg/bin"
"/usr/contrib/bin" "/opt/bin" "/opt/sbin"
"/opt/local/bin" "/opt/homebrew/bin"
"/opt/homebrew/sbin"
"/run/current-system/profile/bin"))
```

--
Christopher Howard
Closed
Jesse Millwood wrote 4 months ago
emacs 30 ssh: couldn't find a proper `ls' command
(address . 73052@debbugs.gnu.org)
c99ddc02-3e79-40cc-b61d-6b7a0706c0d5@fastmail.com
I'm having this problem as well but with emacs 29 on a foreign distro
trying to tramp ssh connect to a GuixSD system. I have added the same
paths to the "tramp-remote-path" but I get the same issue. I did notice
that the docs for the "tramp-remote-path" mentions that it needs
"getconf" first, otherwise it just uses /bin:/usr/bin :

Default Directories represent the list of directories given by
the command "getconf PATH".聽 It is recommended to use this
entry on head of this list, because these are the default
directories for POSIX compatible commands.聽 On remote hosts which
do not offer the getconf command, the value "/bin:/usr/bin" is
used instead.聽 This entry is represented in the list by the
special value tramp-default-remote-path.

The getconf utility doesn't seem to be available in Guix though.


Jesse
?
Your comment

This issue is archived.

To comment on this conversation send an email to 73052@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 73052
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help