[PATCH] gnu: Add ansifilter.

  • Open
  • quality assurance status badge
Details
2 participants
  • Ahmad Draidi
  • Ludovic Courtès
Owner
unassigned
Submitted by
Ahmad Draidi
Severity
normal
A
A
Ahmad Draidi wrote on 5 Sep 16:48 +0200
(address . guix-patches@gnu.org)(name . Ahmad Draidi)(address . a.r.draidi@redscript.org)
cea3e6a3d50a1d53518a83c32b2b057303b49045.1725547731.git.a.r.draidi@redscript.org
* gnu/packages/pretty-print.scm (ansifilter): New variable.

Change-Id: I12e86080f5f39c52ea1def6084b9a5e6cc7af92c
---
gnu/packages/pretty-print.scm | 43 +++++++++++++++++++++++++++++++++++
1 file changed, 43 insertions(+)

Toggle diff (58 lines)
diff --git a/gnu/packages/pretty-print.scm b/gnu/packages/pretty-print.scm
index d8ff1664b4..baf1ec4f7d 100644
--- a/gnu/packages/pretty-print.scm
+++ b/gnu/packages/pretty-print.scm
@@ -124,6 +124,49 @@ (define-public a2ps
special cases, such as pretty-printing @samp{-help} output.")
(license gpl3+)))
+(define-public ansifilter
+ (package
+ (name "ansifilter")
+ (version "2.21")
+ (outputs (list "out" "gui"))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.com/saalen/ansifilter")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0gnxf0mnb8pfgpx2324gbwyz7dh4xh5jvnigg768rs7dh329w48l"))))
+ (build-system gnu-build-system)
+ (arguments
+ (list
+ #:tests? #f ;no tests
+ #:phases #~(modify-phases %standard-phases
+ (delete 'configure) ;no configure script
+ (add-after 'build 'build-gui
+ (lambda* (#:key outputs #:allow-other-keys)
+ (invoke "make" "gui")))
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ (invoke "make" "install"
+ (string-append "PREFIX=" out)))))
+ (add-after 'install 'install-gui
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((gui (assoc-ref outputs "gui")))
+ (mkdir-p (string-append gui "/bin"))
+ (invoke "make" "install-gui"
+ (string-append "PREFIX=" gui))))))))
+ (inputs (list qtbase-5))
+ (home-page "http://andre-simon.de/doku/ansifilter/en/ansifilter.html")
+ (synopsis "ANSI sequence filter")
+ (description
+ "Ansifilter handles text files containing ANSI terminal escape codes.
+The command sequences may be stripped or be interpreted to generate formatted
+output (HTML, RTF, TeX, LaTeX, BBCode, Pango).")
+ (license gpl3+)))
+
(define-public trueprint
(package
(name "trueprint")

base-commit: 993d6d2e7be4dac738629c76a51058f4dc5bc449
--
2.45.2
L
L
Ludovic Courtès wrote on 4 Oct 21:40 +0200
(name . Ahmad Draidi)(address . a.r.draidi@redscript.org)(address . 73045@debbugs.gnu.org)
87plofpsgz.fsf@gnu.org
Hi,

Ahmad Draidi <a.r.draidi@redscript.org> skribis:

Toggle quote (4 lines)
> * gnu/packages/pretty-print.scm (ansifilter): New variable.
>
> Change-Id: I12e86080f5f39c52ea1def6084b9a5e6cc7af92c

I get:

r:sha256 hash mismatch for /gnu/store/dshvl4cylvc4cjaxy3s7bqrq06s87nh7-ansifilter-2.21-checkout:
expected hash: 0gnxf0mnb8pfgpx2324gbwyz7dh4xh5jvnigg768rs7dh329w48l
actual hash: 1pvx4l0k8dw642yisf1wahdqcfw36ny6v3v1lcshvxiqxmwrna3d

Could you check?

Apart from that it LGTM.

Thanks,
Ludo’.
A
A
Ahmad Draidi wrote on 5 Oct 06:35 +0200
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 73045@debbugs.gnu.org)
8734lbgoaq.fsf@redscript.org
Hello Ludovic,

Ludovic Courtès <ludo@gnu.org> writes:

Toggle quote (19 lines)
> Hi,
>
> Ahmad Draidi <a.r.draidi@redscript.org> skribis:
>
>> * gnu/packages/pretty-print.scm (ansifilter): New variable.
>>
>> Change-Id: I12e86080f5f39c52ea1def6084b9a5e6cc7af92c
>
> I get:
>
> r:sha256 hash mismatch for
> /gnu/store/dshvl4cylvc4cjaxy3s7bqrq06s87nh7-ansifilter-2.21-checkout:
> expected hash:
> 0gnxf0mnb8pfgpx2324gbwyz7dh4xh5jvnigg768rs7dh329w48l
> actual hash:
> 1pvx4l0k8dw642yisf1wahdqcfw36ny6v3v1lcshvxiqxmwrna3d
>
> Could you check?

This is really weird. Just now I downloaded the mbox from this
issue and did:

git pull
git reset --hard origin/master
git am ~/Downloads/73045-0.mbox

And then inside a guix shell:

./bootstrap && ./configure && ./pre-inst-env make
./pre-inst-env guix build ansifilter --check

And can see it builds successfully.

successfully built
/gnu/store/fjzyi5v42i5z6cdq89g2vhv0d8ipj9ns-ansifilter-2.21.drv

Toggle quote (6 lines)
>
> Apart from that it LGTM.
>
> Thanks,
> Ludo’.

Thanks,
Ahmad
L
L
Ludovic Courtès wrote 4 days ago
(name . Ahmad Draidi)(address . a.r.draidi@redscript.org)(address . 73045@debbugs.gnu.org)
87r08i3olc.fsf@gnu.org
Hi,

Ahmad Draidi <a.r.draidi@redscript.org> skribis:

Toggle quote (28 lines)
> Ludovic Courtès <ludo@gnu.org> writes:
>
>> Hi,
>>
>> Ahmad Draidi <a.r.draidi@redscript.org> skribis:
>>
>>> * gnu/packages/pretty-print.scm (ansifilter): New variable.
>>>
>>> Change-Id: I12e86080f5f39c52ea1def6084b9a5e6cc7af92c
>>
>> I get:
>>
>> r:sha256 hash mismatch for
>> /gnu/store/dshvl4cylvc4cjaxy3s7bqrq06s87nh7-ansifilter-2.21-checkout:
>> expected hash:
>> 0gnxf0mnb8pfgpx2324gbwyz7dh4xh5jvnigg768rs7dh329w48l
>> actual hash:
>> 1pvx4l0k8dw642yisf1wahdqcfw36ny6v3v1lcshvxiqxmwrna3d
>>
>> Could you check?
>
> This is really weird. Just now I downloaded the mbox from this issue
> and did:
>
> git pull
> git reset --hard origin/master
> git am ~/Downloads/73045-0.mbox

Perhaps the source was still in your store though.

What if you run: ./pre-inst-env guix build -S ansifilter --check -K
?

Ludo’.
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 73045@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 73045
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch