[PATCH] gnu: Add micron.

  • Open
  • quality assurance status badge
Details
2 participants
  • Andy Tai
  • Zheng Junjie
Owner
unassigned
Submitted by
Andy Tai
Severity
normal
A
A
Andy Tai wrote on 5 Sep 2024 15:34
(address . guix-patches@gnu.org)(name . Andy Tai)(address . atai@atai.org)
b2ac45983fd6d8597f6550c6f51a031dad869452.1725543223.git.atai@atai.org
* gnu/packages/cron.scm (micron): New variable.

Change-Id: I1bd78df12b5ea7f17104a005659e9034c20403f1
---
gnu/packages/cron.scm | 45 +++++++++++++++++++++++++++++++++++++++++++
1 file changed, 45 insertions(+)
create mode 100644 gnu/packages/cron.scm

Toggle diff (56 lines)
diff --git a/gnu/packages/cron.scm b/gnu/packages/cron.scm
new file mode 100644
index 0000000000..1991ad4b60
--- /dev/null
+++ b/gnu/packages/cron.scm
@@ -0,0 +1,45 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2024 Andy Tai <atai@atai.org>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages cron)
+ #:use-module (guix download)
+ #:use-module ((guix licenses) #:prefix license:)
+ #:use-module (guix packages)
+ #:use-module (guix build-system gnu)
+ #:use-module (gnu packages))
+
+
+(define-public micron
+ (package
+ (name "micron")
+ (version "1.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnu/micron/micron-" version ".tar.gz"))
+ (sha256
+ (base32 "196dfcjijzsnddc9zzkyl0z22p4xkz9nl3jbdaxrikv0b8pncvh3"))))
+ (build-system gnu-build-system)
+ (home-page "https://www.gnu.org/software/micron/")
+ (synopsis "Implementation of the UNIX cron daemon")
+ (description
+ "GNU Micron is an implementation of the UNIX cron daemon, a program that
+executes periodically various tasks. It provides a flexible job scheduler, which
+offers complete control over the execution of the scheduled commands and contains
+additional organizational features.")
+ (license license:gpl3+)))
\ No newline at end of file

base-commit: 993d6d2e7be4dac738629c76a51058f4dc5bc449
--
2.34.1
A
A
Andy Tai wrote on 25 Sep 2024 04:30
[PATCH v2] gnu: Add micron.
(address . 73040@debbugs.gnu.org)(name . Andy Tai)(address . atai@atai.org)
d5079463d66c1025b48e2eca4ab6c7755a405420.1727231388.git.atai@atai.org
* gnu/packages/cron.scm (micron): New variable.

Change-Id: I1bd78df12b5ea7f17104a005659e9034c20403f1
---
gnu/packages/cron.scm | 45 +++++++++++++++++++++++++++++++++++++++++++
1 file changed, 45 insertions(+)
create mode 100644 gnu/packages/cron.scm

Toggle diff (56 lines)
diff --git a/gnu/packages/cron.scm b/gnu/packages/cron.scm
new file mode 100644
index 0000000000..1991ad4b60
--- /dev/null
+++ b/gnu/packages/cron.scm
@@ -0,0 +1,45 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2024 Andy Tai <atai@atai.org>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages cron)
+ #:use-module (guix download)
+ #:use-module ((guix licenses) #:prefix license:)
+ #:use-module (guix packages)
+ #:use-module (guix build-system gnu)
+ #:use-module (gnu packages))
+
+
+(define-public micron
+ (package
+ (name "micron")
+ (version "1.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnu/micron/micron-" version ".tar.gz"))
+ (sha256
+ (base32 "196dfcjijzsnddc9zzkyl0z22p4xkz9nl3jbdaxrikv0b8pncvh3"))))
+ (build-system gnu-build-system)
+ (home-page "https://www.gnu.org/software/micron/")
+ (synopsis "Implementation of the UNIX cron daemon")
+ (description
+ "GNU Micron is an implementation of the UNIX cron daemon, a program that
+executes periodically various tasks. It provides a flexible job scheduler, which
+offers complete control over the execution of the scheduled commands and contains
+additional organizational features.")
+ (license license:gpl3+)))
\ No newline at end of file

base-commit: 3ac69c1a757430d6dfdd37eb948ba1d6967967cc
--
2.34.1
A
A
Andy Tai wrote on 21 Oct 2024 00:27
[PATCH v3] gnu: Add micron.
(address . 73040@debbugs.gnu.org)(name . Andy Tai)(address . atai@atai.org)
e237f2bb5b88d95538f519f9cff468b2eb98e546.1729463236.git.atai@atai.org
* gnu/packages/cron.scm (micron): New variable.

Change-Id: I1bd78df12b5ea7f17104a005659e9034c20403f1
---
gnu/packages/cron.scm | 45 +++++++++++++++++++++++++++++++++++++++++++
1 file changed, 45 insertions(+)
create mode 100644 gnu/packages/cron.scm

Toggle diff (56 lines)
diff --git a/gnu/packages/cron.scm b/gnu/packages/cron.scm
new file mode 100644
index 0000000000..1991ad4b60
--- /dev/null
+++ b/gnu/packages/cron.scm
@@ -0,0 +1,45 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2024 Andy Tai <atai@atai.org>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages cron)
+ #:use-module (guix download)
+ #:use-module ((guix licenses) #:prefix license:)
+ #:use-module (guix packages)
+ #:use-module (guix build-system gnu)
+ #:use-module (gnu packages))
+
+
+(define-public micron
+ (package
+ (name "micron")
+ (version "1.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnu/micron/micron-" version ".tar.gz"))
+ (sha256
+ (base32 "196dfcjijzsnddc9zzkyl0z22p4xkz9nl3jbdaxrikv0b8pncvh3"))))
+ (build-system gnu-build-system)
+ (home-page "https://www.gnu.org/software/micron/")
+ (synopsis "Implementation of the UNIX cron daemon")
+ (description
+ "GNU Micron is an implementation of the UNIX cron daemon, a program that
+executes periodically various tasks. It provides a flexible job scheduler, which
+offers complete control over the execution of the scheduled commands and contains
+additional organizational features.")
+ (license license:gpl3+)))
\ No newline at end of file

base-commit: 92910f5413fd9112c0502138eed5fff758c5de65
--
2.34.1
A
A
Andy Tai wrote on 28 Nov 2024 08:16
[PATCH v4] gnu: Add micron.
(address . 73040@debbugs.gnu.org)(name . Andy Tai)(address . atai@atai.org)
d6b4c818bc0a0d8674d07f010ff1707ccc4311fb.1732778145.git.atai@atai.org
* gnu/packages/cron.scm (micron): New variable.

Change-Id: I1bd78df12b5ea7f17104a005659e9034c20403f1
---
gnu/packages/cron.scm | 45 +++++++++++++++++++++++++++++++++++++++++++
1 file changed, 45 insertions(+)
create mode 100644 gnu/packages/cron.scm

Toggle diff (56 lines)
diff --git a/gnu/packages/cron.scm b/gnu/packages/cron.scm
new file mode 100644
index 0000000000..1991ad4b60
--- /dev/null
+++ b/gnu/packages/cron.scm
@@ -0,0 +1,45 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2024 Andy Tai <atai@atai.org>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages cron)
+ #:use-module (guix download)
+ #:use-module ((guix licenses) #:prefix license:)
+ #:use-module (guix packages)
+ #:use-module (guix build-system gnu)
+ #:use-module (gnu packages))
+
+
+(define-public micron
+ (package
+ (name "micron")
+ (version "1.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnu/micron/micron-" version ".tar.gz"))
+ (sha256
+ (base32 "196dfcjijzsnddc9zzkyl0z22p4xkz9nl3jbdaxrikv0b8pncvh3"))))
+ (build-system gnu-build-system)
+ (home-page "https://www.gnu.org/software/micron/")
+ (synopsis "Implementation of the UNIX cron daemon")
+ (description
+ "GNU Micron is an implementation of the UNIX cron daemon, a program that
+executes periodically various tasks. It provides a flexible job scheduler, which
+offers complete control over the execution of the scheduled commands and contains
+additional organizational features.")
+ (license license:gpl3+)))
\ No newline at end of file

base-commit: ce877a777e6ec089dc347e9883387d3080b471cf
--
2.34.1
Z
Z
Zheng Junjie wrote on 28 Nov 2024 09:44
(name . Andy Tai)(address . atai@atai.org)(address . 73040@debbugs.gnu.org)
87frnbsq7e.fsf@iscas.ac.cn
Andy Tai <atai@atai.org> writes:

Toggle quote (63 lines)
> * gnu/packages/cron.scm (micron): New variable.
>
> Change-Id: I1bd78df12b5ea7f17104a005659e9034c20403f1
> ---
> gnu/packages/cron.scm | 45 +++++++++++++++++++++++++++++++++++++++++++
> 1 file changed, 45 insertions(+)
> create mode 100644 gnu/packages/cron.scm
>
> diff --git a/gnu/packages/cron.scm b/gnu/packages/cron.scm
> new file mode 100644
> index 0000000000..1991ad4b60
> --- /dev/null
> +++ b/gnu/packages/cron.scm
> @@ -0,0 +1,45 @@
> +;;; GNU Guix --- Functional package management for GNU
> +;;; Copyright © 2024 Andy Tai <atai@atai.org>
> +;;;
> +;;; This file is part of GNU Guix.
> +;;;
> +;;; GNU Guix is free software; you can redistribute it and/or modify it
> +;;; under the terms of the GNU General Public License as published by
> +;;; the Free Software Foundation; either version 3 of the License, or (at
> +;;; your option) any later version.
> +;;;
> +;;; GNU Guix is distributed in the hope that it will be useful, but
> +;;; WITHOUT ANY WARRANTY; without even the implied warranty of
> +;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
> +;;; GNU General Public License for more details.
> +;;;
> +;;; You should have received a copy of the GNU General Public License
> +;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
> +
> +(define-module (gnu packages cron)
> + #:use-module (guix download)
> + #:use-module ((guix licenses) #:prefix license:)
> + #:use-module (guix packages)
> + #:use-module (guix build-system gnu)
> + #:use-module (gnu packages))
> +
> +
> +(define-public micron
> + (package
> + (name "micron")
> + (version "1.4")
> + (source
> + (origin
> + (method url-fetch)
> + (uri (string-append "mirror://gnu/micron/micron-" version ".tar.gz"))
> + (sha256
> + (base32 "196dfcjijzsnddc9zzkyl0z22p4xkz9nl3jbdaxrikv0b8pncvh3"))))
> + (build-system gnu-build-system)
> + (home-page "https://www.gnu.org/software/micron/")
> + (synopsis "Implementation of the UNIX cron daemon")
> + (description
> + "GNU Micron is an implementation of the UNIX cron daemon, a program that
> +executes periodically various tasks. It provides a flexible job scheduler, which
> +offers complete control over the execution of the scheduled commands and contains
> +additional organizational features.")
> + (license license:gpl3+)))
> \ No newline at end of file
>
> base-commit: ce877a777e6ec089dc347e9883387d3080b471cf

I don't believe this package requires a separate file. However, if there
are other cron packages to be added later, let's disregard this message.

and then please add gnu/packages/cron.scm to gnu/local.mk
(GNU_SYSTEM_MODULES).
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEfr6klGDOXiwIdX/bO1qpk+Gi3/AFAmdILVUACgkQO1qpk+Gi
3/C6Vg//alQKybbip+FeafBvKWF2VORwcFs9SR/Xw4cOWLmu0DHDDV6cJezohrrW
Q/ByXI/OJ6L5nJ4Klc5GD+yG7rvohTDXAeAFdGBSn8V36YS1TxkR8l69c2U4Ij0a
gQ8UTeh3wv+gMXtISPSrBwLK+Fs01bbG9DN3oVLXw5qxmk5vb8PGnKeEOn1FBNFn
xYaZHNq0rDJuziwEopB5+pUxragccMnMtqo+xVDAmoAbzAZJhsM7ccQGADVM0Fw/
GpxoCUjNzFjJt3cjnPgS40JufAy1y/BBAe6yfHwZBJOkC40PT+J+WpxOLDPkIYi9
C0y9uHQYT9vets2ad38O92glzEjP7hBgfz7j8xUBSjgLnhGJ+AeMmxLgepI7vyVk
Lu/IqG3Dqoqkoxsb3D6NXsEViwxnmGQMJBLx05Yj4la2z4pimO/Ext+7698Acab6
Y10KH5U5Tgz2rYBzC/Bfvo5ZLsa1ToVIuw2bssR4lQ1Uf6eq9gIOaGh9mq2UUGtR
QFq8+cMRKqBh8jAAnYtu0rbm5JtIu9jUmvRC6YJifAXDuDE4GmSfMBD/Umnm+pMX
DczFggBPNrjYk2ITTY3Wn0NTXjJzkY/WqcdjtTirYxF0zJW9FBNRffMNzFZKKN3j
KeVPT2eHhz7f6fizwAnmn6KdYpKSJVmCB796pQWD40HSaqpwu9E=
=ipxi
-----END PGP SIGNATURE-----

?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 73040@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 73040
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch