[PATCH] gnu: Add r-pairwiseadonis.

  • Done
  • quality assurance status badge
Details
2 participants
  • Andreas Enge
  • Mădălin Ionel Patrașcu
Owner
unassigned
Submitted by
Mădălin Ionel Patrașcu
Severity
normal

Debbugs page

Mădălin Ionel Patrașcu wrote 6 months ago
(address . guix-patches@gnu.org)
c3895546de04902d8ea4379f2e07943479fde420.1725449860.git.madalinionel.patrascu@mdc-berlin.de
* gnu/packages/bioinformatics.scm (r-pairwiseadonis): New variable.

Change-Id: Idf7ad9efa3625bb60663f421ec79d0a69170e4dd
---
gnu/packages/bioinformatics.scm | 50 ++++++++++++++++++++++++++++++++-
1 file changed, 49 insertions(+), 1 deletion(-)

Toggle diff (72 lines)
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 4653360792..0206ebe1a3 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -11,7 +11,7 @@
;;; Copyright © 2017, 2021, 2022, 2024 Arun Isaac <arunisaac@systemreboot.net>
;;; Copyright © 2018 Joshua Sierles, Nextjournal <joshua@nextjournal.com>
;;; Copyright © 2018 Gábor Boskovits <boskovits@gmail.com>
-;;; Copyright © 2018-2023 Mădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de>
+;;; Copyright © 2018-2024 Mădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de>
;;; Copyright © 2019, 2020, 2021, 2023 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2019 Brian Leung <bkleung89@gmail.com>
;;; Copyright © 2019 Brett Gilio <brettg@gnu.org>
@@ -13155,6 +13155,54 @@ (define-public r-pairadise
(propagated-inputs (list r-doparallel r-foreach r-iterators r-nloptr))
(license license:expat)))
+(define-public r-pairwiseadonis
+ ;; There is no tag for version 0.4.1, nor is there a release archive.
+ (let ((commit "cb190f7668a0c82c0b0853927db239e7b9ec3e83")
+ (revision "1"))
+ (package
+ (name "r-pairwiseadonis")
+ ;; The versioning scheme of this package is inconsistent, with versions
+ ;; progressing from 0.21 to 0.3 and then to 0.4.1, which does not follow
+ ;; a standard numerical order or convention (e.g., semantic versioning).
+ (version (git-version "0.4.1" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/pmartinezarbizu/pairwiseAdonis")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "11hl6qqmr5vns476921802y0qmb46i1jf0rf7xfkyswlh6xkcl99"))))
+ (properties `((upstream-name . "pairwiseAdonis")))
+ (build-system r-build-system)
+ (arguments
+ (list
+ #:phases
+ ;; Move into the subdirectory containing the R package files
+ '(modify-phases %standard-phases
+ (add-after 'unpack 'move-to-subdir
+ (lambda _ (chdir "pairwiseAdonis"))))))
+ (propagated-inputs
+ (list r-cluster
+ r-permute
+ r-vegan))
+ (synopsis "Pairwise multilevel comparison using adonis")
+ (description
+ "This package implements two functions:
+@itemize
+@item @code{pairwise.adonis} is a wrapper function for multilevel pairwise
+comparison using adonis2 from package vegan. The function returns adjusted
+p-values using @code{p.adjust()}. It does not accept interaction between factors
+neither strata.
+@item @code{pairwise.adonis2} accepts a model formula like in adonis from vegan.
+You can use interactions between factors and define strata to constrain
+permutations. For pairwise comparison a list of unique pairwise combination of
+factors is produced.
+@end itemize")
+ (home-page "https://github.com/pmartinezarbizu/pairwiseAdonis")
+ (license license:gpl2+))))
+
(define-public pardre
(package
(name "pardre")

base-commit: 7fa9df431e9423e2b79c8c520de1d0ef7aed910d
--
2.45.2
Andreas Enge wrote 6 months ago
Close
(address . 73025-done@debbugs.gnu.org)(address . 73017-done@debbugs.gnu.org)
Zu51VnQcR68KV1I2@jurong
Pushed, thanks!

Andreas
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 73025@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 73025
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help