[PATCH] gnu: Add fontopia.

  • Done
  • quality assurance status badge
Details
2 participants
  • Andy Tai
  • Zheng Junjie
Owner
unassigned
Submitted by
Andy Tai
Severity
normal
A
A
Andy Tai wrote on 4 Sep 09:26 +0200
(address . guix-patches@gnu.org)(name . Andy Tai)(address . atai@atai.org)
2ada61579bb1e1de815a091543ff9ee204cdc7b0.1725434752.git.atai@atai.org
* gnu/packages/fontutils.scm (fontopia): New variable.

Change-Id: I8f9b51922af06f994955b755ec8345d42189cfd7
---
gnu/packages/fontutils.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)

Toggle diff (47 lines)
diff --git a/gnu/packages/fontutils.scm b/gnu/packages/fontutils.scm
index 00fb9c33ee..de2e45c91b 100644
--- a/gnu/packages/fontutils.scm
+++ b/gnu/packages/fontutils.scm
@@ -62,6 +62,7 @@ (define-module (gnu packages fontutils)
#:use-module (gnu packages java)
#:use-module (gnu packages linux)
#:use-module (gnu packages man)
+ #:use-module (gnu packages mc)
#:use-module (gnu packages ninja)
#:use-module (gnu packages perl)
#:use-module (gnu packages pkg-config)
@@ -2056,6 +2057,29 @@ (define-public libraqm
can support most writing systems covered by Unicode.")
(license license:expat)))
+
+(define-public fontopia
+ (package
+ (name "fontopia")
+ (version "2.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnu/fontopia/fontopia-"
+ version ".tar.gz"))
+ (sha256
+ (base32 "0wv7bd7gdm1ma4xgq9av73ic3xhpwyszj6g6c6311xjk26xm9ahd"))))
+ (build-system gnu-build-system)
+ (inputs
+ (list gnudos))
+ (home-page "https://www.gnu.org/software/fontopia/")
+ (synopsis "Text-based, console font editor")
+ (description
+ "GNU fontopia is an easy-to-use, text-based, console font editor. You can
+edit the fonts that your GNU/Linux kernel is using to display your text on text-
+based (vs graphical) terminals. ")
+ (license license:gpl3+)))
+
+
(define-public lcdf-typetools
(package
(name "lcdf-typetools")

base-commit: 7fa9df431e9423e2b79c8c520de1d0ef7aed910d
prerequisite-patch-id: 6084d080fcb60fcbb2063ddf60036b4753c5dee3
--
2.34.1
A
A
Andy Tai wrote on 4 Sep 11:03 +0200
[PATCH v2] gnu: Add fontopia.
(address . 73024@debbugs.gnu.org)(name . Andy Tai)(address . atai@atai.org)
be6552bd04f02b4b7bd2d923a0483ad137af4d7f.1725440552.git.atai@atai.org
* gnu/packages/fontutils.scm (fontopia): New variable.

Change-Id: I8f9b51922af06f994955b755ec8345d42189cfd7
---
gnu/packages/fontutils.scm | 26 ++++++++++++++++++++++++++
1 file changed, 26 insertions(+)

Toggle diff (49 lines)
diff --git a/gnu/packages/fontutils.scm b/gnu/packages/fontutils.scm
index 00fb9c33ee..3a7bfa1aa0 100644
--- a/gnu/packages/fontutils.scm
+++ b/gnu/packages/fontutils.scm
@@ -62,6 +62,7 @@ (define-module (gnu packages fontutils)
#:use-module (gnu packages java)
#:use-module (gnu packages linux)
#:use-module (gnu packages man)
+ #:use-module (gnu packages mc)
#:use-module (gnu packages ninja)
#:use-module (gnu packages perl)
#:use-module (gnu packages pkg-config)
@@ -2056,6 +2057,31 @@ (define-public libraqm
can support most writing systems covered by Unicode.")
(license license:expat)))
+
+(define-public fontopia
+ (package
+ (name "fontopia")
+ (version "2.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnu/fontopia/fontopia-" version ".tar.gz"))
+ (sha256
+ (base32 "0wv7bd7gdm1ma4xgq9av73ic3xhpwyszj6g6c6311xjk26xm9ahd"))))
+ (build-system gnu-build-system)
+ (inputs (list gnudos))
+ (home-page "https://www.gnu.org/software/fontopia/")
+ (synopsis "A console font editor")
+ (description
+ "GNU Fontopia is an easy-to-use, text-based, console font editor. It's used
+to edit the fonts that GNU/Linux uses to display text on text-based
+terminals. Fontopia works on both PSF 1 & 2, BDF, Code Paged (CP) fonts, and
+Raw font files. It provides a user-friendly, easy-to-use glyph editor and it
+can easily change font metrics (e.g. length, width, and height) and convert
+between different font formats.")
+ (license license:gpl3+)))
+
+
(define-public lcdf-typetools
(package
(name "lcdf-typetools")

base-commit: 7fa9df431e9423e2b79c8c520de1d0ef7aed910d
prerequisite-patch-id: 6084d080fcb60fcbb2063ddf60036b4753c5dee3
--
2.34.1
A
A
Andy Tai wrote on 25 Sep 04:31 +0200
(address . 73024@debbugs.gnu.org)(name . Andy Tai)(address . atai@atai.org)
f7cd40a1bad17d03efa517b836987d4d8029e221.1727231483.git.atai@atai.org
* gnu/packages/fontutils.scm (fontopia): New variable.

Change-Id: I8f9b51922af06f994955b755ec8345d42189cfd7
---
gnu/packages/fontutils.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)

Toggle diff (46 lines)
diff --git a/gnu/packages/fontutils.scm b/gnu/packages/fontutils.scm
index 3b6d4900f6..0ca2b0ea2e 100644
--- a/gnu/packages/fontutils.scm
+++ b/gnu/packages/fontutils.scm
@@ -62,6 +62,7 @@ (define-module (gnu packages fontutils)
#:use-module (gnu packages java)
#:use-module (gnu packages linux)
#:use-module (gnu packages man)
+ #:use-module (gnu packages mc)
#:use-module (gnu packages ninja)
#:use-module (gnu packages perl)
#:use-module (gnu packages pkg-config)
@@ -2056,6 +2057,29 @@ (define-public libraqm
can support most writing systems covered by Unicode.")
(license license:expat)))
+
+(define-public fontopia
+ (package
+ (name "fontopia")
+ (version "2.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnu/fontopia/fontopia-"
+ version ".tar.gz"))
+ (sha256
+ (base32 "0wv7bd7gdm1ma4xgq9av73ic3xhpwyszj6g6c6311xjk26xm9ahd"))))
+ (build-system gnu-build-system)
+ (inputs
+ (list gnudos))
+ (home-page "https://www.gnu.org/software/fontopia/")
+ (synopsis "Text-based, console font editor")
+ (description
+ "GNU fontopia is an easy-to-use, text-based, console font editor. You can
+edit the fonts that your GNU/Linux kernel is using to display your text on text-
+based (vs graphical) terminals. ")
+ (license license:gpl3+)))
+
+
(define-public lcdf-typetools
(package
(name "lcdf-typetools")

base-commit: 3ac69c1a757430d6dfdd37eb948ba1d6967967cc
--
2.34.1
Z
Z
Zheng Junjie wrote on 3 Oct 12:37 +0200
(name . Andy Tai)(address . atai@atai.org)(address . 73024-done@debbugs.gnu.org)
87o741h3qa.fsf@iscas.ac.cn
Andy Tai <atai@atai.org> writes:

Toggle quote (52 lines)
> * gnu/packages/fontutils.scm (fontopia): New variable.
>
> Change-Id: I8f9b51922af06f994955b755ec8345d42189cfd7
> ---
> gnu/packages/fontutils.scm | 24 ++++++++++++++++++++++++
> 1 file changed, 24 insertions(+)
>
> diff --git a/gnu/packages/fontutils.scm b/gnu/packages/fontutils.scm
> index 3b6d4900f6..0ca2b0ea2e 100644
> --- a/gnu/packages/fontutils.scm
> +++ b/gnu/packages/fontutils.scm
> @@ -62,6 +62,7 @@ (define-module (gnu packages fontutils)
> #:use-module (gnu packages java)
> #:use-module (gnu packages linux)
> #:use-module (gnu packages man)
> + #:use-module (gnu packages mc)
> #:use-module (gnu packages ninja)
> #:use-module (gnu packages perl)
> #:use-module (gnu packages pkg-config)
> @@ -2056,6 +2057,29 @@ (define-public libraqm
> can support most writing systems covered by Unicode.")
> (license license:expat)))
>
> +
> +(define-public fontopia
> + (package
> + (name "fontopia")
> + (version "2.0")
> + (source (origin
> + (method url-fetch)
> + (uri (string-append "mirror://gnu/fontopia/fontopia-"
> + version ".tar.gz"))
> + (sha256
> + (base32 "0wv7bd7gdm1ma4xgq9av73ic3xhpwyszj6g6c6311xjk26xm9ahd"))))
> + (build-system gnu-build-system)
> + (inputs
> + (list gnudos))
> + (home-page "https://www.gnu.org/software/fontopia/")
> + (synopsis "Text-based, console font editor")
> + (description
> + "GNU fontopia is an easy-to-use, text-based, console font editor. You can
> +edit the fonts that your GNU/Linux kernel is using to display your text on text-
> +based (vs graphical) terminals. ")
> + (license license:gpl3+)))
> +
> +
> (define-public lcdf-typetools
> (package
> (name "lcdf-typetools")
>
> base-commit: 3ac69c1a757430d6dfdd37eb948ba1d6967967cc

push, and fix guix lint's warn.
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEfr6klGDOXiwIdX/bO1qpk+Gi3/AFAmb+c90ACgkQO1qpk+Gi
3/CTpBAAtq2Ql/mcOSq03Al2WYRmZh0e1fCTLJh4WIGqGX/FJUiVoREJyeI7hZYk
2FR3uVQdE7YSwVR0JWKQQ1WO7qNrvEafcp45Ceph1rX144h3CKGkqFQPyo7qO50+
RG4v4jOhlHG9ecpAxTR0i8OkRPPYPywK/HUs0AQaJSrmT4M6TUVR81X0Nwxm/Wtn
6us2QOxEhvhoJOrGGt0/ABYfLMIco5WmqR9fdn3R7Lj9mBftUJbM5mxeDKY/7qV0
+m50RbxEsImhd5pn2uGpcvrFG/3ogQcAhxjwQg91DKKX/0TubAKJidkybu9ubU7l
8WvC9Xut7D8xgMSN788+VheL/1Z3sqr/O+aGNlKfGfljH9ov4fy2ZEVHi0SqPDd8
NCuMU/Mqb++UYvok7BmzMbvkPGBStTtIw+qsp9am9USKkT2JOuF1IsbZE9uO7zcq
i3+RrZALSHvU+sU7A7L7a9h3de0w795oFXq1UE18tp23gY0NJm9omt36P1VeBijg
kbF0Kbo2l/h8s4Sit/QvJN0Mt1hc3ROPRGV3LoPfXX4viOzYEaEyQoIO9H+Zl3P7
eh6AEFpUHAGJRoURZJ0A59l96u5Nzyq+OMTcn0d9e9XSvRCNs/NtxtgjeQ9qMYYP
F6+3dqBflPfZ7gND0BVx8Osc7bPG7952Yu7RxNyt420jWlx83hE=
=XN2Z
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 73024@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 73024
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch