[PATCH] gnu: Add r-dtwclust.

  • Done
  • quality assurance status badge
Details
2 participants
  • Andreas Enge
  • Mădălin Ionel Patrașcu
Owner
unassigned
Submitted by
Mădălin Ionel Patrașcu
Severity
normal

Debbugs page

Mădălin Ionel Patrașcu wrote 6 months ago
(address . guix-patches@gnu.org)
48864048e5aa1ea50e568f62c275b684b3916aaa.1725409842.git.madalinionel.patrascu@mdc-berlin.de
From: =?UTF-8?q?Mădălin Ionel Patrașcu?= <madalinionel.patrascu@mdc-berlin.de>

* gnu/packages/cran.scm (r-dtwclust): New variable.

Change-Id: I411d25b5df8f9bf923e60602901105a612c42fe9
---
gnu/packages/cran.scm | 49 +++++++++++++++++++++++++++++++++++++++++++
1 file changed, 49 insertions(+)

Toggle diff (64 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 4ca23a5c4e..d8a12bfc81 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -10942,6 +10942,55 @@ (define-public r-ips
phylogenies and ancestral character states.")
(license license:gpl3)))
+(define-public r-dtwclust
+ (package
+ (name "r-dtwclust")
+ (version "6.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "dtwclust" version))
+ (sha256
+ (base32 "0by01x4qpf1pin5l61wmm600bmsnlnns9knwb0qmjlj72pmwfkqh"))))
+ (properties `((upstream-name . "dtwclust")))
+ (build-system r-build-system)
+ (propagated-inputs
+ (list r-clue
+ r-cluster
+ r-dplyr
+ r-dtw
+ r-flexclust
+ r-foreach
+ r-ggplot2
+ r-ggrepel
+ r-matrix
+ r-proxy
+ r-rcpp
+ r-rcpparmadillo
+ r-rcppparallel
+ r-rcppthread
+ r-reshape2
+ r-rlang
+ r-rspectra
+ r-shiny
+ r-shinyjs))
+ (native-inputs (list r-knitr))
+ (home-page "https://github.com/asardaes/dtwclust")
+ (synopsis
+ "Clustering time series with dynamic time warping distance optimization")
+ (description
+ "This package implements time series clustering along with optimized
+techniques related to the dynamic time warping distance and its corresponding
+lower bounds. The implementations of partitional, hierarchical, fuzzy, k-Shape
+and TADPole clustering are available. Functionality can be easily extended with
+custom distance measures and centroid definitions. Implementations of @acronym{
+DTW, dynamic time warping} barycenter averaging, a distance based on global
+alignment kernels, and the soft-DTW distance and centroid routines are also
+provided. All included distance functions have custom loops optimized for the
+calculation of cross-distance matrices, including parallelization support.
+Several cluster validity indices are included.")
+ (license license:gpl3)))
+
(define-public r-dtw
(package
(name "r-dtw")

base-commit: 7fa9df431e9423e2b79c8c520de1d0ef7aed910d
--
2.45.2
Andreas Enge wrote 6 months ago
Close
(address . 73025-done@debbugs.gnu.org)(address . 73017-done@debbugs.gnu.org)
Zu51VnQcR68KV1I2@jurong
Pushed, thanks!

Andreas
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 73017@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 73017
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help