Geary Build Failure

  • Done
  • quality assurance status badge
Details
2 participants
  • Guillaume Le Vaillant
  • Juliana Sims
Owner
unassigned
Submitted by
Juliana Sims
Severity
normal
J
J
Juliana Sims wrote on 3 Sep 18:32 +0200
(address . bug-guix@gnu.org)
TMW8JS.SSI76UKX0OL2@incana.org
Hello,

After the recent core update, Geary fails to build. A full build log is
attached. The relevant bit appears to be this:

```
# GLib-DEBUG: g_unix_open_pipe() called with FD_CLOEXEC; please migrate
to using O_CLOEXEC instead
# GLib-DEBUG: g_unix_open_pipe() called with FD_CLOEXEC; please migrate
to using O_CLOEXEC instead
ok 177 /engine/Geary.ImapDb.DatabaseTest/upgrade_0_6
not ok 178
/engine/Geary.ImapDb.DatabaseTest/utf8_case_insensitive_collation
Bail out!
stderr:
Geary.Db-Message: 15:34:23.255: Garbage collection of IMAP database
/tmp/guix-build-geary-44.1.drv-0/geary-imap-db-database-test-6GMHT2/geary-0.6-db/geary.db
failed: Operation was cancelled
Geary.ImapDb.DatabaseTest/utf8_case_insensitive_collation: “á” !=
“BB”
```

The related code in the source tree is at
`test/engine/imap-db-database-test.vala` and specifically the function
`utf8_case_insensitive_collation` which is:

```
public void utf8_case_insensitive_collation() throws GLib.Error {
Database db = new Database(
this.tmp_dir.get_child("test.db"),
GLib.File.new_for_path(_SOURCE_ROOT_DIR).get_child("sql"),
this.tmp_dir.get_child("attachments"),
new
Geary.SimpleProgressMonitor(Geary.ProgressType.DB_UPGRADE),
new
Geary.SimpleProgressMonitor(Geary.ProgressType.DB_VACUUM)
);

db.open.begin(
Geary.Db.DatabaseFlags.CREATE_FILE, null,
this.async_completion
);
db.open.end(async_result());

db.exec("""
CREATE TABLE Test (id INTEGER PRIMARY KEY, test_str TEXT);
INSERT INTO Test (test_str) VALUES ('a');
INSERT INTO Test (test_str) VALUES ('b');
INSERT INTO Test (test_str) VALUES ('B');
INSERT INTO Test (test_str) VALUES ('BB');
INSERT INTO Test (test_str) VALUES ('á');
""");

string[] expected = { "BB", "B", "b", "á", "a" };
Db.Result result = db.query(
"SELECT test_str FROM Test ORDER BY test_str COLLATE
UTF8COLL DESC"
);

int i = 0;
while (!result.finished) {
assert_true(i < expected.length, "Too many rows");
assert_equal(result.string_at(0), expected[i]);
i++;
result.next();
}
assert_true(i == expected.length, "Not enough rows");

// Need to close it again to stop the GC process running
db.close();
}

```

Best,
Juli
G
G
Guillaume Le Vaillant wrote on 3 Sep 20:56 +0200
(name . Juliana Sims)(address . juli@incana.org)(address . 73007-close@debbugs.gnu.org)
87ed60r2gp.fsf@kitej
Fixed in 56d9745d81ea2d0464ed94fc9b3ba0205619835e.
Thanks for the report.
-----BEGIN PGP SIGNATURE-----

iIUEAREKAC0WIQTLxZxm7Ce5cXlAaz5r6CCK3yH+PwUCZtdbxg8cZ2x2QHBvc3Rl
by5uZXQACgkQa+ggit8h/j+wDQD9F4JN8zOZDA4IJ70u6MWVG5jmjV7lEyaWWo7I
hMKFo2oA/3dneJol9VXWv5wgNpZpCYzDa8jUUWSDKwcMvQc4dDa5
=QpMQ
-----END PGP SIGNATURE-----

?
Your comment

This issue is archived.

To comment on this conversation send an email to 73007@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 73007
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch