PHP not building

  • Done
  • quality assurance status badge
Details
2 participants
  • Andreas Enge
  • Rutherther
Owner
unassigned
Submitted by
Andreas Enge
Severity
normal

Debbugs page

Andreas Enge wrote 6 months ago
(address . bug-guix@gnu.org)
ZtW_lDDWX_Yf-2wB@jurong
Hello,

after the core-updates merge, I noticed that php does not build any more.
I thought that maybe commit adfb0be57fd036dded0225a3ff1eb13f6646ee00, which
had updated the version from 8.3.9 to 8.3.10, was to be blamed; has his
gone through QA?

In any case, reverting the commit does not help. So maybe it is a problem
between the former core-updates and master.

The first problem is that gd requires to add fontconfig, freetype and
libjpeg through the Requires.private field of its pkg-config file.

After doing this, one of the tests fails:
=====================================================================
FAILED TEST SUMMARY
---------------------------------------------------------------------
Bug #79676 (imagescale adds black border with IMG_BICUBIC) [ext/gd/tests/bug79676.phpt]
imagegetinterpolation() and imagesetinterpolation() basic test [ext/gd/tests/imageinterpolation_basic.phpt]
Scale images and preserve aspect ratio [ext/gd/tests/imagescale_preserve_ratio.phpt]
=====================================================================

Andreas
Andreas Enge wrote 6 months ago
(name . Rutherther)(address . rutherther@protonmail.com)(address . 72967-done@debbugs.gnu.org)
ZtYHM9lZsSRLKCcU@jurong
Hello Rutherther,

Am Mon, Sep 02, 2024 at 05:00:25PM +0000 schrieb Rutherther:
Toggle quote (3 lines)
> the main problem is a removed patch inside of core-updates.
> See this issue #

ah indeed, I should have checked first whether the problem was already
reported! As there are already several issues and mine does not contribute
anything new, I will not merge it, but simply close it.

Thanks for bringing this to my attention!

Andreas
Closed
Rutherther wrote 6 months ago
(address . 72967@debbugs.gnu.org)(name . Andreas Enge)(address . andreas@enge.fr)
87r0a2m1nd.fsf@protonmail.com
Hello Andreas,

the main problem is a removed patch inside of core-updates.
See this issue #

A separate problem is that three tests, related to gd,
are not passing.

As a temporary workaround, you can use the attached code to obtain a
buildable php.

Regards,
Rutherther

---
(use-modules
(guix packages)
(gnu packages gd)
(gnu packages php))

(define gd-fixed
(package/inherit gd
(name "gd-fixed")
(propagated-inputs
(package-inputs gd))))

(define php
(package/inherit php
(inputs (modify-inputs (package-inputs php)
(replace "gd" gd-fixed)))))

php
Rutherther wrote 6 months ago
(address . 72967@debbugs.gnu.org)(name . Andreas Enge)(address . andreas@enge.fr)
87ed62at21.fsf@protonmail.com
I am sorry, I forgot to put in the number of the issue, here it is #72943
?
Your comment

This issue is archived.

To comment on this conversation send an email to 72967@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 72967
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help