[PATCH] gnu: linux-libre: Add ‘linux-libre-arm64-honeycomb’.

  • Open
  • quality assurance status badge
Details
3 participants
  • Ludovic Courtès
  • Christopher Baines
  • Wilko Meyer
Owner
unassigned
Submitted by
Ludovic Courtès
Severity
normal
L
L
Ludovic Courtès wrote on 2 Sep 14:11 +0200
[PATCH] gnu: linux-libre: Add ‘linux-libr e-arm64-honeycomb’.
(address . guix-patches@gnu.org)(name . Ludovic Courtès)(address . ludo@gnu.org)
d58012c0ae34e5f642f60fbf25df6c613787d361.1725273008.git.ludo@gnu.org
Package definition taken from guix/maintenance.git commit
0dc194cc85f8f0ef8cfcde29b9610ade7138beff, written by
Ricardo Wurmus <rekado@elephly.net>.

* gnu/packages/linux.scm (linux-libre-arm64-honeycomb): New variable.

Change-Id: Ieb8503424a19c1c32a3ecac829c3d5d2a47b458e
---
gnu/packages/linux.scm | 60 ++++++++++++++++++++++++++++++++++++++++++
1 file changed, 60 insertions(+)

Hello,

This definition comes from the (sysadmin honeycomb) module in
maintenance.git. I’m moving it here for convenience so that it gets
built by CI and we don’t have to build it on demand when deploying
Guix System on the Honeycombs.

Ludo’.

Toggle diff (75 lines)
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 318c6ccf13..f583ae0b7a 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -1371,6 +1371,66 @@ (define-public linux-libre-arm64-generic-5.4
("CONFIG_RTC_DRV_RK808" . #t))
(default-extra-linux-options linux-libre-5.4-version))))
+(define-public linux-libre-arm64-honeycomb
+ ;; Kernel for use on the HoneyComb LX2 boards:
+ ;; <https://shop.solid-run.com/product/SRCFTXE000IV13/>.
+ (make-linux-libre* linux-libre-5.15-version
+ linux-libre-5.15-gnu-revision
+ linux-libre-5.15-source
+ '("aarch64-linux")
+ #:extra-version "arm64-honeycomb"
+ #:extra-options
+ ;; See
+ ;; https://github.com/SolidRun/lx2160a_build/blob/master/configs/linux/lx2k_additions.config
+ (append
+ `(("CONFIG_GPIO_SYSFS" . #true)
+ ("CONFIG_GPIO_MPC8XXX" . #true)
+ ("CONFIG_NET_PKTGEN" . #true)
+ ("CONFIG_USB_SERIAL" . #true)
+ ("CONFIG_USB_SERIAL_CONSOLE" . #true)
+ ("CONFIG_USB_SERIAL_GENERIC" . #true)
+ ("CONFIG_USB_SERIAL_SIMPLE" . #true)
+ ("CONFIG_USB_SERIAL_FTDI_SIO" . #true)
+ ("CONFIG_USB_ACM" . #true)
+ ("CONFIG_USB_NET_DRIVERS" . #true)
+ ("CONFIG_USB_USBNET" . #true)
+ ("CONFIG_USB_NET_CDCETHER" . #true)
+ ("CONFIG_USB_NET_CDC_NCM" . #true)
+ ("CONFIG_USB_NET_NET1080" . #true)
+ ("CONFIG_USB_NET_CDC_SUBSET_ENABLE" . #true)
+ ("CONFIG_USB_NET_CDC_SUBSET" . #true)
+ ("CONFIG_USB_ARMLINUX" . #true)
+ ("CONFIG_BLK_DEV_NVME" . #true)
+ ("CONFIG_NVMEM_BCM_OCOTP" . #true)
+ ("CONFIG_DRM_AMDGPU" . #true)
+ ("CONFIG_DRM_AMDGPU_SI" . #true)
+ ("CONFIG_DRM_AMDGPU_CIK" . #true)
+ ("CONFIG_DRM_AMDGPU_USERPTR" . #true)
+ ("CONFIG_DRM_AMD_DC" . #true)
+ ("CONFIG_CHASH" . #true)
+ ("CONFIG_PMBUS" . #true)
+ ("CONFIG_SENSORS_PMBUS" . #true)
+ ("CONFIG_REGULATOR" . #true)
+ ("CONFIG_REGULATOR_FIXED_VOLTAGE" . #true)
+ ("CONFIG_REGULATOR_PWM" . #true)
+ ("CONFIG_SENSORS_AMC6821" . #true)
+ ("CONFIG_SENSORS_LM90" . #true)
+ ("CONFIG_SENSORS_LTC2978" . #true)
+ ("CONFIG_SENSORS_LTC2978_REGULATOR" . #true)
+ ("CONFIG_TMPFS" . #true)
+ ("CONFIG_TMPFS_POSIX_ACL" . #true)
+ ("CONFIG_TMPFS_XATTR" . #true)
+ ;;("CONFIG_BLK_DEV_RAM_SIZE" . 524288)
+ ("CONFIG_POWER_RESET_GPIO" . #true)
+ ("CONFIG_CRYPTO_USER_API_HASH" . #true)
+ ("CONFIG_CRYPTO_USER_API_SKCIPHER" . #true)
+ ("CONFIG_CRYPTO_USER_API_RNG" . #true)
+ ("CONFIG_CRYPTO_USER_API_AEAD" . #true)
+
+ ;; For connecting to ci.guix.gnu.org over VPN.
+ ("CONFIG_WIREGUARD" . m))
+ (default-extra-linux-options linux-libre-5.15-version))))
+
(define-public linux-libre-riscv64-generic
(make-linux-libre* linux-libre-version
linux-libre-gnu-revision

base-commit: 3c21d0da62b3d6832dd1ab450d8ab50ab8d38f27
--
2.45.2
C
C
Christopher Baines wrote on 21 Sep 11:41 +0200
Re: [bug#72964] [PATCH] gnu: linux-libre: Add ‘linux-libre-arm64-honeycomb’.
(name . Ludovic Courtès)(address . ludo@gnu.org)
87ikup8ht9.fsf@cbaines.net
Ludovic Courtès <ludo@gnu.org> writes:

Toggle quote (4 lines)
> Package definition taken from guix/maintenance.git commit
> 0dc194cc85f8f0ef8cfcde29b9610ade7138beff, written by
> Ricardo Wurmus <rekado@elephly.net>.

I don't think that's the right commit? I think originally I hacked this
together for hatysa and it was posted to guix-sysadmin on 02/07/21 in
the "Re: what to buy for Honeycomb LX2 boards?" thread.

Is it possible to enable some of these modules in the regular kernel
packages?
-----BEGIN PGP SIGNATURE-----

iQKlBAEBCgCPFiEEPonu50WOcg2XVOCyXiijOwuE9XcFAmbulNJfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcRHG1haWxAY2Jh
aW5lcy5uZXQACgkQXiijOwuE9Xfuwg//cSiX8Zvu4Z2wGRwYMby+kOBPEFu9BGAJ
eI9QZ4ImgdK0prwIKc4TaGZSf9J6aktTSxOqzWo+YQvYQ3iC+mYE5zb0NDbt6tTN
Hh2K5uX5XQHajzgQxGkH51KpiDiC/rD/IV2ieyjqUhI39maY+e2OCSemqHkRMVN0
NCedA4j4htVCRGva1ccThhMB1rNdTjH3m/CHvO462bGjmCC4JB9KER8epbyQPknR
vBbh4EOGdVWLtxhb9FEiPlt8vyAQUt80bNgGcDAFwNkDE6hXwbxtnUI8WJOrtInZ
tnJK+EgeWee8kgnZn5OcR+0ag9N5LeUQI08/wzHz7gqFuuIg8ZmyxBlusVVwHgkC
gv3DX+o0HUeCERU+NTdv8JBxoUY0MTjEBmqoyO3AyDXD/E7ohU+hvVaBsx1baQ59
VdK/rl1iyj30j9FabqOX+7CI38GQJqUfNTNuaTOUq+2HBg9uwsFD09yuoXbxe4Ua
xP5agc9xkImT3A8I7SQ/x7szC9WgTjt5i7693ZHVEY8x7lVhP+YSzUAgI6F+LnOz
d9BZBK4Xz1SCN8nf7RkE6V24VjhcYbWmcDUi41tDg/YzGYYwlJicX8RUawmfglsb
hVvINYWJzSMqsiN8FHGhIYmVIu0VNVlmhz46b2zSyiY0jMaVfs3UfSv1LH+1HeMw
Y1VHfJEq4Hk=
=115W
-----END PGP SIGNATURE-----

W
W
Wilko Meyer wrote on 27 Sep 16:13 +0200
(name . Christopher Baines)(address . mail@cbaines.net)
875xqhkww1.fsf@wmeyer.eu
Christopher Baines <mail@cbaines.net> writes:
Toggle quote (3 lines)
> Is it possible to enable some of these modules in the regular kernel
> packages?

Definitely, I'll have a look into that and see that we enable as much as
possible in the default config we ship; I think enabling as much
hardware support as we can out of the box seems pretty feasible
here. I'll follow up on this thread as soon as I found the time to look
into it.

--
Kind regards,
Wilko Meyer
L
L
Ludovic Courtès wrote on 1 Oct 17:30 +0200
(name . Wilko Meyer)(address . w@wmeyer.eu)
87ldz7zvqh.fsf@gnu.org
Hello,

Wilko Meyer <w@wmeyer.eu> skribis:

Toggle quote (10 lines)
> Christopher Baines <mail@cbaines.net> writes:
>> Is it possible to enable some of these modules in the regular kernel
>> packages?
>
> Definitely, I'll have a look into that and see that we enable as much as
> possible in the default config we ship; I think enabling as much
> hardware support as we can out of the box seems pretty feasible
> here. I'll follow up on this thread as soon as I found the time to look
> into it.

Oh that would be even better, indeed (sorry for not noticing your reply
earlier).

I think creating a new issue would be clearer.

Ludo’.
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 72964@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 72964
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch