php-8.3.10 build failure

  • Open
  • quality assurance status badge
Details
4 participants
  • Marek Pa?nikowski
  • Tobias Geerinckx-Rice
  • Nathan Dehnel
  • Rutherther
Owner
unassigned
Submitted by
Marek Pa?nikowski
Severity
normal
Merged with
M
M
Marek Pa?nikowski wrote on 2 Sep 13:04 +0200
(address . bug-guix@gnu.org)
87plpmiaey.fsf@marekpasnikowski.pl
Good morning or afternoon.

I am not able to update my system due to the following build failure:

standard output context
~
The following derivations will be built:
/gnu/store/m7jd9csjwb8yvznassm2mgkx8nyx9m0q-easyeffects-7.1.7.drv
/gnu/store/1gr6a27wls2xlykjqkgy51pxv8c5hfmi-lsp-plugins-1.2.15.drv
/gnu/store/gxjs8dzg8gmif2gj1ybkxxzv623qpq4q-php-8.3.10.drv
~

build log context
~
configure: error: Package requirements (gdlib >= 2.1.0) were not met:

Package 'freetype2', required by 'gdlib', not found
~

I checked with the source code of (gnu packages php) — freetype does not
exist in the file.

I apologize for not posting a patch, but I am still wrapping my head
around concepts more fundamental than patch submission. For example, I
think it is a good idea to Cc the PHP team here, but failed to find
documentation on how to identify the team’s email address.
T
T
Tobias Geerinckx-Rice wrote on 2 Sep 13:48 +0200
(name . Marek Pa?nikowski)(address . marek@marekpasnikowski.pl)
7028ea249a468048c40100a3bd070024@tobias.gr
merge 72943 72962
thanks
^ bot commands

Hi Marek,

Toggle quote (3 lines)
> I apologize for not posting a patch, but I am still wrapping my head
> around concepts more fundamental than patch submission.

Good news! I've merged this issue with the likely cause and a possible
fix.

Toggle quote (4 lines)
> For example, I
> think it is a good idea to Cc the PHP team here, but failed to find
> documentation on how to identify the team’s email address.

Teams don't have addresses/aliases, so you could have kept looking.

The teams are defined[0] in the Guix git repository, to facilitate
automation[1] integrated with ‘git send-email’, and to keep one
consistent source of truth.

If those examples look too complicated, ignore them, and just manually
look up your favourite team members :-)

Kind regards,

T G-R

Sent from a Web browser. Excuse or enjoy my brevity.

T
T
Tobias Geerinckx-Rice wrote on 2 Sep 13:53 +0200
(no subject)
(address . control@debbugs.gnu.org)
6921935c0d74dd5c7b96395f373f0085@tobias.gr
reassign 72962 guix-patches
merge 72943 72962
thanks
not
R
R
Rutherther wrote on 2 Sep 19:27 +0200
Re: php-8.3.10 build failure
(address . 72962@debbugs.gnu.org)(name . Tobias Geerinckx-Rice)(address . me@tobias.gr)
87frqi2cf6.fsf@protonmail.com
Hello everyone,

note that the linked issue solves this only partially.
It fixes gd itself, but then there are still three
failing tests in php.

I suggest this as current workaround locally:
---
(use-modules
(guix packages)
(gnu packages gd)
(gnu packages php))

(define gd-fixed
(package/inherit gd
(name "gd-fixed")
(propagated-inputs
(package-inputs gd))))

(define php
(package/inherit php
(inputs (modify-inputs (package-inputs php)
(replace "gd" gd-fixed)))))

php
M
M
Marek Pa?nikowski wrote on 4 Sep 08:50 +0200
Re: bug#72962: php-8.3.10 build failure
(name . Carlo Zancanaro)(address . carlo@zancanaro.id.au)
87cyljzzcw.fsf_-_@marekpasnikowski.pl
Carlo Zancanaro <carlo@zancanaro.id.au> writes:

Toggle quote (4 lines)
> * gnu/packages/php.scm (php)[arguments]: Delete three tests that are known to
> fail.
>

This is my first time composing a patch review — I am not sure if I am
doing it correctly.

I attempted to build php with the following command:
=
guix build php --with-patch=gd=patch-1.txt --with-patch=php=patch-2.txt
=

The text files are files saved by using the “download” option of the web
interface of Guix Issues. My understanding is that the patch to gd
applies cleanly, but the patch to php does not:

=
source is at 'php-8.3.10'
applying '/gnu/store/f2zxspb49cbcmcla3mbjrikl48kmbf52-patch-2.txt'...
can't find file to patch at input line 13
Perhaps you used the wrong -p or --strip option?
The text leading up to this was:
--------------------------
|* gnu/packages/php.scm (php)[arguments]: Delete three tests that are known to
|fail.
|
|Change-Id: Ib684328654c75f37111d252fb0f9fb3356daff9a
|---
| gnu/packages/php.scm | 7 +++++++
| 1 file changed, 7 insertions(+)
|
|diff --git a/gnu/packages/php.scm b/gnu/packages/php.scm
|index 8f879dbdca..ce7458d0e5 100644
|--- a/gnu/packages/php.scm
|+++ b/gnu/packages/php.scm
--------------------------
No file to patch. Skipping patch.
1 out of 1 hunk ignored
patch unexpectedly ends in middle of line
=

Is this helpful?
M
M
Marek Pa?nikowski wrote on 4 Sep 09:43 +0200
(name . Carlo Zancanaro)(address . carlo@zancanaro.id.au)
87plpjrhhq.fsf_-_@marekpasnikowski.pl
Carlo Zancanaro <carlo@zancanaro.id.au> writes:

Toggle quote (11 lines)
>> I attempted to build php with the following command:
>> =
>> guix build php --with-patch=gd=patch-1.txt --with-patch=php=patch-2.txt
>> =
>
> You should be able to apply them in a fresh clone of the repository with
> "git am $patch-name". To build, you can follow the instructions in the
> manual "(guix) Building from Git". After that, you can build PHP with
> these patches with "./pre-inst-env guix build php".
>

I had a guix clone from previous attempts to patch things, so I
proceeded to apply the patches. Patch 1 returned a message along the
lines (translation) of "apply: * gnu/packages/gd.scm (gd): Change inputs
to propagated-inputs". However,
=
LC_ALL=C git am ../Downloads/patch-2.txt
Patch format detection failed.
=
M
M
Marek Pa?nikowski wrote on 4 Sep 09:59 +0200
(name . Carlo Zancanaro)(address . carlo@zancanaro.id.au)
87ttevq273.fsf_-_@marekpasnikowski.pl
Upon further inspection, I noticed the second patch is missing the
From: <email> header. I copied it from the first patch and it applied.

The build is now in progress on my slow laptop, so I am sending this
report immediately.
M
M
Marek Pa?nikowski wrote on 4 Sep 12:32 +0200
(name . Carlo Zancanaro)(address . carlo@zancanaro.id.au)
878qw7zp37.fsf_-_@marekpasnikowski.pl
The build completed and passed all the tests.

Is this the right moment to say reviewed-looks-good? Would I do it by
writing the usertag followed by thanks in the beginning of the message?
Or am I confusing concepts?
N
N
Nathan Dehnel wrote on 11 Sep 05:29 +0200
php-8.3.10 build failure
(address . 72962@debbugs.gnu.org)
CAEEhgEtCXiJ8-ymcx93xYpjYjGCuDVWz_jempPrKd=77ULyg=Q@mail.gmail.com
ping
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 72962@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 72962
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch