(address . guix-patches@gnu.org)(name . gemmaro)(address . gemmaro.dev@gmail.com)
* gnu/packages/ruby.scm (ruby-rubocop-itamae): New variable.
Change-Id: Ic5679a92c5e5faf420ed7f49acb7d9e28430bff4
---
gnu/packages/ruby.scm | 29 +++++++++++++++++++++++++++++
1 file changed, 29 insertions(+)
Toggle diff (44 lines)
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 5af1bb1cef..7b82ebd58e 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -1996,6 +1996,35 @@ (define-public ruby-rubocop-capybara
ruby-simplecov
ruby-yard))))
+(define-public ruby-rubocop-itamae
+ (package
+ (name "ruby-rubocop-itamae")
+ (version "0.1.5")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/sue445/rubocop-itamae")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1cynpafby3v6psg94whix2z9fhpdh669w9imm92zsjpbdgsxpmd7"))))
+ (build-system ruby-build-system)
+ (arguments
+ (list
+ #:phases #~(modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "rspec" "-Ilib" "-Ispec" "spec")))))))
+ (native-inputs (list ruby-rspec))
+ (propagated-inputs (list ruby-rubocop))
+ (synopsis "Code style checking for Itamae recipes")
+ (description "This RuboCop plugin is for checking the code style of Itamae
+configuration management system recipes.")
+ (home-page "https://github.com/sue445/rubocop-itamae")
+ (license license:expat)))
+
;;; A minimal variant used to build ruby-rubocop itself.
(define ruby-rubocop-rake-minimal
(package
base-commit: 3c21d0da62b3d6832dd1ab450d8ab50ab8d38f27
--
2.45.2