[PATCH] gnu: Add bin-graph.

  • Done
  • quality assurance status badge
Details
3 participants
  • Andreas Enge
  • Artyom V. Poptsov
  • Zheng Junjie
Owner
unassigned
Submitted by
Artyom V. Poptsov
Severity
normal

Debbugs page

Artyom V. Poptsov wrote 6 months ago
(address . guix-patches@gnu.org)(name . Artyom V. Poptsov)(address . poptsov.artyom@gmail.com)
1441b8dd251c1fe66966d807a6f663ca2700f9c6.1725271047.git.poptsov.artyom@gmail.com
* gnu/packages/linux.scm (bin-graph): New variable.

Change-Id: I7405cbc00e038d024d035fb100473352c9a7b59d
---
gnu/packages/linux.scm | 37 +++++++++++++++++++++++++++++++++++++
1 file changed, 37 insertions(+)

Toggle diff (52 lines)
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 318c6ccf13..38f3d6fc2f 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -1776,6 +1776,43 @@ (define-public bbswitch-module
graphics card on Optimus laptops.")
(license license:gpl2))))
+(define-public bin-graph
+ ;; XXX: The upstream does not have tags yet.
+ (let ((commit "1dd42e3e8e123e993d6c287967502c8d4b36f9ba")
+ (revision "0"))
+ (package
+ (name "bin-graph")
+ (version (git-version "0.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/8dcc/bin-graph")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1wjkl789r7iys3nnyk813gsdxwwy2ryxgxirx5xw02lzk790dywl"))))
+ (arguments
+ (list #:tests? #f ; no tests
+ #:make-flags
+ #~(list (string-append "CC=" #$(cc-for-target))
+ (string-append "PREFIX=" #$output))
+ #:phases
+ #~(modify-phases %standard-phases
+ (delete 'configure)
+ (replace 'install
+ (lambda _
+ (install-file "bin-graph"
+ (string-append #$output "/bin")))))))
+ (build-system gnu-build-system)
+ (inputs (list libpng))
+ (home-page "https://github.com/8dcc/bin-graph")
+ (synopsis "Visualize binary files")
+ (description
+ "@code{bin-graph} provides a simple way of visualizing the different regions
+of a binary file.")
+ (license license:gpl3))))
+
(define-public ddcci-driver-linux
(package
(name "ddcci-driver-linux")

base-commit: a977900d76b7585c401222a3ce8bbb82e5f6da45
--
2.45.2
Zheng Junjie wrote 6 months ago
(name . Artyom V. Poptsov)(address . poptsov.artyom@gmail.com)
87ed602l5j.fsf@iscas.ac.cn
"Artyom V. Poptsov" <poptsov.artyom@gmail.com> writes:


maybe gnu/packages/graph.scm better here

Toggle quote (37 lines)
> * gnu/packages/linux.scm (bin-graph): New variable.
>
> Change-Id: I7405cbc00e038d024d035fb100473352c9a7b59d
> ---
> gnu/packages/linux.scm | 37 +++++++++++++++++++++++++++++++++++++
> 1 file changed, 37 insertions(+)
>
> diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
> index 318c6ccf13..38f3d6fc2f 100644
> --- a/gnu/packages/linux.scm
> +++ b/gnu/packages/linux.scm
> @@ -1776,6 +1776,43 @@ (define-public bbswitch-module
> graphics card on Optimus laptops.")
> (license license:gpl2))))
>
> +(define-public bin-graph
> + ;; XXX: The upstream does not have tags yet.
> + (let ((commit "1dd42e3e8e123e993d6c287967502c8d4b36f9ba")
> + (revision "0"))
> + (package
> + (name "bin-graph")
> + (version (git-version "0.0.0" revision commit))
> + (source
> + (origin
> + (method git-fetch)
> + (uri (git-reference
> + (url "https://github.com/8dcc/bin-graph")
> + (commit commit)))
> + (file-name (git-file-name name version))
> + (sha256
> + (base32 "1wjkl789r7iys3nnyk813gsdxwwy2ryxgxirx5xw02lzk790dywl"))))
> + (arguments
> + (list #:tests? #f ; no tests
> + #:make-flags
> + #~(list (string-append "CC=" #$(cc-for-target))
> + (string-append "PREFIX=" #$output))


when use (string-append "INSTALL_DIR=" #$output "/bin") , not need to
replace install phase.

Toggle quote (4 lines)
> + #:phases
> + #~(modify-phases %standard-phases
> + (delete 'configure)

please add a comment, ; no configure script

Toggle quote (18 lines)
> + (replace 'install
> + (lambda _
> + (install-file "bin-graph"
> + (string-append #$output "/bin")))))))
> + (build-system gnu-build-system)
> + (inputs (list libpng))
> + (home-page "https://github.com/8dcc/bin-graph")
> + (synopsis "Visualize binary files")
> + (description
> + "@code{bin-graph} provides a simple way of visualizing the different regions
> +of a binary file.")
> + (license license:gpl3))))
> +
> (define-public ddcci-driver-linux
> (package
> (name "ddcci-driver-linux")
>
> base-commit: a977900d76b7585c401222a3ce8bbb82e5f6da45
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEfr6klGDOXiwIdX/bO1qpk+Gi3/AFAmbXyWgACgkQO1qpk+Gi
3/A0gRAAqMkV4L4WHuL3Z+mQm9hIuSLTyKvfKTy/ovE4AEV/+GbIk0HgpkDejw4U
Wstt81qFCDZgTix1laOtjnZoP4fgidrd2h17RhjQgc8BcRjuDwmHp9VqzoHnK4Ag
bcMVIHLav9hDx01fLM6AJq5KH8gzrCeq+zSIIqWkh97ektmvRQLtgALSjKJot1ON
/ADc8Mv7ZjgvhFcXbMxsHK43MRy5nbz3nn1uAK4upf0ZXrYe9lsG0c/Gbr2xbGba
h6OuGmr6aeqZJrHllMbuoCh/IZPZIlOePMln+juQtD3xrSooXuBL/G2Iglk/PkLM
nz4DmXp7k9wU13B3vOme5goYjJCGhDdk7XLTnS1qatrfVe+ZUScM9AeFZc9AGkZM
zbB84wHmfpUNt3zQLDarsMASqL6Aq4yHISqYFTIWa3ajW9FpNt+w2Xx6TAN1gnpq
2drYiodK7Fz+4f/aqtG6wRUgkHvbsmJE8xRMs1fYbtRaJcqjwD1TQeDk+3Uu5ddd
6L6OVXIukPYXrlgqf1UBZk0wgKkeBHrcDI30GX8kwYdf0t+en/AzimHD50GHAFme
48Zm4ptwcwqPK1W2tVATwMJB1NBP4aCz2AmRJAMGb8cj6f0iHxaUPorF+trF9BHM
GJxAWdtrhL0kcdp7HIBhyPHkYy6dUQ5xdbaNU9HBkl8T98n0uoE=
=r/kl
-----END PGP SIGNATURE-----

Artyom V. Poptsov wrote 6 months ago
[PATCH v2] gnu: Add bin-graph.
(address . 72957@debbugs.gnu.org)(name . Artyom V. Poptsov)(address . poptsov.artyom@gmail.com)
b79b8f892660a0c19f7d63e9f4cdb3941733613e.1725435643.git.poptsov.artyom@gmail.com
* gnu/packages/linux.scm (bin-graph): New variable.

Change-Id: I7405cbc00e038d024d035fb100473352c9a7b59d
---
gnu/packages/linux.scm | 34 ++++++++++++++++++++++++++++++++++
1 file changed, 34 insertions(+)

Toggle diff (49 lines)
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index a3b63a6f62..76de4be816 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -1776,6 +1776,40 @@ (define-public bbswitch-module
graphics card on Optimus laptops.")
(license license:gpl2))))
+(define-public bin-graph
+ ;; XXX: The upstream does not have tags yet.
+ (let ((commit "1dd42e3e8e123e993d6c287967502c8d4b36f9ba")
+ (revision "0"))
+ (package
+ (name "bin-graph")
+ (version (git-version "0.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/8dcc/bin-graph")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1wjkl789r7iys3nnyk813gsdxwwy2ryxgxirx5xw02lzk790dywl"))))
+ (arguments
+ (list #:tests? #f ; no tests
+ #:make-flags
+ #~(list (string-append "CC=" #$(cc-for-target))
+ (string-append "PREFIX=" #$output)
+ (string-append "INSTALL_DIR=" #$output "/bin"))
+ #:phases
+ #~(modify-phases %standard-phases
+ (delete 'configure)))) ; no configure script
+ (build-system gnu-build-system)
+ (inputs (list libpng))
+ (home-page "https://github.com/8dcc/bin-graph")
+ (synopsis "Visualize binary files")
+ (description
+ "@code{bin-graph} provides a simple way of visualizing the different regions
+of a binary file.")
+ (license license:gpl3))))
+
(define-public ddcci-driver-linux
(package
(name "ddcci-driver-linux")

base-commit: 7fa9df431e9423e2b79c8c520de1d0ef7aed910d
--
2.45.2
Artyom V. Poptsov wrote 6 months ago
Re: [bug#72957] [PATCH] gnu: Add bin-graph.
(name . Zheng Junjie)(address . zhengjunjie@iscas.ac.cn)
87plpj6eu3.fsf@gmail.com
Hello, Zheng Junjie!

Thank you for the patch review! I fixed most of the issues that you
mentioned.

Toggle quote (2 lines)
> maybe gnu/packages/graph.scm better here

I don't think that "graph.scm" is a good place for "bin-graph" as this
is not a tool for working with images only but more like a tool for
visualizing the insides of binaries. It's closer to reverse-engineering
realm than to image processing realm.

- avp

--
Artyom "avp" Poptsov <poptsov.artyom@gmail.com>
CADR Hackerspace co-founder: https://cadrspace.ru/
GPG: D0C2 EAC1 3310 822D 98DE B57C E9C5 A2D9 0898 A02F
-----BEGIN PGP SIGNATURE-----

iQJNBAEBCgA3FiEEAf2F9Bp7f4IFgwalk16+BzbchX4FAmbYEGkZHHBvcHRzb3Yu
YXJ0eW9tQGdtYWlsLmNvbQAKCRCTXr4HNtyFfs14D/9lYbAR1ubCeYHR9MW74kxr
FX4caBbG1yI1fJKeEmkvDBSynC0d1cM4D3ImQHthHW6FTWKBM7gFQLfNP1CS5meQ
fliKWK7pYWZ03dnxOQCV754BSCq2B+05nlEmyZwidFE2E2o5FTa7yXQjxT6DdUsA
nTMQsQRuFytDPfMzFq66qZMnj7kBdcHEafJVvZn7LJvJp64kJqKyhOuDNs0XCkj+
EriJKrWsl7kGsjt06NfIYDUWtTDnvNVVuARJoPzNvoWKlawyMa14+zoNs2nurYR4
ahvlRc7TO8yELSlL8UXmntq7IzFqBZoCwQlcSMKc/jfwW4Mlctbpk0YoI8V2IdAg
JNWPIW8UcK/HpuR8mpqsN7CqlsYyKEf0PNRYUPkDZFyoTdsKwn2KesAenr9rfgGp
etbNnwGEQFP1T4jJyb/Nd1yihC/Yjn+3K1WkLWLEi1PlFxg33CyD131+8qDXRRd4
shwh9Ed4uhXltttSYJGnnd58uXQmNo37BswiHQBpF0QZOynFwg6q05dRj5oY11xN
pOsjrV7EsMBmu6xmT7zgkpsEATWb4jH0yfj1h/I1dn/QwF9v9tdhCNXXbAf/gJ9D
UAgZ2dAhpCm4Olnvgyh3FPpvAtIqSMxcsKqpPuTRCaYZoyQoEjhgpus7VURTGfZ9
Chhi/KfYluJsD4w9/l9q0A==
=F8Au
-----END PGP SIGNATURE-----

Andreas Enge wrote 6 months ago
Looks good
(address . 72957@debbugs.gnu.org)
ZuqU8bp-IgN5ILed@jurong
Hello Artyom,

it looks good and passes QA.

I think you have commit rights now and can push it yourself and close
the issue? If not, please come back to me.

Andreas
Artyom V. Poptsov wrote 5 months ago
Re: [PATCH] gnu: Add bin-graph.
(address . 72957-done@debbugs.gnu.org)
87jzeccnnu.fsf@gmail.com
Pushed to the "master" as e4f5eb6c01727ef143e533019e74830e00d6f5d2.

- avp

--
Artyom "avp" Poptsov <poptsov.artyom@gmail.com>
CADR Hackerspace co-founder: https://cadrspace.ru/
GPG: D0C2 EAC1 3310 822D 98DE B57C E9C5 A2D9 0898 A02F
-----BEGIN PGP SIGNATURE-----

iQJNBAEBCgA3FiEEAf2F9Bp7f4IFgwalk16+BzbchX4FAmcLnjgZHHBvcHRzb3Yu
YXJ0eW9tQGdtYWlsLmNvbQAKCRCTXr4HNtyFfh8TD/9ZQhvpVInv+A3/6Y8O+egV
DdNFfBo5srE5IM0VewKNT9bw+hvwNVj7Ev46qQuQ1oqEbVjR18sT8Y+tNJjFPNWE
L8Fpq70MeUA/fnBTjRh2uzxIylJn6TXXVx7t6QL/zFFhnPsJYHv2QIs9MHCya5CT
CXVmWHvCTMQZ+eO0oqrmOgEbdSNbnHdubCvQx/TP6ECQsN+BpfW0TVMWfyu2NuYU
apuWsdYAt2gBNhkJ9uszjwzIumCK9kXHBLeyUjOKbVIWg+nUbjbprvWaHfExZDdc
KVIV8wcEJvKPcqdXPMgiQDDFQdmmUjcE1Wg0wIMUmexDZXcpcBKTC8CJXGAPm3jD
GQNBAJaxD98vAVnnp3rSU4HD7aeOy60LfDlnIytBJHaO4or+yAwQZH1C3gN8tnDv
lyYn5hGZtgaFqvNORRe2IkFSeeeal/3VmLFm0aBSQcGZCdhEcGxjekqKt7xoc+1z
KVxnmiLuPMG3JfhrAs4ihJj4Qdm0LekarO4UdRfVY7N+HwjWPkLp/vMvM2bj+L2+
LVJP0ksmdfGz+skBhCH6WRp56C0Cabs/bIsuv3x9+yYl3M/+CMHR1RDfVM/4O5rj
9HAJfJ/qk+7sHUvwejo2rJrBzr2/HeeV3EFZRcMWl49IWw5T7IcZ26YVgJt8KGqE
XchTNkLPGvWG7etLDT3OJg==
=2i7x
-----END PGP SIGNATURE-----

?
Your comment

This issue is archived.

To comment on this conversation send an email to 72957@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 72957
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help