[PATCH 2/2] gnu: Add fcitx5-chewing.

  • Open
  • quality assurance status badge
Details
One participant
  • Charles
Owner
unassigned
Submitted by
Charles
Severity
normal
C
C
Charles wrote on 2 Sep 04:54 +0200
(address . guix-patches@gnu.org)(name . Charles)(address . charles@charje.net)
20240902025439.31542-3-charles@charje.net
* gnu/packages/fcitx5.scm (fcitx5-chewing): New variable.

Change-Id: Ib14bccae792bf1d56bedc5e7297d8cc9c3c59ebc
---
gnu/packages/fcitx5.scm | 28 ++++++++++++++++++++++++++++
1 file changed, 28 insertions(+)

Toggle diff (52 lines)
diff --git a/gnu/packages/fcitx5.scm b/gnu/packages/fcitx5.scm
index 4ad7fa98ca..b38812b539 100644
--- a/gnu/packages/fcitx5.scm
+++ b/gnu/packages/fcitx5.scm
@@ -4,6 +4,7 @@
;;; Copyright © 2022 Dominic Martinez <dom@dominicm.dev>
;;; Copyright © 2022 dan <i@dan.games>
;;; Copyright © 2024 Zheng Junjie <873216071@qq.com>
+;;; Copyright © 2024 Charles Jackson <charles@charje.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -41,6 +42,7 @@ (define-module (gnu packages fcitx5)
#:use-module (gnu packages ibus)
#:use-module (gnu packages iso-codes)
#:use-module (gnu packages kde-frameworks)
+ #:use-module (gnu packages language)
#:use-module (gnu packages libevent)
#:use-module (gnu packages linux)
#:use-module (gnu packages lua)
@@ -589,3 +591,29 @@ (define-public fcitx5-rime
and sentences intelligently and provide very accurate traditional Chinese
output.")
(license license:lgpl2.1+)))
+
+(define-public fcitx5-chewing
+ (package
+ (name "fcitx5-chewing")
+ (version "5.1.5")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/fcitx/fcitx5-chewing")
+ (commit version)))
+ (sha256
+ (base32 "011psyvvcbrw062zw807lm33n827qza7mqaagf8zb0cz3hh1qwm9"))
+ (file-name (git-file-name name version))))
+ (build-system cmake-build-system)
+ (arguments
+ (list #:tests? #f)) ;; tests fail
+ (inputs (list libchewing))
+ (native-inputs
+ (list extra-cmake-modules
+ pkg-config
+ gettext-minimal
+ fcitx5))
+ (home-page "https://github.com/fcitx/fcitx5-chewing")
+ (synopsis "Chewing Wrapper for Fcitx")
+ (description "This provides libchewing input method support for fcitx5.")
+ (license license:gpl2+)))
--
2.45.2
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 72946@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 72946
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch