guix import crate produce broken package definition

  • Done
  • quality assurance status badge
Details
2 participants
  • Aleksandr Vityazev
  • Ludovic Courtès
Owner
unassigned
Submitted by
Aleksandr Vityazev
Severity
normal
A
A
Aleksandr Vityazev wrote on 1 Sep 22:08 +0200
(address . bug-guix@gnu.org)
87frqjf87c.fsf@disroot.org
Hi,

guix import crate sanakirja-core

Restult:

(define-public rust-sanakirja-core-1
(package
(name "rust-sanakirja-core")
(version "1.4.1")
(source
(origin
(method url-fetch)
(uri (crate-uri "sanakirja-core" version))
(file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32 "1xcb4d9gaxp61na4dyz9iiq3n1shhiivqs0iv5xnxb1ymqsdnxl3"))))
(build-system cargo-build-system)
(arguments
`(#:cargo-inputs ,(list ("rust-crc32fast" ,rust-crc32fast-1)
("rust-ed25519-zebra" ,rust-ed25519-zebra-2)
("rust-sha2" ,rust-sha2-0.10)
("rust-uuid" ,rust-uuid-1))))
(synopsis
"Copy-on-write datastructures, storable on disk (or elsewhere) with a stable format")
(description
"This package provides Copy-on-write datastructures, storable on disk (or elsewhere) with a stable
format.")
(license (list license:expat license:asl2.0))))

quasiquote and unquote in arguments are unbalanced. Probably introduced
in b8af6694b9bbea96e8b0d1c9aea64b7f8e690812.


--
Best regards,
Aleksandr Vityazev
-----BEGIN PGP SIGNATURE-----

iHUEARYKAB0WIQT/cod8TyH8TUZ9IMTcy1JVIJi2wQUCZtTJtwAKCRDcy1JVIJi2
wYAIAPsFlUsrSr4DEYOv46M5oAXS7QAUS7P0VwxgTrK6aL4HKQD/W1PjYg9yel3j
wwzNG+fcS6qN3Rj6iXomy+rt4YyXQAE=
=dxlx
-----END PGP SIGNATURE-----

L
L
Ludovic Courtès wrote on 19 Sep 15:04 +0200
(name . Aleksandr Vityazev)(address . avityazev@disroot.org)
87bk0j7q2g.fsf@gnu.org
Hi Aleksandr,

(Cc’ing potentially interested parties.)

Aleksandr Vityazev <avityazev@disroot.org> skribis:

Toggle quote (2 lines)
> guix import crate sanakirja-core

[...]

Toggle quote (6 lines)
> (arguments
> `(#:cargo-inputs ,(list ("rust-crc32fast" ,rust-crc32fast-1)
> ("rust-ed25519-zebra" ,rust-ed25519-zebra-2)
> ("rust-sha2" ,rust-sha2-0.10)
> ("rust-uuid" ,rust-uuid-1))))

[...]

Toggle quote (3 lines)
> quasiquote and unquote in arguments are unbalanced. Probably introduced
> in b8af6694b9bbea96e8b0d1c9aea64b7f8e690812.

Indeed. Fixed in 89413a11625dd6c548827dd0078ebe0191086597 by reverting
that commit.

Commit b8af6694b9bbea96e8b0d1c9aea64b7f8e690812 originates from
https://issues.guix.gnu.org/49531, which included more work, such as a
‘guix style’ feature to update Rust packages to this new style. I don’t
think the part about Rust packages reached consensus though.

Thanks,
Ludo’.
L
L
Ludovic Courtès wrote on 19 Sep 15:04 +0200
control message for bug #72939
(address . control@debbugs.gnu.org)
87a5g37q1r.fsf@gnu.org
close 72939
quit
?
Your comment

This issue is archived.

To comment on this conversation send an email to 72939@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 72939
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch