(address . bug-guix@gnu.org)
Hi,
guix import crate sanakirja-core
Restult:
(define-public rust-sanakirja-core-1
(package
(name "rust-sanakirja-core")
(version "1.4.1")
(source
(origin
(method url-fetch)
(uri (crate-uri "sanakirja-core" version))
(file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32 "1xcb4d9gaxp61na4dyz9iiq3n1shhiivqs0iv5xnxb1ymqsdnxl3"))))
(build-system cargo-build-system)
(arguments
`(#:cargo-inputs ,(list ("rust-crc32fast" ,rust-crc32fast-1)
("rust-ed25519-zebra" ,rust-ed25519-zebra-2)
("rust-sha2" ,rust-sha2-0.10)
("rust-uuid" ,rust-uuid-1))))
(home-page "https://nest.pijul.com/pijul/sanakirja")
(synopsis
"Copy-on-write datastructures, storable on disk (or elsewhere) with a stable format")
(description
"This package provides Copy-on-write datastructures, storable on disk (or elsewhere) with a stable
format.")
(license (list license:expat license:asl2.0))))
quasiquote and unquote in arguments are unbalanced. Probably introduced
in b8af6694b9bbea96e8b0d1c9aea64b7f8e690812.
--
Best regards,
Aleksandr Vityazev
-----BEGIN PGP SIGNATURE-----
iHUEARYKAB0WIQT/cod8TyH8TUZ9IMTcy1JVIJi2wQUCZtTJtwAKCRDcy1JVIJi2
wYAIAPsFlUsrSr4DEYOv46M5oAXS7QAUS7P0VwxgTrK6aL4HKQD/W1PjYg9yel3j
wwzNG+fcS6qN3Rj6iXomy+rt4YyXQAE=
=dxlx
-----END PGP SIGNATURE-----