[PATCH 0/2] gnu: autorandr: Update to 1.15.

  • Done
  • quality assurance status badge
Details
2 participants
  • jgart
  • Artyom V. Poptsov
Owner
unassigned
Submitted by
Artyom V. Poptsov
Severity
normal

Debbugs page

Artyom V. Poptsov wrote 6 months ago
(address . guix-patches@gnu.org)(name . Artyom V. Poptsov)(address . poptsov.artyom@gmail.com)
cover.1725216784.git.poptsov.artyom@gmail.com
This patchset updates autorandr to version 1.15 and improves the package
definition.

Artyom V. Poptsov (2):
gnu: autorandr: Update to 1.15.
gnu: autorandr: Use GEXPs.

gnu/packages/xdisorg.scm | 49 ++++++++++++++++++++--------------------
1 file changed, 24 insertions(+), 25 deletions(-)


base-commit: e1c92c98f7afff13fb7060199ba0dd4d9c5c2c53
--
2.45.2
Artyom V. Poptsov wrote 6 months ago
[PATCH 1/2] gnu: autorandr: Update to 1.15.
(address . 72937@debbugs.gnu.org)(name . Artyom V. Poptsov)(address . poptsov.artyom@gmail.com)
98dd684509c78254016abcdd96c86a892e5bed84.1725216784.git.poptsov.artyom@gmail.com
* gnu/packages/xdisorg.scm (autorandr): Update to 1.15.

Change-Id: I663cd9271a426287bbaee9179d75df05bd61c7ad
---
gnu/packages/xdisorg.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index e7eab3babf..e470ad8c0a 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -281,7 +281,7 @@ (define-public arandr
(define-public autorandr
(package
(name "autorandr")
- (version "1.14")
+ (version "1.15")
(home-page "https://github.com/phillipberndt/autorandr")
(source
(origin
@@ -291,7 +291,7 @@ (define-public autorandr
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "0yb0rnv37xymjhg54mk7zw3h9501f45ykc1754mxy1q3bm0fgva6"))))
+ (base32 "1n4cmgisk1p199zny8zrdpfrbakchd6pvpkp9vzqqdw2f75iylzh"))))
(build-system python-build-system)
(native-inputs
(list pkg-config))
--
2.45.2
Artyom V. Poptsov wrote 6 months ago
[PATCH 2/2] gnu: autorandr: Use GEXPs.
(address . 72937@debbugs.gnu.org)(name . Artyom V. Poptsov)(address . poptsov.artyom@gmail.com)
617d4764936280f3fe24c7928195078f563f255f.1725216784.git.poptsov.artyom@gmail.com
* gnu/packages/xdisorg.scm (autorandr): Use GEXPs.

Change-Id: I476e29ddff17c0180e8a0eeefe818954364eac71
---
gnu/packages/xdisorg.scm | 45 ++++++++++++++++++++--------------------
1 file changed, 22 insertions(+), 23 deletions(-)

Toggle diff (58 lines)
diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index e470ad8c0a..f123b739e7 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -298,29 +298,28 @@ (define-public autorandr
(inputs
(list xrandr libxcb))
(arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-before 'build 'configure
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (let ((xrandr (search-input-file inputs "/bin/xrandr")))
- (substitute* "contrib/etc/xdg/autostart/autorandr.desktop"
- (("/usr") (assoc-ref outputs "out")))
- (substitute* "autorandr.py"
- (("popen\\(\"xrandr") (string-append "popen(\"" xrandr))
- (("\\[\"xrandr") (string-append "[\"" xrandr)))
- (substitute* "contrib/autorandr_launcher/autorandr_launcher.c"
- (("/usr/bin/autorandr")
- (string-append (assoc-ref outputs "out") "/bin/autorandr")))
- (setenv "CC" "gcc"))
- #t))
- (add-after 'install 'install-contrib
- (lambda* (#:key outputs #:allow-other-keys)
- (invoke "make"
- (string-append "DESTDIR=" (assoc-ref outputs "out"))
- "PREFIX="
- "BASH_COMPLETIONS_DIR=etc/bash_completion.d"
- "install"
- "TARGETS=autorandr launcher manpage bash_completion"))))))
+ (list #:phases
+ #~(modify-phases %standard-phases
+ (add-before 'build 'configure
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let ((xrandr (search-input-file inputs "/bin/xrandr")))
+ (substitute* "contrib/etc/xdg/autostart/autorandr.desktop"
+ (("/usr") (assoc-ref outputs "out")))
+ (substitute* "autorandr.py"
+ (("popen\\(\"xrandr") (string-append "popen(\"" xrandr))
+ (("\\[\"xrandr") (string-append "[\"" xrandr)))
+ (substitute* "contrib/autorandr_launcher/autorandr_launcher.c"
+ (("/usr/bin/autorandr")
+ (string-append (assoc-ref outputs "out") "/bin/autorandr")))
+ (setenv "CC" "gcc"))))
+ (add-after 'install 'install-contrib
+ (lambda* (#:key outputs #:allow-other-keys)
+ (invoke "make"
+ (string-append "DESTDIR=" (assoc-ref outputs "out"))
+ "PREFIX="
+ "BASH_COMPLETIONS_DIR=etc/bash_completion.d"
+ "install"
+ "TARGETS=autorandr launcher manpage bash_completion"))))))
(synopsis "Auto-detect connected displays and load appropriate setup")
(description "Autorandr wraps around xrandr to help with X11
multi-screen configuration management. It allows the user to create profiles
--
2.45.2
jgart wrote 6 months ago
Re: [PATCH 0/2] gnu: autorandr: Update to 1.15.
(address . 72937-done@debbugs.gnu.org)(name . Artyom V. Poptsov)(address . poptsov.artyom@gmail.com)
87mskn7bml.fsf@dismail.de
Applied with slight modifications. I used $#output instead of assoc-ref style
--
all the best,
jgart
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 72937@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 72937
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help