lxc fails to build

  • Open
  • quality assurance status badge
Details
One participant
  • Jakob Kirsch
Owner
unassigned
Submitted by
Jakob Kirsch
Severity
normal

Debbugs page

Jakob Kirsch wrote 6 months ago
(address . bug-guix@gnu.org)
bf430ea7-ec39-4090-8efc-f93b57d699c7@web.de
The error message is:
```
mount_utils.c: In function ‘create_detached_idmapped_mount’:
mount_utils.c:297:29: error: passing argument 4 of ‘mount_setattr’ from
incompatible pointer type [-Werror=incompatible-pointer-types]
 297 |                             &attr, sizeof(attr));
     |                             ^~~~~
     |                             |
     |                             struct lxc_mount_attr *
In file included from mount_utils.c:9:
/gnu/store/zvlp3n8iwa1svxmwv4q22pv1pb1c9pjq-glibc-2.39/include/sys/mount.h:320:46:
note: expected ‘struct mount_attr *’ but argument is of type ‘struct
lxc_mount_attr *’
 320 |                           struct mount_attr *__uattr, size_t
__usize)
     |                           ~~~~~~~~~~~~~~~~~~~^~~~~~~
mount_utils.c: In function ‘__fd_bind_mount’:
mount_utils.c:380:37: error: passing argument 4 of ‘mount_setattr’ from
incompatible pointer type [-Werror=incompatible-pointer-types]
 380 |                                     &attr, sizeof(attr));
     |                                     ^~~~~
     |                                     |
     |                                     struct lxc_mount_attr *
In file included from mount_utils.c:9:
/gnu/store/zvlp3n8iwa1svxmwv4q22pv1pb1c9pjq-glibc-2.39/include/sys/mount.h:320:46:
note: expected ‘struct mount_attr *’ but argument is of type ‘struct
lxc_mount_attr *’
 320 |                           struct mount_attr *__uattr, size_t
__usize)
```
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 72934@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 72934
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help