Jakob Kirsch wrote 6 months ago
(address . bug-guix@gnu.org)
The error message is:
```
mount_utils.c: In function ‘create_detached_idmapped_mount’:
mount_utils.c:297:29: error: passing argument 4 of ‘mount_setattr’ from
incompatible pointer type [-Werror=incompatible-pointer-types]
297 | &attr, sizeof(attr));
| ^~~~~
| |
| struct lxc_mount_attr *
In file included from mount_utils.c:9:
/gnu/store/zvlp3n8iwa1svxmwv4q22pv1pb1c9pjq-glibc-2.39/include/sys/mount.h:320:46:
note: expected ‘struct mount_attr *’ but argument is of type ‘struct
lxc_mount_attr *’
320 | struct mount_attr *__uattr, size_t
__usize)
| ~~~~~~~~~~~~~~~~~~~^~~~~~~
mount_utils.c: In function ‘__fd_bind_mount’:
mount_utils.c:380:37: error: passing argument 4 of ‘mount_setattr’ from
incompatible pointer type [-Werror=incompatible-pointer-types]
380 | &attr, sizeof(attr));
| ^~~~~
| |
| struct lxc_mount_attr *
In file included from mount_utils.c:9:
/gnu/store/zvlp3n8iwa1svxmwv4q22pv1pb1c9pjq-glibc-2.39/include/sys/mount.h:320:46:
note: expected ‘struct mount_attr *’ but argument is of type ‘struct
lxc_mount_attr *’
320 | struct mount_attr *__uattr, size_t
__usize)
```