[PATCH] gnu: wine64: Fix build.

  • Done
  • quality assurance status badge
Details
3 participants
  • Dr. Arne Babenhauserheide
  • Ian Eure
  • Liliana Marie Prikler
Owner
unassigned
Submitted by
Liliana Marie Prikler
Severity
normal
L
L
Liliana Marie Prikler wrote on 31 Aug 21:09 +0200
(address . guix-patches@gnu.org)
eb4aff7e593e9c9d54b55d6441e7142dd944a780.1725141926.git.liliana.prikler@gmail.com
With the core-updates merge, the handling of modify-phases makes the current
ordering a hard error. Make it so that phases are read from top to bottom.

* gnu/packages/wine.scm (wine64)[#:phases]: Move ‘copy-wine32-binaries’
and ‘copy-wine32-libraries’ before conditional ‘wrap-executable’.
<copy-wine32-manpage>: Use “.zst” instead of “.gz” as file ending.
---
gnu/packages/wine.scm | 34 +++++++++++++++++-----------------
1 file changed, 17 insertions(+), 17 deletions(-)

Toggle diff (60 lines)
diff --git a/gnu/packages/wine.scm b/gnu/packages/wine.scm
index 35520ee03b..0e1195b6ed 100644
--- a/gnu/packages/wine.scm
+++ b/gnu/packages/wine.scm
@@ -256,6 +256,21 @@ (define-public wine64
)
((#:phases phases)
#~(modify-phases #$phases
+ (add-after 'install 'copy-wine32-binaries
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let ((out (assoc-ref %outputs "out")))
+ ;; Copy the 32-bit binaries needed for WoW64.
+ (copy-file (search-input-file inputs "/bin/wine")
+ (string-append out "/bin/wine"))
+ ;; Copy the real 32-bit wine-preloader instead of the wrapped
+ ;; version.
+ (copy-file (search-input-file inputs "/bin/.wine-preloader-real")
+ (string-append out "/bin/wine-preloader")))))
+ (add-after 'install 'copy-wine32-libraries
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let* ((out (assoc-ref %outputs "out")))
+ (copy-recursively (search-input-directory inputs "/lib/wine32")
+ (string-append out "/lib/wine32")))))
;; Explicitly set both the 64-bit and 32-bit versions of vulkan-loader
;; when installing to x86_64-linux so both are available.
;; TODO: Add more JSON files as they become available in Mesa.
@@ -281,27 +296,12 @@ (define-public wine64
`("VK_ICD_FILENAMES" ":" = ,icd-files)))))))
(_
`()))
- (add-after 'install 'copy-wine32-binaries
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (let ((out (assoc-ref %outputs "out")))
- ;; Copy the 32-bit binaries needed for WoW64.
- (copy-file (search-input-file inputs "/bin/wine")
- (string-append out "/bin/wine"))
- ;; Copy the real 32-bit wine-preloader instead of the wrapped
- ;; version.
- (copy-file (search-input-file inputs "/bin/.wine-preloader-real")
- (string-append out "/bin/wine-preloader")))))
- (add-after 'install 'copy-wine32-libraries
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (let* ((out (assoc-ref %outputs "out")))
- (copy-recursively (search-input-directory inputs "/lib/wine32")
- (string-append out "/lib/wine32")))))
(add-after 'compress-documentation 'copy-wine32-manpage
(lambda* (#:key inputs outputs #:allow-other-keys)
(let* ((out (assoc-ref %outputs "out")))
;; Copy the missing man file for the wine binary from wine.
- (copy-file (search-input-file inputs "/share/man/man1/wine.1.gz")
- (string-append out "/share/man/man1/wine.1.gz")))))))
+ (copy-file (search-input-file inputs "/share/man/man1/wine.1.zst")
+ (string-append out "/share/man/man1/wine.1.zst")))))))
((#:configure-flags configure-flags '())
#~(cons "--enable-win64" #$configure-flags))))
(synopsis "Implementation of the Windows API (WoW64 version)")

base-commit: 19e0b937857563e77841a4fc5433589fa98c810d
--
2.45.2
I
I
Ian Eure wrote on 1 Sep 18:28 +0200
(address . 72922@debbugs.gnu.org)
87bk17e3pe.fsf@retrospec.tv
This looks good to me.

Thanks,

— Ian
D
D
Dr. Arne Babenhauserheide wrote on 2 Sep 21:37 +0200
(address . 72922@debbugs.gnu.org)
87seuh4zk3.fsf@web.de
Tested — this works for me.

Thank you!

Best wishes,
Arne
--
Unpolitisch sein
heißt politisch sein,
ohne es zu merken.
draketo.de
-----BEGIN PGP SIGNATURE-----

iQJEBAEBCAAuFiEE801qEjXQSQPNItXAE++NRSQDw+sFAmbWE/wQHGFybmVfYmFi
QHdlYi5kZQAKCRAT741FJAPD6/YeD/4zJGhWKI3frN6Uzv0dGgQIU2/VG6+9pM9S
RqsdV08Fhno3wjOvz5Meu2LuoWuVCd5sb8/9ombXRS9Lik6IklIUZOwUsrKG17iE
9+v9s7YqdYInZWfF67R4bMbMt+RFjBxuJz8oBxMtEEc+2N2mYeLDUfiyTr4MaP6Z
+GZoMCVPg2gxO4NikfnNH+bwNA/CM1+zoQfZwLYGI0UOBbBWy/KLSCG8wZXr+gqh
xVqcdzMzo9YOYG6lDtvubc6grIR8yLH2wieb22Pt3u2L8WR+SiuyhcKlI9rvGwqy
RnfpIMtVj+RV8cJ3CdrYzzS0AiS3huEUNKaYC7/HV8y12FGcsDg/TBi8e0vE8eqw
koFhYShj0ebvl+fG5ry8NwtHQFNjN6awA8h3vDZvdQb8ePU6iFz2trho0rCeA4oR
OXib7vhC9In3N8inMNwway4ZA0NqQIWhSlA7yTBseHjackwZ5GDpSaAktdnDmeRG
M1Z+6r6XSi4qikLdxnn6dic9LFkttPuMKjpcuVD1eccCjzhg5+unhpPvjOsQ+SqV
RfruZZC8IhjkVV0SaQgGP6s6DylbQu9ZFuyIwZva+ZhCK6Ra8kM25HVYItGq3RzC
refR0WUZLe/9jMc2DG7zw2tgYlpPVQXevGjN4NgbC+LuXHCKB/8CiTnnae1yZdO3
XOcO0lf/PYjEBAEBCAAuFiEE3Si95tmHXKvOSosd3M8NswvBBUgFAmbWE/wQHGFy
bmVfYmFiQHdlYi5kZQAKCRDczw2zC8EFSFgkA/9AEnC4T8mkPM+ko1zsQIl7BZvN
H2PXGaGYTHceAoHgrT418hMwQY3cV6bckz1GDeMS5wl/dB4HpHsZPL53yAbY61sY
Hz8nrH7uW7G0QHNcqn6lu4g1fbRSwIgRFGwmnB+DxA/WNcnvudTv9mkJo36DQ9pm
bclO0CXUBbtvEWBLXQ==
=y+vk
-----END PGP SIGNATURE-----

L
L
Liliana Marie Prikler wrote on 8 Sep 16:03 +0200
(address . 72922-done@debbugs.gnu.org)
0601021e0016f782b263018c33816f9ae83e760d.camel@gmail.com
Am Samstag, dem 31.08.2024 um 21:09 +0200 schrieb Liliana Marie
Prikler:
Toggle quote (9 lines)
> With the core-updates merge, the handling of modify-phases makes the
> current ordering a hard error.  Make it so that phases are read from
> top to bottom.
>
> * gnu/packages/wine.scm (wine64)[#:phases]: Move ‘copy-wine32-
> binaries’ and ‘copy-wine32-libraries’ before conditional ‘wrap-
> executable’.
> <copy-wine32-manpage>: Use “.zst” instead of “.gz” as file ending.
> ---
Pushed some while ago.
Closed
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 72922@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 72922
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch