Building emacs-yaml with emacs takes approximately eternity

  • Open
  • quality assurance status badge
Details
2 participants
  • Liliana Marie Prikler
  • Tomas Volf
Owner
unassigned
Submitted by
Tomas Volf
Severity
normal
T
T
Tomas Volf wrote on 31 Aug 23:01 +0200
(address . bug-guix@gnu.org)
87a5gsl84w.fsf@wolfsden.cz
The emacs-yaml package is configured to build against emacs-minimal,
which seems to work. When you however switch to emacs package, it takes
way to long to build, much longer than compiling for example firefox
package. That feels off.

Toggle snippet (8 lines)
$ time guix time-machine -q --commit=b8327cb31199fb9f4ebed6c53a59601d41def5a1 -- build --check --no-grafts -q --with-input=emacs-minimal=emacs-minimal emacs-yaml
/gnu/store/8lqdd8yna92zqgsgip396a1wbyhr5pfn-emacs-yaml-0.5.5
12.573 secs
$ time guix time-machine -q --commit=b8327cb31199fb9f4ebed6c53a59601d41def5a1 -- build --check --no-grafts -q --with-input=emacs-minimal=emacs emacs-yaml
/gnu/store/ja9xfndhfafjczp6n7qfy1h21hvdpd5j-emacs-yaml-0.5.5
2869.878 secs

The difference is huge. The process taking vast majority of the time
(in the emacs version) is this one:

Toggle snippet (3 lines)
32393 guixbuil 47:10 {.emacs-29.4-rea} /gnu/store/y7yhpgi48klqpadrmfknl4bln9c4n05y-emacs-29.4/bin/emacs -no-comp-spawn -Q --batch -l /tmp/guix-build-emacs-yaml-0.5.5.drv-0/emacs-int-comp-yaml-pbHFU3.el

I do not know enough to even guess what could be the problem, but it was
suggested I should bug-report this.

Cheers,
Tomas

--
There are only two hard things in Computer Science:
cache invalidation, naming things and off-by-one errors.
-----BEGIN PGP SIGNATURE-----

iQJCBAEBCgAsFiEEt4NJs4wUfTYpiGikL7/ufbZ/wakFAmbThJUOHH5Ad29sZnNk
ZW4uY3oACgkQL7/ufbZ/wakiIxAAtyvkn/w07y7vd+U9Ia3HBZkLI2jSh7uxV9cM
ItH0N8VijlKSNZ+FkbEPOLy0cX4ZOl2IxWuPwWru0X/F0/jxzMLuhNg4tDeIFmdk
tNUe9E6dqC8edW/mlRjp46iYog3Kbswqi0QSptyz/BRnQSGvzt1lovYS53U6Uhnh
5KataskocP5GeTUEioh1Ivd7EjryxRK/eduvk78sv+U2TFFqOYc7me90A8TYcZGk
YYRCwsSFIaxE7Uk6AFpLHR6OXt81y9kGU4TOPXW+r2OxAcobw7ShRBTmnzeobmlO
DEcPgdNSwYSEZY0ate29dJ7yXx3tKHHZFaHz30NisK8X2GdEsnkf/OhHk0T18FdJ
VBDAwKnT8dqWVUg0K7bCLPBhi6DPZoduikNrK1GxJjXplBuiuzyiAcrr9E1f3/sG
utPk+aUOoZfptCtH6ukLyK3+0xFysQHqSdYtawloXrli9GeZ7fL0FezyqwXX2bEs
2Zrmtfic4hz2HDzCZlWk1uw7tWlrPg5BuTrrR02DpSFpQTK4AXDuq4Lp9IosH9hY
qNvrwId2TCgvF9hzenGczADY2Ho2F88sxQnbuF2PZsP5kUMxcIvW+ssZ0zRprD0S
AtBNTxkVIZFspihCvhoxfhyCNng75xoEZeoNG512S8uFPftREuRLNqzDEqteyk+2
NH4hUco=
=/jnY
-----END PGP SIGNATURE-----

L
L
Liliana Marie Prikler wrote on 1 Sep 08:45 +0200
4b00fcb4424a4cd31d058ad79f8804edf5bffa77.camel@gmail.com
Am Samstag, dem 31.08.2024 um 23:01 +0200 schrieb Tomas Volf:
Toggle quote (30 lines)
> The emacs-yaml package is configured to build against emacs-minimal,
> which seems to work.  When you however switch to emacs package, it
> takes way to long to build, much longer than compiling for example
> firefox package.  That feels off.
>
> --8<---------------cut here---------------start------------->8---
> $ time guix time-machine -q --
> commit=b8327cb31199fb9f4ebed6c53a59601d41def5a1 -- build --check --
> no-grafts -q --with-input=emacs-minimal=emacs-minimal emacs-yaml
> /gnu/store/8lqdd8yna92zqgsgip396a1wbyhr5pfn-emacs-yaml-0.5.5
> 12.573 secs
> $ time guix time-machine -q --
> commit=b8327cb31199fb9f4ebed6c53a59601d41def5a1 -- build --check --
> no-grafts -q --with-input=emacs-minimal=emacs emacs-yaml
> /gnu/store/ja9xfndhfafjczp6n7qfy1h21hvdpd5j-emacs-yaml-0.5.5
> 2869.878 secs
> --8<---------------cut here---------------end--------------->8---
>
> The difference is huge.  The process taking vast majority of the time
> (in the emacs version) is this one:
>
> --8<---------------cut here---------------start------------->8---
> 32393 guixbuil 47:10 {.emacs-29.4-rea}
> /gnu/store/y7yhpgi48klqpadrmfknl4bln9c4n05y-emacs-29.4/bin/emacs -no-
> comp-spawn -Q --batch -l /tmp/guix-build-emacs-yaml-0.5.5.drv-
> 0/emacs-int-comp-yaml-pbHFU3.el
> --8<---------------cut here---------------end--------------->8---
>
> I do not know enough to even guess what could be the problem, but it
> was suggested I should bug-report this.
This issue has already been reported updstream [1], but not addressed
yet: What takes so long between emacs-minimal and plain emacs is the
fact that plain emacs does native compilation.

emacs-build-system currently uses native compilation whenever that is
supported by the emacs used to build. Perhaps we should allow for some
choice here – ideas welcome.

Cheers

?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 72921@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 72921
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch