[PATCH 0/1] Update Minetest to 5.9.0 (again)

  • Done
  • quality assurance status badge
Details
3 participants
  • Leo Famulari
  • Liliana Marie Prikler
  • Jan Wielkiewicz
Owner
unassigned
Submitted by
Jan Wielkiewicz
Severity
normal
J
J
Jan Wielkiewicz wrote on 31 Aug 12:52 +0200
(address . guix-patches@gnu.org)(name . Jan Wielkiewicz)(address . tona_kosmicznego_smiecia@interia.pl)
cover.1725057692.git.tona_kosmicznego_smiecia@interia.pl
Sending again after sending guix lint messages.

Minetest got updated to 5.9.0. This was a big update with major changes.
Minetest Game (MTG) got dropped - is not longer the official game for the
Minetest engine, and got debundled from default Minetest (engine) shipped
to players. Hence I'm debundling it from this Guix package renamed from
"minetest-data" to "minetest-minetest-game" and deprecated the former package.
In this release irrlicht-for-minetest got merged into Minetest's tree, so
I'm deprecating the package. I also had to adjust the minetest build system
to use the new "minetest-minetest-game" package for testing.
MTG also entered maintenance-only mode and became a rolling release,
so I picked the latest commit from the master branch for it instead of git tags.

Minetest build system actually makes a pretty ugly assumption -
that all minetest mods are mods for MTG, while the game supports
mods for any minetest game (for example Voxelibre, Nodecore and such).
So testing all mods against MTG makes no sense, but it will addressed in
future commits.

Jan Wielkiewicz (1):
gnu: minetest: update to 5.9.0.

gnu/packages/games.scm | 24 +---
gnu/packages/minetest.scm | 239 +++++++++++++++++----------------
guix/build-system/minetest.scm | 4 +
3 files changed, 130 insertions(+), 137 deletions(-)


base-commit: d5312370b46ace47e138d84e1bb28e5651cee94b
--
2.45.2
J
J
Jan Wielkiewicz wrote on 31 Aug 12:54 +0200
[PATCH 1/1] gnu: minetest: update to 5.9.0.
(address . 72912@debbugs.gnu.org)(name . Jan Wielkiewicz)(address . tona_kosmicznego_smiecia@interia.pl)
9633e961c2bed508ed8eb3159141170838a768bb.1725057692.git.tona_kosmicznego_smiecia@interia.pl
* gnu/packages/minetest.scm (minetest): Update to 5.9.0.
(minetest-data): Update to 88ecab3.
Rename to (minetest-minetest-game),
deprecate (minetest-data). Minetest Game stopped being
the official game for the Minetest engine.

* gnu/packages/games.scm (irrlicht-for-minetest):
deprecate as it was merged into upstream minetest.

* guix/build-system/minetest.scm:
add (default-minetest-game), use in
(standard-minetest-packages).

Change-Id: I0117bd33a2ce5eb1c79fdb29878682081f61dd4e
---
gnu/packages/games.scm | 24 +---
gnu/packages/minetest.scm | 239 +++++++++++++++++----------------
guix/build-system/minetest.scm | 4 +
3 files changed, 130 insertions(+), 137 deletions(-)

Toggle diff (352 lines)
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 8e35df0278..3b5c6c9544 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -83,6 +83,7 @@
;;; Copyright © 2024 Vagrant Cascadian <vagrant@debian.org>
;;; Copyright © 2024 Sébastien Lerique <sl@eauchat.org>
;;; Copyright © 2024 James Smith <jsubuntuxp@disroot.org>
+;;; Copyright © 2024 Jan Wielkiewicz <tona_kosmicznego_smiecia@interia.pl>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -3954,29 +3955,6 @@ (define-public irrlicht
(home-page "https://irrlicht.sourceforge.io/")
(license license:zlib)))
-(define-public irrlicht-for-minetest
- (package
- (inherit irrlicht)
- (name "irrlicht-for-minetest")
- (version "1.9.0mt13")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/minetest/irrlicht")
- (commit version)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "11pxg0yh50ym1hvh8va5jbbcjz5dsshj3xxvm3qhkgg96vpism06"))))
- (build-system cmake-build-system)
- (arguments
- ;; No check target.
- (list #:tests? #f))
- (inputs
- (modify-inputs (package-inputs irrlicht)
- (prepend libxi)))))
-
(define-public mars
;; The latest release on SourceForge relies on an unreleased version of SFML
;; with a different API, so we take the latest version from the official
diff --git a/gnu/packages/minetest.scm b/gnu/packages/minetest.scm
index 831ccf6e72..26764bfba8 100644
--- a/gnu/packages/minetest.scm
+++ b/gnu/packages/minetest.scm
@@ -8,6 +8,7 @@
;;; Copyright © 2021 Trevor Hass <thass@okstate.edu>
;;; Copyright © 2020, 2021, 2022 Liliana Marie Prikler <liliana.prikler@gmail.com>
;;; Copyright © 2021 Maxime Devos <maximedevos@telenet.be>
+;;; Copyright © 2024 Jan Wielkiewicz <tona_kosmicznego_smiecia@interia.pl>
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
@@ -29,7 +30,6 @@ (define-module (gnu packages minetest)
#:use-module (gnu packages compression)
#:use-module (gnu packages curl)
#:use-module (gnu packages fontutils)
- #:use-module (gnu packages games)
#:use-module (gnu packages gettext)
#:use-module (gnu packages gl)
#:use-module (gnu packages image)
@@ -53,105 +53,106 @@ (define-module (gnu packages minetest)
(define-public minetest
(package
(name "minetest")
- (version "5.8.0")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/minetest/minetest")
- (commit version)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1sww17h8z77w38jk19nsqxn8xcj27msq0glbil7pyj4i0ffprjrr"))
- (modules '((guix build utils)))
- (snippet
- '(begin
- ;; Delete bundled libraries.
- (delete-file-recursively "lib")
- #t))))
+ (version "5.9.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/minetest/minetest")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1h4yn4k0wpjr1h24aiqcnc9xsxgxj4bq757pla2pa9zmh2xf45kk"))
+ (modules '((guix build utils)))
+ ;; Delete bundled libraries, keep lib/sha256 because there's no good
+ ;; upstream, see:
+ ;; https://github.com/openssl/openssl/blob/master/crypto/sha/sha512.c
+ ;; "SHA512 low level APIs are deprecated for public use,
+ ;; but still ok for internal use." Also asked MT devs on IRC for this.
+ (snippet
+ '(begin
+ (with-directory-excursion "lib"
+ (for-each (lambda (file)
+ (if (not (string=? file "sha256"))
+ (delete-file-recursively file)))
+ (find-files (string-append "lib") #:directories? #t)))
+ #t))))
(build-system cmake-build-system)
(arguments
(list
#:configure-flags
- #~(list "-DRUN_IN_PLACE=0"
- "-DENABLE_FREETYPE=1"
- "-DENABLE_GETTEXT=1"
- "-DENABLE_SYSTEM_JSONCPP=TRUE"
- (string-append "-DIRRLICHTMT_INCLUDE_DIR="
- (search-input-directory %build-inputs
- "include/irrlichtmt"))
+ #~(list "-DENABLE_LTO=ON"
+ "-DENABLE_UPDATE_CHECKER=FALSE"
(string-append "-DCURL_INCLUDE_DIR="
- (search-input-directory %build-inputs
- "include/curl"))
+ (search-input-directory
+ %build-inputs "include/curl"))
(string-append "-DZSTD_INCLUDE_DIR="
- (dirname
- (search-input-file %build-inputs
- "include/zstd.h")))
+ (dirname (search-input-file
+ %build-inputs
+ "include/zstd.h")))
(string-append "-DZSTD_LIBRARY="
- (search-input-file %build-inputs
- "lib/libzstd.so")))
- #:phases
- #~(modify-phases %standard-phases
- (add-after 'unpack 'patch-sources
- (lambda* (#:key inputs #:allow-other-keys)
- (substitute* "src/filesys.cpp"
- ;; Use store-path for "rm" instead of non-existing FHS path.
- (("\"/bin/rm\"")
- (format #f "~s" (search-input-file inputs "bin/rm"))))
- (substitute* "src/CMakeLists.txt"
- ;; Let minetest binary remain in build directory.
- (("set\\(EXECUTABLE_OUTPUT_PATH .*\\)") ""))
- (substitute* "src/unittest/test_servermodmanager.cpp"
- ;; do no override MINETEST_SUBGAME_PATH
- (("(un)?setenv\\(\"MINETEST_SUBGAME_PATH\".*\\);")
- "(void)0;"))
- (setenv "MINETEST_SUBGAME_PATH" ; for check
- (string-append (getcwd) "/games"))))
- (delete 'check)
- (add-after 'install 'check
- (lambda* (#:key tests? #:allow-other-keys)
- ;; Thanks to our substitutions, the tests should also run
- ;; when invoked on the target outside of `guix build'.
- (when tests?
- (setenv "HOME" "/tmp")
- (invoke "src/minetest" "--run-unittests")))))))
+ (search-input-file
+ %build-inputs "lib/libzstd.so")))
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'patch-sources
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "src/filesys.cpp"
+ ;; Use store-path for "rm" instead of non-existing FHS path.
+ (("\"/bin/rm\"")
+ (format #f "~s"
+ (search-input-file inputs "bin/rm"))))
+ (substitute* "src/CMakeLists.txt"
+ ;; Let minetest binary remain in build directory.
+ (("set\\(EXECUTABLE_OUTPUT_PATH .*\\)")
+ ""))
+ (substitute* "src/unittest/test_servermodmanager.cpp"
+ ;; do no override MINETEST_GAME_PATH
+ (("(un)?setenv\\(\"MINETEST_GAME_PATH\".*\\);")
+ "(void)0;"))
+ (setenv "MINETEST_GAME_PATH" ;for check
+ (string-append (getcwd) "/games"))))
+ (delete 'check)
+ (add-after 'install 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ ;; Thanks to our substitutions, the tests should also run
+ ;; when invoked on the target outside of `guix build'.
+ (when tests?
+ (setenv "HOME" "/tmp")
+ (invoke "src/minetest" "--run-unittests")))))))
(native-search-paths
(list (search-path-specification
- (variable "MINETEST_SUBGAME_PATH")
+ (variable "MINETEST_GAME_PATH")
(files '("share/minetest/games")))
(search-path-specification
(variable "MINETEST_MOD_PATH")
(files '("share/minetest/mods")))))
- (native-inputs
- (list pkg-config))
- (inputs
- (list coreutils
- curl
- freetype
- gettext-minimal
- gmp
- irrlicht-for-minetest
- jsoncpp
- libjpeg-turbo
- libpng
- libogg
- libvorbis
- libxxf86vm
- luajit
- mesa
- ncurses
- openal
- sqlite
- `(,zstd "lib")))
- (propagated-inputs
- (list minetest-data))
- (synopsis "Infinite-world block sandbox game")
+ (native-inputs (list pkg-config))
+ (inputs (list coreutils
+ curl
+ freetype
+ gettext-minimal
+ gmp
+ jsoncpp
+ libjpeg-turbo
+ libpng
+ libogg
+ libvorbis
+ libxxf86vm
+ libxi
+ luajit
+ mesa
+ ncurses
+ openal
+ sqlite
+ `(,zstd "lib")))
+ (synopsis "Voxel game and game engine")
(description
- "Minetest is a sandbox construction game. Players can create and destroy
-various types of blocks in a three-dimensional open world. This allows
-forming structures in every possible creation, on multiplayer servers or as a
-single player. Mods and texture packs allow players to personalize the game
-in different ways.")
+ "Minetest is a voxel game engine with easy modding and game creation
+using its Lua modding API. It allows playing a wide range of voxel-based
+games, installing mods and texture packs. This package only provides the base
+platform, users need to install games themselves (either through Guix, the
+built-in interface or other sources).")
(home-page "https://www.minetest.net/")
(license license:lgpl2.1+)))
@@ -183,35 +184,45 @@ (define-public minetest-server
"openal")))
(synopsis "Infinite-world block sandbox game (server)")
(description
- "Minetest is a sandbox construction game. Players can create and destroy
-various types of blocks in a three-dimensional open world. This allows
-forming structures in every possible creation, on multiplayer servers or as a
-single player. Mods and texture packs allow players to personalize the game
-in different ways. This package provides @command{minetestserver} to run a
-Minetest server.")))
+ "Server for Minetest game engine and gaming platform. Allows hosting
+Minetest games with multiplayer support. This package provides
+@command{minetestserver} to run a Minetest server.")))
-(define minetest-data
- (package
- (name "minetest-data")
- (version (package-version minetest))
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/minetest/minetest_game")
- (commit version)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1pq4rm15lzwcqv6npgyz6v89hi3zj8zybw25n9i0d27qj786xc4z"))))
- (build-system copy-build-system)
- (arguments
- (list #:install-plan
- #~'(("." "/share/minetest/games/minetest_game"))))
- (synopsis "Main game data for the Minetest game engine")
- (description
- "Game data for the Minetest infinite-world block sandbox game.")
- (home-page "https://www.minetest.net/")
- (license license:lgpl2.1+)))
+(define-public minetest-minetest-game
+ (let ((branch "master")
+ (commit "88ecab34d98550c8eb77f49ac2866b480a6e707a"))
+ (package
+ (name "minetest-minetest-game")
+ (version (git-version branch "0" commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/minetest/minetest_game")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0pvr3m7kxrriabw20sy6rhx0givh5ic85dk5g88cbbsy83admsp0"))))
+ (build-system copy-build-system)
+ (arguments
+ (list
+ #:install-plan #~'(("." "/share/minetest/games/minetest_game"))))
+ (synopsis "Ex-official game for Minetest game engine")
+ (description
+ "A game for the Minetest voxel game platform. It provides a very basic
+Minecraft-like base for some mods. It is currently in maintenance mode
+and gets no new features.")
+ (home-page "https://www.minetest.net/")
+ (license license:lgpl2.1+))))
+
+;; This package is deprecated. MTG is no longer the official game.
+(define-public minetest-data
+ (deprecated-package "minetest-data" minetest-minetest-game))
+
+;; Minetest merged its irrlicht fork into the minetest repo
+;; this package is not used outside of minetest, hence I deprecate it.
+(define-public irrlicht-for-minetest
+ (deprecated-package "irrlicht-for-minetest" minetest))
(define-public (minetest-topic topic-id)
"Return an URL (as a string) pointing to the forum topic with
diff --git a/guix/build-system/minetest.scm b/guix/build-system/minetest.scm
index 1fae3a47e9..85459f905c 100644
--- a/guix/build-system/minetest.scm
+++ b/guix/build-system/minetest.scm
@@ -37,6 +37,9 @@ (define (default-optipng)
(define (default-minetest)
(module-ref (resolve-interface '(gnu packages minetest)) 'minetest))
+(define (default-minetest-game)
+ (module-ref (resolve-interface '(gnu packages minetest)) 'minetest-minetest-game))
+
(define (default-xvfb-run)
(module-ref (resolve-interface '(gnu packages xorg)) 'xvfb-run))
@@ -57,6 +60,7 @@ (define (standard-minetest-packages)
`(("xvfb-run" ,(default-xvfb-run))
("optipng" ,(default-optipng))
("minetest" ,(default-minetest))
+ ("minetest-game" ,(default-minetest-game))
,@(filter (lambda (input)
(member (car input)
'("libc" "tar" "gzip" "bzip2" "xz" "locales")))
--
2.45.2
L
L
Liliana Marie Prikler wrote on 31 Aug 13:40 +0200
Re: [bug#72912] [PATCH 0/1] Update Minetest to 5.9.0 (again)
438cb9c032652d3ba32ae927121e58adb5c82abd.camel@gmail.com
Am Samstag, dem 31.08.2024 um 12:52 +0200 schrieb Jan Wielkiewicz:
Toggle quote (1 lines)
> Sending again after sending guix lint messages.
Note for future submissions: it's okay (and even expected) to use --
reroll-count while sending the revised patch to the same address as the
original one.

Toggle quote (6 lines)
> Minetest got updated to 5.9.0. This was a big update with major
> changes. Minetest Game (MTG) got dropped - is not longer the
> official game for the Minetest engine, and got debundled from default
> Minetest (engine) shipped to players. Hence I'm debundling it from
> this Guix package renamed from "minetest-data" to "minetest-minetest-
> game" and deprecated the former package.
That's a somewhat unfortunate name. Is there no better name to choose?
Is there a reason not to use "minetest-game" for example?

Toggle quote (6 lines)
> In this release irrlicht-for-minetest got merged into Minetest's
> tree, so I'm deprecating the package. I also had to adjust the
> minetest build system to use the new "minetest-minetest-game" package
> for testing. MTG also entered maintenance-only mode and became a
> rolling release, so I picked the latest commit from the master branch
> for it instead of git tags.
We also like to unbundle such dependencies. Is there a way forward for
doing so?

Toggle quote (5 lines)
> Minetest build system actually makes a pretty ugly assumption -
> that all minetest mods are mods for MTG, while the game supports
> mods for any minetest game (for example Voxelibre, Nodecore and
> such). So testing all mods against MTG makes no sense, but it will
> addressed in future commits.
Sounds like a plan.

Cheers
J
J
Jan Wielkiewicz wrote on 31 Aug 14:26 +0200
(name . Liliana Marie Prikler)(address . liliana.prikler@gmail.com)
20240831142605.29484112@interia.pl
On Sat, 31 Aug 2024 13:40:02 +0200
Liliana Marie Prikler <liliana.prikler@gmail.com> wrote:

Toggle quote (6 lines)
> Am Samstag, dem 31.08.2024 um 12:52 +0200 schrieb Jan Wielkiewicz:
> > Sending again after sending guix lint messages.
> Note for future submissions: it's okay (and even expected) to use --
> reroll-count while sending the revised patch to the same address as
> the original one.

Okay, will do so. I missed that in documentation.

Toggle quote (9 lines)
> > Minetest got updated to 5.9.0. This was a big update with major
> > changes. Minetest Game (MTG) got dropped - is not longer the
> > official game for the Minetest engine, and got debundled from
> > default Minetest (engine) shipped to players. Hence I'm debundling
> > it from this Guix package renamed from "minetest-data" to
> > "minetest-minetest- game" and deprecated the former package.
> That's a somewhat unfortunate name. Is there no better name to
> choose? Is there a reason not to use "minetest-game" for example?

The minetest-something convention is for packages that are either
games for minetest or mods for any minetest game. Minetest - the engine
executes games. Previously "Minetest Game" was the default game for
Minetest (the engine), but is not anymore. A similar example would be a
game called "MineClone" for Minetest, the package is then called
minetest-mineclone. But "Minetest Game" is indeed the name of the
ex-default game, hence minetest-minetest-game. "minetest-game" would
suggest it's a game for minetest named "game" also could make it
possible to confuse it with simply "minetest" - the engine.

I know it's convoluted, but the naming ambiguity is inherited from the
upstream project. I believe this redundant name makes it clearer.

Toggle quote (9 lines)
> > In this release irrlicht-for-minetest got merged into Minetest's
> > tree, so I'm deprecating the package. I also had to adjust the
> > minetest build system to use the new "minetest-minetest-game"
> > package for testing. MTG also entered maintenance-only mode and
> > became a rolling release, so I picked the latest commit from the
> > master branch for it instead of git tags.
> We also like to unbundle such dependencies. Is there a way forward
> for doing so?

There's no unbundling to be done here. Minetest was the sole user of
irrlicht-for-minetest. Minetest developers moved irrlicht directly into
the game's code and the two components are tightly coupled. The
irrlicht fork has been archived: https://github.com/minetest/irrlicht
So the irrlicht-for-minetest code that was moved into Minetest is now
considered to be a non-replaceable non-modular part of the code that's
not meant to be anywhere but in Minetest only. On top of that it's not
longer possible to use upstream irrlicht in Minetest, hence the
decision to move the fork into the game's tree directly.

Toggle quote (10 lines)
>
> > Minetest build system actually makes a pretty ugly assumption -
> > that all minetest mods are mods for MTG, while the game supports
> > mods for any minetest game (for example Voxelibre, Nodecore and
> > such). So testing all mods against MTG makes no sense, but it will
> > addressed in future commits.
> Sounds like a plan.
>
> Cheers

Hope this makes it clear.

--

Jan Wielkiewicz
L
L
Leo Famulari wrote on 5 Sep 21:17 +0200
(name . Jan Wielkiewicz)(address . tona_kosmicznego_smiecia@interia.pl)
ZtoD5NPPnYSgOqZG@jasmine.lan
Hi Jan,

Thanks so much for performing this complicated upgrade! I confirm it
works fine to play Minetest.

On Sat, Aug 31, 2024 at 02:26:05PM +0200, Jan Wielkiewicz wrote:
Toggle quote (11 lines)
> The minetest-something convention is for packages that are either
> games for minetest or mods for any minetest game. Minetest - the engine
> executes games. Previously "Minetest Game" was the default game for
> Minetest (the engine), but is not anymore. A similar example would be a
> game called "MineClone" for Minetest, the package is then called
> minetest-mineclone. But "Minetest Game" is indeed the name of the
> ex-default game, hence minetest-minetest-game. "minetest-game" would
> suggest it's a game for minetest named "game" also could make it
> possible to confuse it with simply "minetest" - the engine.
> The name of the package: https://github.com/minetest/minetest_game

We have similar conventions for other packages in Guix, such as Python
modules.

But if a Python program is named by its authors "python-foo", we do not
package it as "python-python-foo". Well, there is one package like this
currently, but that's one mistake, after we avoided the repetitive names
many times.

I think that if somebody wants to play the basic Minetest game, they
will not have much trouble choosing the package called "minetest-game".

I've attached a diff against your patch that makes that change and some
other minor changes.

Specifically:

It tweaks the description of the minetest engine packages to remove the
"marketing" word "easy", as requested in the guidelines on writing
package descriptions:


It also uses "minetest-game" as an example of a game that could be
installed based on this engine. Or should we use mineclone? We don't
have any other games packaged, right?

It adjusts the version procedure of minetest-game to respect the
guidlines in the manual section Version Numbers:


It removes irrlicht-for-minetest entirely. I don't think we need to
deprecate libraries that wouldn't have been installed into someone's
profile.

I'm not as sure about minetest-data. Was that something that people
would install? I never needed to in order to play the minetest game.

What do you think?
From f29b6d80484f6d702a023a85bc51e55b83175e62 Mon Sep 17 00:00:00 2001
Message-ID: <f29b6d80484f6d702a023a85bc51e55b83175e62.1725563587.git.leo@famulari.name>
From: Leo Famulari <leo@famulari.name>
Date: Thu, 5 Sep 2024 15:00:10 -0400
Subject: [PATCH] WIP

Change-Id: Iaa3ae3314de1da287f296648699ff26cdb59c96e
---
gnu/packages/minetest.scm | 24 ++++++++++--------------
guix/build-system/minetest.scm | 2 +-
2 files changed, 11 insertions(+), 15 deletions(-)

Toggle diff (69 lines)
diff --git a/gnu/packages/minetest.scm b/gnu/packages/minetest.scm
index 26764bfba8..d3c7fcde5d 100644
--- a/gnu/packages/minetest.scm
+++ b/gnu/packages/minetest.scm
@@ -148,11 +148,12 @@ (define-public minetest
`(,zstd "lib")))
(synopsis "Voxel game and game engine")
(description
- "Minetest is a voxel game engine with easy modding and game creation
+ "Minetest is a voxel game engine that supports modding and game creation
using its Lua modding API. It allows playing a wide range of voxel-based
games, installing mods and texture packs. This package only provides the base
-platform, users need to install games themselves (either through Guix, the
-built-in interface or other sources).")
+platform, users need to install games themselves (for example,
+@code{minetest-game}), either through Guix, the built-in interface or other
+sources.")
(home-page "https://www.minetest.net/")
(license license:lgpl2.1+)))
@@ -188,12 +189,12 @@ (define-public minetest-server
Minetest games with multiplayer support. This package provides
@command{minetestserver} to run a Minetest server.")))
-(define-public minetest-minetest-game
- (let ((branch "master")
- (commit "88ecab34d98550c8eb77f49ac2866b480a6e707a"))
+(define-public minetest-game
+ (let ((commit "88ecab34d98550c8eb77f49ac2866b480a6e707a")
+ (revision "0"))
(package
- (name "minetest-minetest-game")
- (version (git-version branch "0" commit))
+ (name "minetest-game")
+ (version (git-version "0.0.0" revision commit))
(source
(origin
(method git-fetch)
@@ -217,12 +218,7 @@ (define-public minetest-minetest-game
;; This package is deprecated. MTG is no longer the official game.
(define-public minetest-data
- (deprecated-package "minetest-data" minetest-minetest-game))
-
-;; Minetest merged its irrlicht fork into the minetest repo
-;; this package is not used outside of minetest, hence I deprecate it.
-(define-public irrlicht-for-minetest
- (deprecated-package "irrlicht-for-minetest" minetest))
+ (deprecated-package "minetest-data" minetest-game))
(define-public (minetest-topic topic-id)
"Return an URL (as a string) pointing to the forum topic with
diff --git a/guix/build-system/minetest.scm b/guix/build-system/minetest.scm
index 85459f905c..9774c5882a 100644
--- a/guix/build-system/minetest.scm
+++ b/guix/build-system/minetest.scm
@@ -38,7 +38,7 @@ (define (default-minetest)
(module-ref (resolve-interface '(gnu packages minetest)) 'minetest))
(define (default-minetest-game)
- (module-ref (resolve-interface '(gnu packages minetest)) 'minetest-minetest-game))
+ (module-ref (resolve-interface '(gnu packages minetest)) 'minetest-game))
(define (default-xvfb-run)
(module-ref (resolve-interface '(gnu packages xorg)) 'xvfb-run))

base-commit: 2d54ea6c8cc0a0bbb0c39d90d080fcf572533205
--
2.45.2
J
J
Jan Wielkiewicz wrote on 6 Sep 01:05 +0200
(name . Leo Famulari)(address . leo@famulari.name)
20240906010548.1eab8fb1@interia.pl
Hi,

On Thu, 5 Sep 2024 15:17:56 -0400
Leo Famulari <leo@famulari.name> wrote:

Toggle quote (30 lines)
> Hi Jan,
>
> Thanks so much for performing this complicated upgrade! I confirm it
> works fine to play Minetest.
>
> On Sat, Aug 31, 2024 at 02:26:05PM +0200, Jan Wielkiewicz wrote:
> > The minetest-something convention is for packages that are either
> > games for minetest or mods for any minetest game. Minetest - the
> > engine executes games. Previously "Minetest Game" was the default
> > game for Minetest (the engine), but is not anymore. A similar
> > example would be a game called "MineClone" for Minetest, the
> > package is then called minetest-mineclone. But "Minetest Game" is
> > indeed the name of the ex-default game, hence
> > minetest-minetest-game. "minetest-game" would suggest it's a game
> > for minetest named "game" also could make it possible to confuse it
> > with simply "minetest" - the engine. The name of the
> > package: https://github.com/minetest/minetest_game
>
> We have similar conventions for other packages in Guix, such as Python
> modules.
>
> But if a Python program is named by its authors "python-foo", we do
> not package it as "python-python-foo". Well, there is one package
> like this currently, but that's one mistake, after we avoided the
> repetitive names many times.
>
> I think that if somebody wants to play the basic Minetest game, they
> will not have much trouble choosing the package called
> "minetest-game".

Well, I guess "minetest-game" should be fine then.

Toggle quote (3 lines)
> I've attached a diff against your patch that makes that change and
> some other minor changes.

Do I need to apply the patch and resend it or will a maintainer take
care of that?

Toggle quote (8 lines)
> Specifically:
>
> It tweaks the description of the minetest engine packages to remove
> the "marketing" word "easy", as requested in the guidelines on writing
> package descriptions:
>
> https://guix.gnu.org/manual/devel/en/html_node/Synopses-and-Descriptions.html

Looks good.

Toggle quote (4 lines)
> It also uses "minetest-game" as an example of a game that could be
> installed based on this engine. Or should we use mineclone? We don't
> have any other games packaged, right?

There are multiple games for Minetest, most of them listed on ContentDB
The general idea is that after dropping MTG as the default, it's up to
the user to pick what they want to play. ContentDB can be also accessed
in the game and the game upon the first startup instructs the user to
install a game. ContentDB has a relatively strict policy for package
Most games/mods are free software, some packages that aren't are
clearly marked as such with red text. Most importantly Minetest by
default hides non-free packages from ContentDB in the game. So it
should be fine to let users pick a game they like from ContentDB.

I think that Mineclone is not the best default game because it does a
1:1 copy of Minecraft. It is free software and assets are free, but a
1:1 copy is legally questionable. That's why I believe we shouldn't ship
Minetest with any game preinstalled.

On a side note, I plan updating existing Minetest packages and adding
more games for it, but this work should be merged first.

Toggle quote (9 lines)
> It adjusts the version procedure of minetest-game to respect the
> guidlines in the manual section Version Numbers:
>
> https://guix.gnu.org/manual/en/html_node/Version-Numbers.html
>
> It removes irrlicht-for-minetest entirely. I don't think we need to
> deprecate libraries that wouldn't have been installed into someone's
> profile.

Makes sense.

Toggle quote (3 lines)
> I'm not as sure about minetest-data. Was that something that people
> would install? I never needed to in order to play the minetest game.

People still play this, in fact it has hundreds of mods and is still
the second most popular game, it's just not official anymore. Also the
input was propagated so it makes sense to replace it with the new
"minetest-game" package I guess? If people don't want it they can still
remove it. But new installs shouldn't get this installed by default.
Long story short Minetest devs considered MTG was a bad advertisement
for the project also a waste of their resources and decided to focus on
the engine instead.

Toggle quote (2 lines)
> What do you think?

Looks good.

--

Jan
L
L
Leo Famulari wrote on 6 Sep 04:48 +0200
(name . Jan Wielkiewicz)(address . tona_kosmicznego_smiecia@interia.pl)
ZtptiJHWEw1hKC16@jasmine.lan
On Fri, Sep 06, 2024 at 01:05:48AM +0200, Jan Wielkiewicz wrote:
Toggle quote (3 lines)
> Do I need to apply the patch and resend it or will a maintainer take
> care of that?

I prepared an updated patch (attached).

There's something I don't quite understand:

The "minetest-game" package doesn't provide any executables. It's just
data.

The "minetest" package still runs and lets me play the basic minetest
game locally or on a server.

Is that expected? I would have expected differently based on the news
about the removal of the game from the engine's codebase.

Leo
J
J
Jan Wielkiewicz wrote on 6 Sep 17:15 +0200
(name . Leo Famulari)(address . leo@famulari.name)
20240906171513.58c156b1@interia.pl
On Thu, 5 Sep 2024 22:48:40 -0400
Leo Famulari <leo@famulari.name> wrote:

Toggle quote (17 lines)
> On Fri, Sep 06, 2024 at 01:05:48AM +0200, Jan Wielkiewicz wrote:
> > Do I need to apply the patch and resend it or will a maintainer take
> > care of that?
>
> I prepared an updated patch (attached).
>
> There's something I don't quite understand:
>
> The "minetest-game" package doesn't provide any executables. It's just
> data.
>
> The "minetest" package still runs and lets me play the basic minetest
> game locally or on a server.
>
> Is that expected? I would have expected differently based on the news
> about the removal of the game from the engine's codebase.

The Minetest engine is written in C++ but provides a modding Lua API.
Games and mods are written in Lua and Minetest (the engine) executes
them in a similar fashion as Emacs does to Elisp scripts or a web
browser does to JavaScript. Minetest Game (MTG) was previously the
default game and came preinstalled with the engine (the minetest-data
package).

So doing "guix install minetest" should give you only the "engine" and
this is what you should see after starting:

If you see the minetest game installed along minetest that probably
means you had the older Minetest install in your profile and that
minetest-data got replaced by "minetest-game". An alternative
explanation is having MTG installed manually in
~/.minetest/games/minetest_game

Toggle quote (1 lines)
> Leo
L
L
Leo Famulari wrote on 6 Sep 19:45 +0200
(name . Jan Wielkiewicz)(address . tona_kosmicznego_smiecia@interia.pl)
Zts_thcbbB3j6G09@jasmine.lan
On Fri, Sep 06, 2024 at 05:15:13PM +0200, Jan Wielkiewicz wrote:
Toggle quote (4 lines)
> So doing "guix install minetest" should give you only the "engine" and
> this is what you should see after starting:
> https://p.mort.coffee/4Og.png

Okay, I don't see that but rather the interface to launch the Minetest
game.

Toggle quote (6 lines)
> If you see the minetest game installed along minetest that probably
> means you had the older Minetest install in your profile and that
> minetest-data got replaced by "minetest-game". An alternative
> explanation is having MTG installed manually in
> ~/.minetest/games/minetest_game

That must be it.

So, I'm wondering if minetest-game should depend on or even propagate
minetest? Like, what is the correct method for a new user to install and
run the Minetest game with Minetest 5.9.0?
L
L
Liliana Marie Prikler wrote on 6 Sep 20:19 +0200
f671dcb138cdb6221e309a33106e5810fd7e57c9.camel@gmail.com
Am Freitag, dem 06.09.2024 um 13:45 -0400 schrieb Leo Famulari:
Toggle quote (3 lines)
> So, I'm wondering if minetest-game should depend on or even propagate
> minetest? Like, what is the correct method for a new user to install
> and run the Minetest game with Minetest 5.9.0?
I would guess it's `guix install minetest minetest-game', but note that
you could also have `guix install minetest minetest-mineclone`. I
would use the same pattern that we already use for Guile, Emacs, etc.
and just require that the base package be in the profile.

Cheers
J
J
Jan Wielkiewicz wrote 7 days ago
(name . Liliana Marie Prikler)(address . liliana.prikler@gmail.com)
20240909233730.2640e1f5@interia.pl
On Fri, 06 Sep 2024 20:19:06 +0200
Liliana Marie Prikler <liliana.prikler@gmail.com> wrote:

Toggle quote (11 lines)
> Am Freitag, dem 06.09.2024 um 13:45 -0400 schrieb Leo Famulari:
> > So, I'm wondering if minetest-game should depend on or even
> > propagate minetest? Like, what is the correct method for a new user
> > to install and run the Minetest game with Minetest 5.9.0?
> I would guess it's `guix install minetest minetest-game', but note
> that you could also have `guix install minetest minetest-mineclone`.
> I would use the same pattern that we already use for Guile, Emacs,
> etc. and just require that the base package be in the profile.
>
> Cheers

By this you mean I'd have to add minetest as a propagated input for
each package that needs it to run? I could do that, but I believe this
is out of the scope of the current work. I'll update minetest packages
in a future PR and while doing so I'll add minetest to propagated
inputs.

But right now packages don't depend on minetest and putting that in
this issue would be scope creep.

Is there anything else I need to do in order to get this merged?

--

Jan Wielkiewicz
L
L
Liliana Marie Prikler wrote 7 days ago
(name . Jan Wielkiewicz)(address . tona_kosmicznego_smiecia@interia.pl)
f6589d43f9afbf69f5ff6425ebc3b3a5dd35f78f.camel@gmail.com
Am Montag, dem 09.09.2024 um 23:37 +0200 schrieb Jan Wielkiewicz:
Toggle quote (21 lines)
> On Fri, 06 Sep 2024 20:19:06 +0200
> Liliana Marie Prikler <liliana.prikler@gmail.com> wrote:
>
> > Am Freitag, dem 06.09.2024 um 13:45 -0400 schrieb Leo Famulari:
> > > So, I'm wondering if minetest-game should depend on or even
> > > propagate minetest? Like, what is the correct method for a new
> > > user
> > > to install and run the Minetest game with Minetest 5.9.0?
> > I would guess it's `guix install minetest minetest-game', but note
> > that you could also have `guix install minetest minetest-
> > mineclone`.
> > I would use the same pattern that we already use for Guile, Emacs,
> > etc. and just require that the base package be in the profile.
> >
> > Cheers
>
> By this you mean I'd have to add minetest as a propagated input for
> each package that needs it to run? I could do that, but I believe
> this is out of the scope of the current work. I'll update minetest
> packages in a future PR and while doing so I'll add minetest to
> propagated inputs.
No, I mean that it'd be the user who adds minetest on top of whatever
minetest-* they want to their profile, which can be done as-is.

Toggle quote (4 lines)
> But right now packages don't depend on minetest and putting that in
> this issue would be scope creep.
>
> Is there anything else I need to do in order to get this merged?
You would have to look for that in other discussions – I'll check at a
later time.

Cheers
L
L
Leo Famulari wrote 6 days ago
(name . Jan Wielkiewicz)(address . tona_kosmicznego_smiecia@interia.pl)
ZuD5IXgCHBBHe1Ig@jasmine.lan
On Mon, Sep 09, 2024 at 11:37:30PM +0200, Jan Wielkiewicz wrote:
Toggle quote (10 lines)
> Liliana Marie Prikler <liliana.prikler@gmail.com> wrote:
> > Am Freitag, dem 06.09.2024 um 13:45 -0400 schrieb Leo Famulari:
> > > So, I'm wondering if minetest-game should depend on or even
> > > propagate minetest? Like, what is the correct method for a new user
> > > to install and run the Minetest game with Minetest 5.9.0?
> > I would guess it's `guix install minetest minetest-game', but note
> > that you could also have `guix install minetest minetest-mineclone`.
> > I would use the same pattern that we already use for Guile, Emacs,
> > etc. and just require that the base package be in the profile.

Sounds good to me.

Toggle quote (6 lines)
> By this you mean I'd have to add minetest as a propagated input for
> each package that needs it to run? I could do that, but I believe this
> is out of the scope of the current work. I'll update minetest packages
> in a future PR and while doing so I'll add minetest to propagated
> inputs.

Okay, if you like. As Liliana pointed out, propagation may not be
expected in cases like this.

Toggle quote (2 lines)
> Is there anything else I need to do in order to get this merged?

Pushed as ef428cf721861c01e21c96db61330a44e9a5ee28

Thanks again!
Closed
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 72912@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 72912
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch