[PATCH 1/2] gnu: perltidy: Update to 20240511.

  • Open
  • quality assurance status badge
Details
One participant
  • gemmaro
Owner
unassigned
Submitted by
gemmaro
Severity
normal
G
G
gemmaro wrote on 31 Aug 04:39 +0200
(address . guix-patches@gnu.org)(name . gemmaro)(address . gemmaro.dev@gmail.com)
0cd49dd9e8759ad70cbf14543bdda3ecb1e7b2b3.1725071981.git.gemmaro.dev@gmail.com
* gnu/packages/perl.scm (perltidy): Update to 20240511.

Change-Id: I2dc2d6f69169b83dd02756940b97b584c617dbd0
---
gnu/packages/perl.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (25 lines)
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 816aca2d59..5428fd1211 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -11301,14 +11301,14 @@ (define-public perl-throwable
(define-public perltidy
(package
(name "perltidy")
- (version "20180220")
+ (version "20240511")
(source (origin
(method url-fetch)
(uri (string-append "mirror://sourceforge/perltidy/" version
"/Perl-Tidy-" version ".tar.gz"))
(sha256
(base32
- "0w1k5ffcrpx0fm9jgprrwy0290k6cmy7dyk83s61063migi3r5z9"))))
+ "1wk8aicxq5lwvhz4f4nrbx585x7kk8mz1r4w5pf46nlbx669xzs7"))))
(build-system perl-build-system)
(home-page "https://perltidy.sourceforge.net/")
(synopsis "Perl script tidier")

base-commit: df14cacca9b95d69fdd3b6191e42df36af266bcd
--
2.45.2
G
G
gemmaro wrote on 31 Aug 04:39 +0200
[PATCH 2/2] gnu: perltidy: Make the perltidy command available.
(address . guix-patches@gnu.org)(name . gemmaro)(address . gemmaro.dev@gmail.com)
5cb3c41bb522669447f2ac1f4c1ce2fab7c3f2c9.1725071981.git.gemmaro.dev@gmail.com
* gnu/packages/perl.scm (perltidy)[arguments]<#:phases>: Add phases to wrap
the perltidy command and check it works.
[inputs]: Add bash-minimal for wrap-program.

Change-Id: Icef08919409afa508d0ad5a21a59af4a3ce63fbe
---
gnu/packages/perl.scm | 16 ++++++++++++++++
1 file changed, 16 insertions(+)

Toggle diff (29 lines)
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 5428fd1211..8b22279b1d 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -11310,6 +11310,22 @@ (define-public perltidy
(base32
"1wk8aicxq5lwvhz4f4nrbx585x7kk8mz1r4w5pf46nlbx669xzs7"))))
(build-system perl-build-system)
+ (arguments
+ (list
+ #:phases #~(modify-phases %standard-phases
+ (add-after 'install 'wrap-perltidy
+ (lambda _
+ (wrap-program (string-append #$output "/bin/perltidy")
+ (list "PERL5LIB" ":"
+ 'prefix
+ (list (string-append (getenv "PERL5LIB") ":"
+ #$output
+ "/lib/perl5/site_perl"))))))
+ (add-after 'wrap-perltidy 'check-perltidy
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke (string-append #$output "/bin/perltidy"))))))))
+ (inputs (list bash-minimal))
(home-page "https://perltidy.sourceforge.net/")
(synopsis "Perl script tidier")
(description "This package contains a Perl script which indents and
--
2.45.2
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 72898@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 72898
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch