lcrq and lcsync updates

  • Done
  • quality assurance status badge
Details
One participant
  • Vagrant Cascadian
Owner
unassigned
Submitted by
Vagrant Cascadian
Severity
normal

Debbugs page

Vagrant Cascadian wrote 6 months ago
(address . guix-patches@gnu.org)(address . vagrant@debian.org)
87jzfzui51.fsf@wireframe
The forthcoming patches update lcrq to 0.2.1 and lcsync to 0.3.1, and
pass some additional compiler optimizations to the lcrq build.

lcrq, librecast and lcsync all build fine afte rthe fact.

live well,
vagrant
-----BEGIN PGP SIGNATURE-----

iHUEARYKAB0WIQRlgHNhO/zFx+LkXUXcUY/If5cWqgUCZtDpqgAKCRDcUY/If5cW
qoBPAQCrnvTKQ7GbuOuDh/ImUKpKACYODnMj+lZFuu2JpKm0BQD/YrD2YDc+XGO1
GQVRpvbwRgOhfcnVbpcBgypLPzwh1ws=
=L3wr
-----END PGP SIGNATURE-----

vagrant wrote 6 months ago
[PATCH 1/3] gnu: lcrq: Update to 0.2.1.
(address . 72881@debbugs.gnu.org)(address . vagrant@debian.org)
20240829213920.386565-1-vagrant@debian.org
From: Vagrant Cascadian <vagrant@debian.org>

* gnu/packages/networking.scm (lcrq): Update to 0.2.1.
---
gnu/packages/networking.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (26 lines)
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index f4ad280603..eeeb215461 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -275,7 +275,7 @@ (define-public axel
(define-public lcrq
(package
(name "lcrq")
- (version "0.1.2")
+ (version "0.2.1")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -284,7 +284,7 @@ (define-public lcrq
(file-name (git-file-name name version))
(sha256
(base32
- "1m29p4bsafzbchnkidyrnglfdf1c9pnq6akkmivi23qdv9kj51dg"))))
+ "0a6bvlib00na0rhz4lz80kc6v5kqfp8k26ydprwnf8h29nnza6y6"))))
(build-system gnu-build-system)
(arguments
(list

base-commit: d5312370b46ace47e138d84e1bb28e5651cee94b
--
2.39.2
vagrant wrote 6 months ago
[PATCH 2/3] gnu: lcsync: Update to 0.3.1.
(address . 72881@debbugs.gnu.org)(address . vagrant@debian.org)
20240829213920.386565-2-vagrant@debian.org
From: Vagrant Cascadian <vagrant@debian.org>

* gnu/packages/networking.scm (lcsync): Update to 0.3.1.
---
gnu/packages/networking.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index eeeb215461..161cd7cb13 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -345,7 +345,7 @@ (define-public netperf
(define-public lcsync
(package
(name "lcsync")
- (version "0.3.0")
+ (version "0.3.1")
(source
(origin
(method git-fetch)
@@ -354,7 +354,7 @@ (define-public lcsync
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "1rhk80ybd2zranay76z1ysifnnm786lg9kiiijcwv76qy95in9ks"))))
+ (base32 "15vfik9saqmvys2v10ci68n00s71d9k4kpqhrwz4ilv79fys7hn7"))))
(build-system gnu-build-system)
(arguments
(list
--
2.39.2
vagrant wrote 6 months ago
[PATCH 3/3] gnu: lcrq: Add compiler optimizations.
(address . 72881@debbugs.gnu.org)(address . vagrant@debian.org)
20240829213920.386565-3-vagrant@debian.org
From: Vagrant Cascadian <vagrant@debian.org>

* gnu/packages/networking.scm (lcrq)[arguments]: Pass compiler optimizations
to configure. [phases]: Add 'speedtest phase.
---
gnu/packages/networking.scm | 11 +++++++++++
1 file changed, 11 insertions(+)

Toggle diff (27 lines)
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index 161cd7cb13..e78126b341 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -289,9 +289,20 @@ (define-public lcrq
(arguments
(list
#:parallel-tests? #f
+ ;; Use recommended optimizations from lcrq README.md
+ #:configure-flags
+ #~(list (string-append "CFLAGS=-Wall -Wextra -pedantic -O3 -flto "
+ "-funroll-loops -ffast-math -DNDEBUG"))
#:make-flags
#~(list (string-append "CC=" #$(cc-for-target))
(string-append "PREFIX=" #$output))
+ #:phases
+ #~(modify-phases %standard-phases
+ ;; Leave some speed comparisons in the build log
+ (add-after 'check 'speedtest
+ (lambda _
+ (invoke "make" "-C" "test" "speedtest"
+ (string-append "CC=" #$(cc-for-target))))))
#:test-target "test"))
(home-page "https://librecast.net/lcrq.html")
(synopsis "Librecast RaptorQ library")
--
2.39.2
Vagrant Cascadian wrote 6 months ago
Re: lcrq and lcsync updates
(address . 72881-done@debbugs.gnu.org)
87o750o5b0.fsf@wireframe
On 2024-08-29, Vagrant Cascadian wrote:
Toggle quote (5 lines)
> The forthcoming patches update lcrq to 0.2.1 and lcsync to 0.3.1, and
> pass some additional compiler optimizations to the lcrq build.
>
> lcrq, librecast and lcsync all build fine afte rthe fact.

Pushed as:

18d02443e1ec37779ee3cf63f9aaff1746bfdd8e gnu: lcsync: Update to 0.3.1.
4e60d5dfb40ba604db114384469b8ebb2014efe3 gnu: lcrq: Add compiler optimizations.
695eb1e41cada73baece3272953f0cebada27a8f gnu: lcrq: Update to 0.2.1.

live well,
vagrant
-----BEGIN PGP SIGNATURE-----

iHUEARYKAB0WIQRlgHNhO/zFx+LkXUXcUY/If5cWqgUCZttwIwAKCRDcUY/If5cW
qjxFAQDbkJ9GYmOcnAvVbL9/4FnuZHXTEgkDfPwkdkDKqHHN4gD+Pw0fCGCUhlVK
J3mMW8mqeNvXNqoU9DvAHjlX27atYww=
=LtAG
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 72881@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 72881
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help