[PATCH] gnu: plasma-nm: Fix build on aarch64

  • Done
  • quality assurance status badge
Details
2 participants
  • Doğan Çeçen
  • Z572
Owner
unassigned
Submitted by
Doğan Çeçen
Severity
normal

Debbugs page

Doğan Çeçen wrote 6 months ago
(address . guix-patches@gnu.org)(name . Doğan Çeçen)(address . sepeth@fastmail.com)
9db081b3c256086fd4092beab2e2bde56d564182.1724945820.git.sepeth@fastmail.com
* gnu/packages/qt.scm (qtcoro-qt6): pass -fPIC explicitly

Change-Id: Ifb26600945548d84df2cc70318781d87253af476
---
gnu/packages/qt.scm | 8 +++++---
1 file changed, 5 insertions(+), 3 deletions(-)

Toggle diff (31 lines)
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index a91bebf358..974af2a342 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -153,10 +153,11 @@ (define-public qcoro-qt5
(build-system qt-build-system)
(arguments
(list #:configure-flags
- #~(list (string-append "-DUSE_QT_VERSION="
+ #~(list "-DCMAKE_CXX_FLAGS=-fPIC"
+ (string-append "-DUSE_QT_VERSION="
#$(version-major
- (package-version
- (this-package-input "qtbase")))))))
+ (package-version
+ (this-package-input "qtbase")))))))
(native-inputs (list dbus)) ;for tests
(inputs (list qtbase-5 qtdeclarative-5 qtwebsockets-5))
(home-page "https://qcoro.dvratil.cz/")
@@ -169,6 +170,7 @@ (define-public qcoro-qt6
(package
(inherit qcoro-qt5)
(name "qcoro-qt6")
+ (synopsis "C++ Coroutine Library for Qt6")
(inputs (modify-inputs (package-inputs qcoro-qt5)
(replace "qtbase" qtbase)
(replace "qtdeclarative" qtdeclarative)

base-commit: d5312370b46ace47e138d84e1bb28e5651cee94b
--
2.45.2
Doğan Çeçen wrote 6 months ago
(address . 72878@debbugs.gnu.org)
ec85b0d4-dcf5-4e86-b575-a270242468f2@app.fastmail.com
Sorry for not adding a little context, I was battling with my email config.

Anyhow, I was getting the following error when installing plasma-nm:

Toggle snippet (5 lines)
ld: /gnu/store/drbppxblx1gf943dxilhwz5vags287ir-qcoro-qt6-0.10.0/lib/libQCoro6DBus.a(qcorodbuspendingcall.cpp.o): relocation R_AARCH64_ADR_PREL_PG_HI21 against symbol `_ZN23QDBusPendingCallWatcher8finishedEPS_@@Qt_6' which may bind externally can not be used when making a shared object; recompile with -fPIC
ld: /gnu/store/drbppxblx1gf943dxilhwz5vags287ir-qcoro-qt6-0.10.0/lib/libQCoro6DBus.a(qcorodbuspendingcall.cpp.o)(.text+0xb0): unresolvable R_AARCH64_ADR_PREL_PG_HI21 relocation against symbol `_ZN23QDBusPendingCallWatcher8finishedEPS_@@Qt_6'
ld: final link failed: bad value

The problem seemed to be qcoro-qt6. I checked its logs on x86_64, and it seems -fPIC is being passed:


Unfortunately, aarch64 build is still Scheduled:


Anyhow, the suggestion that the linker gave has worked, which is adding -fPIC.
Z572 wrote 6 months ago
Re: [bug#72878] [PATCH] gnu: plasma-nm: Fix build on aarch64
(name . Doğan Çeçen)(address . sepeth@fastmail.com)
87wmjwdt2f.fsf@iscas.ac.cn
Doğan Çeçen <sepeth@fastmail.com> writes:

Title should "gnu: qcoro-qt: Build with -fPIC.", because it change qcoro-qt{5,6}.

Toggle quote (2 lines)
> * gnu/packages/qt.scm (qtcoro-qt6): pass -fPIC explicitly

* gnu/packages/qt.scm (qcoro-qt5, qcoro-qt6)[arguments]: Adjust
configure-flags to add -fPIC to CMAKE_CXX_FLAGS.
Toggle quote (31 lines)
>
> Change-Id: Ifb26600945548d84df2cc70318781d87253af476
> ---
> gnu/packages/qt.scm | 8 +++++---
> 1 file changed, 5 insertions(+), 3 deletions(-)
>
> diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
> index a91bebf358..974af2a342 100644
> --- a/gnu/packages/qt.scm
> +++ b/gnu/packages/qt.scm
> @@ -153,10 +153,11 @@ (define-public qcoro-qt5
> (build-system qt-build-system)
> (arguments
> (list #:configure-flags
> - #~(list (string-append "-DUSE_QT_VERSION="
> + #~(list "-DCMAKE_CXX_FLAGS=-fPIC"
> + (string-append "-DUSE_QT_VERSION="
> #$(version-major
> - (package-version
> - (this-package-input "qtbase")))))))
> + (package-version
> + (this-package-input "qtbase")))))))
> (native-inputs (list dbus)) ;for tests
> (inputs (list qtbase-5 qtdeclarative-5 qtwebsockets-5))
> (home-page "https://qcoro.dvratil.cz/")
> @@ -169,6 +170,7 @@ (define-public qcoro-qt6
> (package
> (inherit qcoro-qt5)
> (name "qcoro-qt6")
> + (synopsis "C++ Coroutine Library for Qt6")

please split to a new patch.

Toggle quote (5 lines)
> (inputs (modify-inputs (package-inputs qcoro-qt5)
> (replace "qtbase" qtbase)
> (replace "qtdeclarative" qtdeclarative)
>
> base-commit: d5312370b46ace47e138d84e1bb28e5651cee94b
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEfr6klGDOXiwIdX/bO1qpk+Gi3/AFAmbTzJgACgkQO1qpk+Gi
3/CqNBAAq1+RpjnaZACQ/RZf7OsnsjlyMBbL8TFX8EK1qfGvjuIQSrbPwHvjnKiL
tLxxzRMRwRAYg0QPacI5/x3j8n1jdL40av6lWd1MTnqHYD2+Km1MBgUIM+YtklxC
8/SiuCmfSMkGD6ku2FEELPB1aPty/D/tPA0PqYBEsZL4E/IyxOBxfjpJ70Z4Dpx6
FlWekT3a63hS4d/RhuJPDesRjCkjOG3FJ8PElgfUDSgslBbqtOI/ppj5hwwQHwyc
Yk8eA1+BNih1z3VyfnRbEQve6RRDqxGSwItC5SuO/7kPQueqKh0JM9cc/3zSXLR1
rIc49dXomfZEQGf0TpGZ9K8xXC1VI7u54Yn0DqInsMO7HgMIsghNDvEKKIP8FJ/r
caqReRL36HWlP+iYgFy7YGSwynxNnNztpx6ghzxdU2vU79s4tMMpZxOjo13HkJ3L
0U9DLDZZhmR2+FXyHC7tz7gTwhQ97inbTY3xgZ+mCOXZcWdbgCCGwIKfjteCmrjY
C2DsKokBij0yUp8X2NvMvXqlZZhSiUQGjRe34liT82MvyVaNx5n4VYjYUSe/IZmg
j1vMo0cExHm4AbtyjFGUr2lNyO9RpixGpLo4trqR8DV22cI3e2y1IjySnwGCaDAZ
MN3r4l9JPyW0wQuWMm91yYSE/ggdh2z//IeYOcNDAflwXCNKGZU=
=95eK
-----END PGP SIGNATURE-----

Doğan Çeçen wrote 6 months ago
[PATCH] gnu: qcoro-qt: Build with -fPIC
(address . 72878@debbugs.gnu.org)(name . Doğan Çeçen)(address . sepeth@fastmail.com)
7fed05988d452c75742df50d207f2850eca0eff0.1725280158.git.sepeth@fastmail.com
* gnu/packages/qt.scm (qcoro-qt5, qcoro-qt6)[arguments]: Adjust
configure-flags to add -fPIC to CMAKE_CXX_FLAGS.

Change-Id: I5ed2ee18cec120b282863ce6a5f6b6b149059515
---
gnu/packages/qt.scm | 8 +++++---
1 file changed, 5 insertions(+), 3 deletions(-)

Toggle diff (31 lines)
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index b99ce365d7..635fc37639 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -153,10 +153,11 @@ (define-public qcoro-qt5
(build-system qt-build-system)
(arguments
(list #:configure-flags
- #~(list (string-append "-DUSE_QT_VERSION="
+ #~(list "-DCMAKE_CXX_FLAGS=-fPIC"
+ (string-append "-DUSE_QT_VERSION="
#$(version-major
- (package-version
- (this-package-input "qtbase")))))))
+ (package-version
+ (this-package-input "qtbase")))))))
(native-inputs (list dbus)) ;for tests
(inputs (list qtbase-5 qtdeclarative-5 qtwebsockets-5))
(home-page "https://qcoro.dvratil.cz/")
@@ -169,6 +170,7 @@ (define-public qcoro-qt6
(package
(inherit qcoro-qt5)
(name "qcoro-qt6")
+ (synopsis "C++ Coroutine Library for Qt6")
(inputs (modify-inputs (package-inputs qcoro-qt5)
(replace "qtbase" qtbase)
(replace "qtdeclarative" qtdeclarative)

base-commit: ad7211cfe0cba1b7a97308c0fec941c807c1c1e5
--
2.45.2
Zheng Junjie wrote 6 months ago
(name . Doğan Çeçen)(address . sepeth@fastmail.com)
874j6s25ta.fsf@iscas.ac.cn
Doğan Çeçen <sepeth@fastmail.com> writes:

Toggle quote (33 lines)
> * gnu/packages/qt.scm (qcoro-qt5, qcoro-qt6)[arguments]: Adjust
> configure-flags to add -fPIC to CMAKE_CXX_FLAGS.
>
> Change-Id: I5ed2ee18cec120b282863ce6a5f6b6b149059515
> ---
> gnu/packages/qt.scm | 8 +++++---
> 1 file changed, 5 insertions(+), 3 deletions(-)
>
> diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
> index b99ce365d7..635fc37639 100644
> --- a/gnu/packages/qt.scm
> +++ b/gnu/packages/qt.scm
> @@ -153,10 +153,11 @@ (define-public qcoro-qt5
> (build-system qt-build-system)
> (arguments
> (list #:configure-flags
> - #~(list (string-append "-DUSE_QT_VERSION="
> + #~(list "-DCMAKE_CXX_FLAGS=-fPIC"
> + (string-append "-DUSE_QT_VERSION="
> #$(version-major
> - (package-version
> - (this-package-input "qtbase")))))))
> + (package-version
> + (this-package-input "qtbase")))))))
> (native-inputs (list dbus)) ;for tests
> (inputs (list qtbase-5 qtdeclarative-5 qtwebsockets-5))
> (home-page "https://qcoro.dvratil.cz/")
> @@ -169,6 +170,7 @@ (define-public qcoro-qt6
> (package
> (inherit qcoro-qt5)
> (name "qcoro-qt6")
> + (synopsis "C++ Coroutine Library for Qt6")

split it on new commit

Toggle quote (7 lines)
> (inputs (modify-inputs (package-inputs qcoro-qt5)
> (replace "qtbase" qtbase)
> (replace "qtdeclarative" qtdeclarative)
>
> base-commit: ad7211cfe0cba1b7a97308c0fec941c807c1c1e5


push, close.
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEfr6klGDOXiwIdX/bO1qpk+Gi3/AFAmbbFxEACgkQO1qpk+Gi
3/CvFA//ewYd4eflARFVlAMVUcdWJlUqicW+0zh6zIyExIOyRQpLCkt9ZhlSMDwy
SXl7WKjntxUqljUjsH3MUt5Ixr0kvobDOHF0E7srOYXJQfzaHyPd3j8mPaUQ4h3j
PxlhS90bYCJlXT2Lmr0YE4U+R8CncOppDwfkw7OQSSxyymvsIo7si4n3rF50tCn1
Hf52qkYLKFASB3YtYALTXR/+Uhtt6JG0lvI4VaEb9l8pBt/9M19JB1KYbq3ZVmkF
UrjRz/C+jg6nJ/D75J4BWgYjm6bwr46k0JrHO4nY0UZAKkE4xJnYuUmJNwB7NsCa
2+4974m+2EeO10jTq/UlRjdKvWsZRrioJMpQYBE7wqq2izH3RWnXQ7GLeEbVlbIN
nkRGfmaDbaeGcHORCPnExbWdPVLjaxw/kTIbxvRDgG3jdH7lTl9wMVut7FOoXEhH
oY95I47eaZ39+yIN02NCNNiQaWlGgCn2XIdc2FySPgxkJ8EtLhni9k6wjkQVxshs
XJ6lgJCoWvVvoJCUXca6OIoVoYwAY2Vl2bWooKOEvn1Rg8WspXyZSFSWIhbVHUlU
sJ6VFKgfSFaSRKx0l99tdH8/2nNDnybBtKAAh+14ZAN7Qji2ZJklxwOXbExBOp5q
U5Lbl1d0fBkRFqGflu+7C2McmgqmYuUBQwy+MG1HtOMXkusMce8=
=iAvr
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 72878@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 72878
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help