[PATCH 0/2] gnu: uniutils: Update to 2.28.

  • Done
  • quality assurance status badge
Details
2 participants
  • Artyom V. Poptsov
  • Z572
Owner
unassigned
Submitted by
Artyom V. Poptsov
Severity
normal

Debbugs page

Artyom V. Poptsov wrote 6 months ago
(address . guix-patches@gnu.org)(name . Artyom V. Poptsov)(address . poptsov.artyom@gmail.com)
cover.1724862350.git.poptsov.artyom@gmail.com
This patchset updates uniutils to the version 2.28.

Artyom V. Poptsov (2):
gnu: uniutils: Update to 2.28.
gnu: uniutils: Use GEXPs.

gnu/packages/textutils.scm | 32 ++++++++++++++++----------------
1 file changed, 16 insertions(+), 16 deletions(-)


base-commit: 0c908518375aea50be6dec703367c01944c8c721
--
2.45.2
Artyom V. Poptsov wrote 6 months ago
[PATCH 1/2] gnu: uniutils: Update to 2.28.
(address . 72856@debbugs.gnu.org)(name . Artyom V. Poptsov)(address . poptsov.artyom@gmail.com)
70d05c31296615ec84d9cff8e343f6d08da68e5a.1724862350.git.poptsov.artyom@gmail.com
* gnu/packages/textutils.scm (uniutils): Update to 2.28.
[source]: Change HTTP to HTTPS in the URI.

Change-Id: I8c01c6021bf9f28c2bd9a6039ff26a8dc5e4dd16
---
gnu/packages/textutils.scm | 7 ++++---
1 file changed, 4 insertions(+), 3 deletions(-)

Toggle diff (32 lines)
diff --git a/gnu/packages/textutils.scm b/gnu/packages/textutils.scm
index b7ed686371..52aaa0771d 100644
--- a/gnu/packages/textutils.scm
+++ b/gnu/packages/textutils.scm
@@ -32,6 +32,7 @@
;;; Copyright © 2024 Timotej Lazar <timotej.lazar@araneo.si>
;;; Copyright © 2024 Sharlatan Hellseher <sharlatanus@gmail.com>
;;; Copyright © 2024 Ashish SHUKLA <ashish.is@lostca.se>
+;;; Copyright © 2024 Artyom V. Poptsov <poptsov.artyom@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -475,14 +476,14 @@ (define-public ascii2binary
(define-public uniutils
(package
(name "uniutils")
- (version "2.27")
+ (version "2.28")
(source
(origin
(method url-fetch)
- (uri (string-append "http://billposer.org/Software/Downloads/"
+ (uri (string-append "https://billposer.org/Software/Downloads/"
"uniutils-" version ".tar.bz2"))
(sha256
- (base32 "19w1510w87gx7n4qy3zsb0m467a4rn5scvh4ajajg7jh6x5xri08"))))
+ (base32 "0z4ibnd2zzya489vl84cfh82bmdwdhf0isf1myqwrs3s9s0vqyyn"))))
(build-system gnu-build-system)
(arguments
'(#:configure-flags '("--disable-dependency-tracking")
--
2.45.2
Artyom V. Poptsov wrote 6 months ago
[PATCH 2/2] gnu: uniutils: Use GEXPs.
(address . 72856@debbugs.gnu.org)(name . Artyom V. Poptsov)(address . poptsov.artyom@gmail.com)
250f365499abeeb7a16956fcf05cd54bd325da37.1724862350.git.poptsov.artyom@gmail.com
* gnu/packages/textutils.scm (uniutils): Use GEXPs.

Change-Id: I9e59018b41820778b92e69aad2f64c715986c4e9
---
gnu/packages/textutils.scm | 25 ++++++++++++-------------
1 file changed, 12 insertions(+), 13 deletions(-)

Toggle diff (38 lines)
diff --git a/gnu/packages/textutils.scm b/gnu/packages/textutils.scm
index 52aaa0771d..4ff50b6732 100644
--- a/gnu/packages/textutils.scm
+++ b/gnu/packages/textutils.scm
@@ -486,19 +486,18 @@ (define-public uniutils
(base32 "0z4ibnd2zzya489vl84cfh82bmdwdhf0isf1myqwrs3s9s0vqyyn"))))
(build-system gnu-build-system)
(arguments
- '(#:configure-flags '("--disable-dependency-tracking")
- #:phases
- (modify-phases %standard-phases
- (add-after 'build 'fix-paths
- (lambda* (#:key outputs inputs #:allow-other-keys)
- (let ((out (assoc-ref outputs "out"))
- (a2b (assoc-ref inputs "ascii2binary"))
- (iconv (assoc-ref inputs "libiconv")))
- (substitute* "utf8lookup"
- (("^ascii2binary ") (string-append a2b "/bin/ascii2binary "))
- (("^uniname ") (string-append out "/bin/uniname "))
- (("^iconv ") (string-append iconv "/bin/iconv ")))
- #t))))))
+ (list #:configure-flags #~(list "--disable-dependency-tracking")
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'build 'fix-paths
+ (lambda* (#:key outputs inputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out"))
+ (a2b (assoc-ref inputs "ascii2binary"))
+ (iconv (assoc-ref inputs "libiconv")))
+ (substitute* "utf8lookup"
+ (("^ascii2binary ") (string-append a2b "/bin/ascii2binary "))
+ (("^uniname ") (string-append out "/bin/uniname "))
+ (("^iconv ") (string-append iconv "/bin/iconv ")))))))))
(inputs
(list ascii2binary libiconv))
(home-page "https://billposer.org/Software/unidesc.html")
--
2.45.2
Z572 wrote 6 months ago
Re: [bug#72856] [PATCH 0/2] gnu: uniutils: Update to 2.28.
(name . Artyom V. Poptsov)(address . poptsov.artyom@gmail.com)(address . 72856-done@debbugs.gnu.org)
87h6b4f1t1.fsf@iscas.ac.cn
"Artyom V. Poptsov" <poptsov.artyom@gmail.com> writes:

Toggle quote (12 lines)
> This patchset updates uniutils to the version 2.28.
>
> Artyom V. Poptsov (2):
> gnu: uniutils: Update to 2.28.
> gnu: uniutils: Use GEXPs.
>
> gnu/packages/textutils.scm | 32 ++++++++++++++++----------------
> 1 file changed, 16 insertions(+), 16 deletions(-)
>
>
> base-commit: 0c908518375aea50be6dec703367c01944c8c721

push, close.
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEfr6klGDOXiwIdX/bO1qpk+Gi3/AFAmbP6hoACgkQO1qpk+Gi
3/Df/g//Rt/xGOpiSgdU3JxVo4dzgfU3Xw8PJXY9pfgprxtFuf+HQJ2E+ENfZOsU
K10jdCCjrDVKEn81ei/N9o2SsXTy+Dinz0MwukKTyFrJFkUuaa8y6WdBRMSWb06z
lAFmC+LN0ri6EJYo1jaNNuNkb3XQcHSm2n0IbfLlWUSRJnTOXHbgJZTGH7B3VSUb
hlVQ0HtKPee+ldIrk3Y+tIgs34Fau/IB+lmlO5N51wtXRnoIISLZt7UPVKUopmy0
A6J6Wrppu6rEUPruCyXFw852AWi9ep374cRjffQrNkO8SvVRUFnzAj6Xag/OA/gj
8UH6kDnjSuX7nqK0pT0515gNstizuo5ByNOIvSum0z6gmklVC70XouYuKwol/+AK
UdS6QHsvCl3p2eAHFmpx+VZ+ObAPKlywkjCpdn9kynkZFYZsqoZVXjgGzuX5aw9b
ZkH8FZN2Awl2U11O7r//2gC49GzToW5RMlAF6vzy4hFUNDaNAJsxUbqKnc9ZY2i+
6UpefHPrfjneBXMhnMsOxxcF2IiJLKlkv5kb7Apv7OQMQp8NbMbzn/kKro73I/3l
OLah7ruGVbUzbI2ZElGn6gtO7qAiSB4ednIRDazhHjsaUIgT2z8aW8TZ0tH9GTfZ
VqjXsTpFHXIZ/SL4eJRQsXd8qOBXzQ633ErHrspbNlTiCTNVNSw=
=3mQ+
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 72856@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 72856
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help