[PATCH 0/4] Update gpodder.scm

  • Done
  • quality assurance status badge
Details
3 participants
  • Andreas Enge
  • kiasoc5
  • Ludovic Courtès
Owner
unassigned
Submitted by
kiasoc5
Severity
normal

Debbugs page

kiasoc5 wrote 6 months ago
(address . guix-patches@gnu.org)(name . kiasoc5)(address . kiasoc5@disroot.org)
cover.1724793413.git.kiasoc5@disroot.org

kiasoc5 (4):
gnu: python-podcastparser: Update to 0.6.10.
gnu: python-mygpoclient: Update to 1.9.
gnu: libmygpo-qt: Improve package style.
gnu: gpodder: Update to 3.11.4.

gnu/packages/gpodder.scm | 90 +++++++++++++++++++---------------------
1 file changed, 43 insertions(+), 47 deletions(-)


base-commit: 1ee12c3c6ba8323881a0d5d5e8fb21f5fe26b51e
--
2.39.2
Andreas Enge wrote 6 months ago
Patches missing
(address . 72847@debbugs.gnu.org)
ZtbPgNk5-1WEgMLi@jurong
Hello,

it looks like you just sent the cover letter, but forgot the actual
patch series. Could you send them, please?

Andreas
kiasoc5 wrote 6 months ago
Patches
(address . 72847@debbugs.gnu.org)
9b20d1f4fa7280f0ebcc38ca661921c4@disroot.org
I am traveling and unable to send emails through git. I've attached the
patches.
From 12ba5eab5a57f45a80813695bd070f372598e671 Mon Sep 17 00:00:00 2001
Message-Id: <12ba5eab5a57f45a80813695bd070f372598e671.1725289939.git.kiasoc5@disroot.org>
In-Reply-To: <4ee49352110cb9a0ac58e5f3ac44ea4481a7b028.1725289939.git.kiasoc5@disroot.org>
References: <4ee49352110cb9a0ac58e5f3ac44ea4481a7b028.1725289939.git.kiasoc5@disroot.org>
From: kiasoc5 <kiasoc5@disroot.org>
Date: Tue, 27 Aug 2024 17:00:32 -0400
Subject: [PATCH 3/4] gnu: libmygpo-qt: Improve package style.

* gnu/packages/gpodder.scm (libmygpo-qt)[inputs]: Remove input labels.
[arguments]: Switch from quasiquote to quote.

Change-Id: If258f1e7ef5d291e5452e3d540564c13d86801ef
---
gnu/packages/gpodder.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (18 lines)
diff --git a/gnu/packages/gpodder.scm b/gnu/packages/gpodder.scm
index e77cd39bcf..1073af0f3b 100644
--- a/gnu/packages/gpodder.scm
+++ b/gnu/packages/gpodder.scm
@@ -147,9 +147,9 @@ (define-public libmygpo-qt
(native-inputs
(list pkg-config))
(inputs
- `(("qt" ,qtbase-5)))
+ (list qtbase-5))
(arguments
- `(#:configure-flags '("-DMYGPO_BUILD_TESTS=ON")
+ '(#:configure-flags '("-DMYGPO_BUILD_TESTS=ON")
;; TODO: Enable tests when https://github.com/gpodder/gpodder/issues/446
;; is fixed.
#:tests? #f))
--
2.39.2
From 0b2b747882807f556ee5bc7fce0a38941f89b529 Mon Sep 17 00:00:00 2001
Message-Id: <0b2b747882807f556ee5bc7fce0a38941f89b529.1725289939.git.kiasoc5@disroot.org>
In-Reply-To: <4ee49352110cb9a0ac58e5f3ac44ea4481a7b028.1725289939.git.kiasoc5@disroot.org>
References: <4ee49352110cb9a0ac58e5f3ac44ea4481a7b028.1725289939.git.kiasoc5@disroot.org>
From: kiasoc5 <kiasoc5@disroot.org>
Date: Tue, 27 Aug 2024 01:20:36 -0400
Subject: [PATCH 2/4] gnu: python-mygpoclient: Update to 1.9.

* gnu/packages/gpodder.scm (python-mygpoclient): Update to 1.9.
[native-inputs]: Add python-pytest.
[arguments]: Switch from quasiquote to quote.

Change-Id: I78c6f49d94619d63a115527a20fb6ae1c30fed4b
---
gnu/packages/gpodder.scm | 8 ++++----
1 file changed, 4 insertions(+), 4 deletions(-)

Toggle diff (30 lines)
diff --git a/gnu/packages/gpodder.scm b/gnu/packages/gpodder.scm
index 52ca28a632..e77cd39bcf 100644
--- a/gnu/packages/gpodder.scm
+++ b/gnu/packages/gpodder.scm
@@ -163,19 +163,19 @@ (define-public libmygpo-qt
(define-public python-mygpoclient
(package
(name "python-mygpoclient")
- (version "1.8")
+ (version "1.9")
(source
(origin
(method url-fetch)
(uri (pypi-uri "mygpoclient" version))
(sha256
(base32
- "1fi5x6k1mngr0iviw2s4n1f3y2x7pwqy5ivkcrjdprzvwr37f0mh"))))
+ "05hmjdb73m7vl6lzvh58bnliy4227pv8hprwfka0bg19cnvgpyf5"))))
(build-system python-build-system)
(native-inputs
- (list python-coverage python-minimock python-nose))
+ (list python-coverage python-minimock python-nose python-pytest))
(arguments
- `(#:phases
+ '(#:phases
(modify-phases %standard-phases
(replace 'check
(lambda _
--
2.39.2
From 4ee49352110cb9a0ac58e5f3ac44ea4481a7b028 Mon Sep 17 00:00:00 2001
Message-Id: <4ee49352110cb9a0ac58e5f3ac44ea4481a7b028.1725289939.git.kiasoc5@disroot.org>
From: kiasoc5 <kiasoc5@disroot.org>
Date: Tue, 27 Aug 2024 01:20:36 -0400
Subject: [PATCH 1/4] gnu: python-podcastparser: Update to 0.6.10.

* gnu/packages/gpodder.scm (python-podcastparser): Update to 0.6.10.

Change-Id: I8378ec847d3815412918e43fe1583cb06a9658f6
---
gnu/packages/gpodder.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/gpodder.scm b/gnu/packages/gpodder.scm
index f9102d3a44..52ca28a632 100644
--- a/gnu/packages/gpodder.scm
+++ b/gnu/packages/gpodder.scm
@@ -191,13 +191,13 @@ (define-public python-mygpoclient
(define-public python-podcastparser
(package
(name "python-podcastparser")
- (version "0.6.6")
+ (version "0.6.10")
(source
(origin
(method url-fetch)
(uri (pypi-uri "podcastparser" version))
(sha256
- (base32 "0m24r2qhck0win44xfhxajbppkss4ha6am0042s0xyq3408883m3"))))
+ (base32 "1mqkkxz928y430xx3mgw9dj78ilkgv9hjdha1hizbks6mmhcp6ib"))))
(native-inputs
(list python-pytest))
(arguments

base-commit: 0aa66ec0b0bef39591ddae3d8d06ac0fa71f03bb
--
2.39.2
Ludovic Courtès wrote 5 months ago
(address . kiasoc5@disroot.org)(address . 72847-done@debbugs.gnu.org)
87iku7psfi.fsf@gnu.org
Hi kiasoc5,

Applied the 4 patches, thanks!

(Well, I can’t push right now because Savannah is overloaded again…)

Ludo’.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 72847@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 72847
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help