[PATCH 0/4] gnu: kubo: Add some direct and indirect dependencies.

  • Done
  • quality assurance status badge
Details
2 participants
  • Artyom V. Poptsov
  • Sharlatan Hellseher
Owner
unassigned
Submitted by
Artyom V. Poptsov
Severity
normal

Debbugs page

Artyom V. Poptsov wrote 6 months ago
(address . guix-patches@gnu.org)(name . Artyom V. Poptsov)(address . poptsov.artyom@gmail.com)
cover.1724792671.git.poptsov.artyom@gmail.com
This patchset unbundles another package from Kubo (IPFS) and adds some
indirect dependencies for it.

Although "go-github-com-ipfs-go-ipfs-posinfo" is archived on GitHub it is
still in use by "go-unixfs":

which in turn is a dependency of "go-unixfsnode":

Artyom V. Poptsov (4):
gnu: Add go-github-com-libp2p-go-doh-resolver.
gnu: kubo: Unbundle go-github-com-libp2p-go-doh-resolver.
gnu: Add go-github-com-ipfs-go-bitfield.
gnu: Add go-github-com-ipfs-go-ipfs-posinfo.

gnu/packages/golang-web.scm | 28 ++++++++++++++++++++++++++++
gnu/packages/golang-xyz.scm | 25 +++++++++++++++++++++++++
gnu/packages/ipfs.scm | 27 ++++++++++++++++++++++++++-
3 files changed, 79 insertions(+), 1 deletion(-)


base-commit: 1ee12c3c6ba8323881a0d5d5e8fb21f5fe26b51e
--
2.45.2
Artyom V. Poptsov wrote 6 months ago
[PATCH 1/4] gnu: Add go-github-com-libp2p-go-doh-resolver.
(address . 72844@debbugs.gnu.org)(name . Artyom V. Poptsov)(address . poptsov.artyom@gmail.com)
8ddd58504b9465a108646dc5ede246484e1090c8.1724792671.git.poptsov.artyom@gmail.com
* gnu/packages/golang-web.scm (go-github-com-libp2p-go-doh-resolver): New variable.

Change-Id: I581c6032fbb9b6ffe74423172359b65ced119ab3
---
gnu/packages/golang-web.scm | 28 ++++++++++++++++++++++++++++
1 file changed, 28 insertions(+)

Toggle diff (41 lines)
diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index 9943891502..b3e583da39 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -2698,6 +2698,34 @@ (define-public go-github-com-libp2p-go-cidranger
published AWS Route53 CIDR 52.95.110.0/24), IP routing rules, etc.")
(license license:expat)))
+(define-public go-github-com-libp2p-go-doh-resolver
+ (package
+ (name "go-github-com-libp2p-go-doh-resolver")
+ (version "0.4.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/libp2p/go-doh-resolver")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0asni7f3gd65bjfqz99fqchz9y75cpgmfwkkhsbq0y2dydagw666"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/libp2p/go-doh-resolver"))
+ (native-inputs (list go-github-com-stretchr-testify))
+ (propagated-inputs (list go-github-com-miekg-dns
+ go-github-com-multiformats-go-multiaddr-dns
+ go-github-com-ipfs-go-log-v2))
+ (home-page "https://github.com/libp2p/go-doh-resolver")
+ (synopsis "DNS over HTTPS resolver")
+ (description
+ "@url{https://datatracker.ietf.org/doc/html/rfc8484, DNS over HTTPS}
+resolver for Golang.")
+ (license license:expat)))
+
(define-public go-github-com-libp2p-go-flow-metrics
(package
(name "go-github-com-libp2p-go-flow-metrics")
--
2.45.2
Artyom V. Poptsov wrote 6 months ago
[PATCH 2/4] gnu: kubo: Unbundle go-github-com-libp2p-go-doh-resolver.
(address . 72844@debbugs.gnu.org)(name . Artyom V. Poptsov)(address . poptsov.artyom@gmail.com)
3bdac1267dafe6e1496321d8eaa4f607f438ddf8.1724792671.git.poptsov.artyom@gmail.com
* gnu/packages/ipfs.scm (kubo): [snippet]: Delete
"vendor/github.com/libp2p/go-doh-resolver".
[inputs]: Add go-github-com-libp2p-go-doh-resolver.

Change-Id: I417802e02b482164fdb65852a19187fb63bd9199
---
gnu/packages/ipfs.scm | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)

Toggle diff (23 lines)
diff --git a/gnu/packages/ipfs.scm b/gnu/packages/ipfs.scm
index d9866a8d9a..af95ca86f3 100644
--- a/gnu/packages/ipfs.scm
+++ b/gnu/packages/ipfs.scm
@@ -865,6 +865,7 @@ (define-public kubo
"vendor/github.com/koron"
"vendor/github.com/libp2p/go-buffer-pool"
"vendor/github.com/libp2p/go-cidranger"
+ "vendor/github.com/libp2p/go-doh-resolver"
"vendor/github.com/libp2p/go-flow-metrics"
"vendor/github.com/libp2p/go-libp2p-asn-util"
"vendor/github.com/libp2p/go-msgio"
@@ -989,7 +990,7 @@ (define-public kubo
go-github-com-jbenet-go-temp-err-catcher
go-github-com-jbenet-goprocess
go-github-com-julienschmidt-httprouter
- ;;go-github-com-libp2p-go-doh-resolver
+ go-github-com-libp2p-go-doh-resolver
;;go-github-com-libp2p-go-libp2p
;;go-github-com-libp2p-go-libp2p-http
;;go-github-com-libp2p-go-libp2p-kad-dht
--
2.45.2
Artyom V. Poptsov wrote 6 months ago
[PATCH 3/4] gnu: Add go-github-com-ipfs-go-bitfield.
(address . 72844@debbugs.gnu.org)(name . Artyom V. Poptsov)(address . poptsov.artyom@gmail.com)
2dd821b4816a9f789d93ffe9335e187c48f04881.1724792671.git.poptsov.artyom@gmail.com
* gnu/packages/golang-xyz.scm (go-github-com-ipfs-go-bitfield): New variable.

Change-Id: I95e627fb5f4dfcca5e4b70e753b544b4965b96c2
---
gnu/packages/golang-xyz.scm | 25 +++++++++++++++++++++++++
1 file changed, 25 insertions(+)

Toggle diff (38 lines)
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 796341a66b..056680afcf 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -3362,6 +3362,31 @@ (define-public go-github-com-itchyny-timefmt-go
time strings.")
(license license:expat)))
+(define-public go-github-com-ipfs-go-bitfield
+ (package
+ (name "go-github-com-ipfs-go-bitfield")
+ (version "1.1.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ipfs/go-bitfield")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1zhgwdg2kizhk0hb9q5p0pwrwldd2pacz8l1pnapxh6qm3fqs663"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/ipfs/go-bitfield"))
+ (home-page "https://github.com/ipfs/go-bitfield")
+ (synopsis "Golang bitfield package")
+ (description
+ "@code{go-bitfield} is a simple bitfield package that's about 2-3x faster than
+using @code{big.Int} from the standard library. It also has a better interface (and,
+e.g., supports counting ones).")
+ (license (list license:expat license:asl2.0))))
+
(define-public go-github-com-jbenet-go-random
(package
(name "go-github-com-jbenet-go-random")
--
2.45.2
Artyom V. Poptsov wrote 6 months ago
[PATCH 4/4] gnu: Add go-github-com-ipfs-go-ipfs-posinfo.
(address . 72844@debbugs.gnu.org)(name . Artyom V. Poptsov)(address . poptsov.artyom@gmail.com)
dc85e032bc50ec89146abe02aa4e7d46e2cf0449.1724792671.git.poptsov.artyom@gmail.com
* gnu/packages/ipfs.scm (go-github-com-ipfs-go-ipfs-posinfo): New variable.

Change-Id: I19486debf95e0877d735fd18fab9faf1cf26c484
---
gnu/packages/ipfs.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)

Toggle diff (37 lines)
diff --git a/gnu/packages/ipfs.scm b/gnu/packages/ipfs.scm
index af95ca86f3..6089dd7362 100644
--- a/gnu/packages/ipfs.scm
+++ b/gnu/packages/ipfs.scm
@@ -165,6 +165,30 @@ (define-public go-github-com-ipfs-go-ipfs-blocksutil
@url{https://github.com/ipfs/go-block-format, IPFS blocks}.")
(license license:expat))))
+(define-public go-github-com-ipfs-go-ipfs-posinfo
+ (package
+ (name "go-github-com-ipfs-go-ipfs-posinfo")
+ (version "0.0.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ipfs/go-ipfs-posinfo")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1wgd3708gr42f37dcva41w1pkb5iywf8jdx6pgfhwwlw2s4lrn0p"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/ipfs/go-ipfs-posinfo"))
+ (propagated-inputs (list go-github-com-ipfs-go-ipld-format))
+ (home-page "https://github.com/ipfs/go-ipfs-posinfo")
+ (synopsis "Wrap offset information for IPFS filestore nodes")
+ (description
+ "@code{go-ipfs-posinfo} wraps offset information for IPFS filestore nodes.")
+ (license license:expat)))
+
(define-public go-github-com-ipfs-go-cid
(package
(name "go-github-com-ipfs-go-cid")
--
2.45.2
Sharlatan Hellseher wrote 6 months ago
[PATCH 0/4] gnu: kubo: Add some direct and indirect dependencies.
(address . 72844-done@debbugs.gnu.org)
87le0gw5ll.fsf@gmail.com
Hi,

Thank you for the patches.

Pushed as 71e1d0a437..de25a21433 to master with minor adjustments.

--
Oleg
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEmEeB3micIcJkGAhndtcnv/Ys0rUFAmbPvKYACgkQdtcnv/Ys
0rVfkQ/+I33KFVBS9E/o6sMMMmJYURoKKpb5Rq3lcYEF5ZcZlRAmjHThluehYYM2
6tK7DtWdmKJe1gM52GkPgpQM27YRLxXkacJAThRUEqL1ZyvcS8I7xz6+kWTgALyz
/sYosuqHSw0VXGgB0tvrNRFY4K7bLGG0ZtlwJ0QiofBe8pQYuz8SnNfFlVgvBIn4
k40ByUAeh2syx0I4KIWjTaftEkir1aYyM5zEog7Jupag1tMaYc3xIjvXPvbmtyP0
TiO7TY4deBjf7nVhUA/OMSwEAeUYghk3cOY4Jy31QQTO6nAW7LSjfKQDh9GToSEN
VV5Y75FSdxkzow5T8BYa5+5I6q4c2SLcpkjQn0hpUgct+pZhgo8wBhgVsb6uHL4s
3UDSB/rTRGr6+IC8d77qN6eiKtcee6imt2y6zfEWRUs/fbYHyRO44IoEar8YQK2l
BUkW4rG3TBqodPSAjAecsdMVMsrqviKqE17I5JJrs4hRUS3Bd/T7FRWdfmewbOGU
GtMQ5tNosTMtgplRCM0d4Zre3W6v70jE3KnmqhIUg+1Y0xAHlSHImd9/vo/OKTEq
HWU5rcaID/KXz/QfULy+G6Slr8AvhrK2pkxBbeB5VOkkyWqFVngqya43AFXBjjml
JLI+xtz4QkslgYyS7+YvvwdubKnuUoc7JiyADGePXWR1BWtJSn4=
=XBDV
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 72844@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 72844
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help