[PATCH] gnu: Add ncpamixer.

  • Open
  • quality assurance status badge
Details
One participant
  • Sisiutl
Owner
unassigned
Submitted by
Sisiutl
Severity
normal
S
S
Sisiutl wrote on 21 Aug 18:16 +0200
(address . guix-patches@gnu.org)(name . Sisiutl)(address . sisiutl@egregore.fun)
20240821161634.20350-1-sisiutl@egregore.fun
* gnu/packages/pulseaudio.scm (ncpamixer): New variable.
* gnu/packages/pulseaudio.scm: Add (gnu packages ncurses) module.

Change-Id: Ie55a965f37bdbbfe32ae0397af02be478d155ae1
---
gnu/packages/pulseaudio.scm | 29 +++++++++++++++++++++++++++++
1 file changed, 29 insertions(+)

Toggle diff (52 lines)
diff --git a/gnu/packages/pulseaudio.scm b/gnu/packages/pulseaudio.scm
index dd0d3985c0..cf56de6a0c 100644
--- a/gnu/packages/pulseaudio.scm
+++ b/gnu/packages/pulseaudio.scm
@@ -64,6 +64,7 @@ (define-module (gnu packages pulseaudio)
#:use-module (gnu packages web)
#:use-module (gnu packages linux)
#:use-module (gnu packages m4)
+ #:use-module (gnu packages ncurses)
#:use-module (gnu packages perl)
#:use-module (gnu packages protobuf)
#:use-module (gnu packages python)
@@ -382,6 +383,34 @@ (define-public pamixer
volume levels of the sinks (get, set, decrease, increase, toggle mute, etc).")
(license l:gpl3+)))
+(define-public ncpamixer
+ (package
+ (name "ncpamixer")
+ (version "1.3.7")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/fulhax/ncpamixer/")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1ix4cja3yka8ah5s1ygd0ghf53jllphnjxjnkivvx72jii4b778q"))))
+ (build-system cmake-build-system)
+ (inputs (list pulseaudio ncurses))
+ (arguments
+ (list
+ #:configure-flags #~'("-DBUILD_MANPAGES=OFF")
+ #:tests? #f
+ #:phases #~(modify-phases %standard-phases
+ (add-before 'configure 'chdir-to-src
+ (lambda _
+ (chdir "src"))))))
+ (home-page "https://github.com/fulhax/ncpamixer")
+ (synopsis "Ncurses PulseAudio Mixer")
+ (description "An ncurses mixer for PulseAudio inspired by pavucontrol.")
+ (license l:expat)))
+
(define-public pasystray
(package
(name "pasystray")

base-commit: 7ed52500c945f5cba8a93dd0df7b89f9bca6b6e7
prerequisite-patch-id: f4453f86b4eee4c3be3bd716167658abf1428aee
--
2.45.2
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 72749@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 72749
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch