[PATCH] gnu: Add r-spacexr.

  • Open
  • quality assurance status badge
Details
One participant
  • Afkhami, Navid
Owner
unassigned
Submitted by
Afkhami, Navid
Severity
normal
A
A
Afkhami, Navid wrote on 20 Aug 10:07 +0200
(address . guix-patches@gnu.org)(name . Afkhami, Navid)(address . Navid.Afkhami@mdc-berlin.de)
02122b27950c60f55dbfa860ebaf750c7ba8a360.1724141223.git.Navid.Afkhami@mdc-berlin.de
* gnu/packages/bioinformatics.scm (r-spacexr): New variable.

Change-Id: Icf2a7dd9d637d14d835c7a428093ba8daf25e25a
---
gnu/packages/bioinformatics.scm | 45 +++++++++++++++++++++++++++++++++
1 file changed, 45 insertions(+)

Toggle diff (62 lines)
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index eae0a29b90..56188309a8 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -22662,6 +22662,51 @@ (define-public r-catch
value of physical insulation between neighboring domains.")
(license license:gpl2+))))
+(define-public r-spacexr
+ (let ((commit "0a0861e3d1e16014a20e9b743d0e19d3b42231f3")
+ (revision "1"))
+ (package
+ (name "r-spacexr")
+ (version (git-version "2.2.1" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/dmcable/spacexr")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0hqrllzq2hi6dsr8nykn1yp7s3rcbjrv3m624b61n4nxnzza458a"))))
+ (properties `((upstream-name . "spacexr")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-compquadform
+ r-data-table
+ r-doparallel
+ r-dplyr
+ r-fields
+ r-foreach
+ r-ggplot2
+ r-knitr
+ r-locfdr
+ r-matrix
+ r-metafor
+ r-mgcv
+ r-pals
+ r-quadprog
+ r-readr
+ r-reshape2
+ r-rfast
+ r-rmarkdown
+ r-tibble))
+ (native-inputs (list r-knitr))
+ (home-page "https://github.com/dmcable/spacexr")
+ (synopsis
+ "Cell type identification and differential expression in spatial transcriptomics")
+ (description
+ "This package is used for cell type identification in spatial transcriptomics.
+It also handles cell type-specific differential expression.")
+ (license license:gpl3))))
+
(define-public r-spectre
(let ((commit "f6648ab3eb9499300d86502b5d60ec370ae9b61a")
(revision "1"))

base-commit: 58faaf4eaadafa09a97ab31103eb54bd2076a699
prerequisite-patch-id: dc2f4964edf0016b1e572e9f41129606c4fb3132
prerequisite-patch-id: 4ce0ef474ba0015be3d30c7eec8f094098beaec7
--
2.34.1
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 72727@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 72727
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch