[PATCH] gnu: Add r-cca.

  • Done
  • quality assurance status badge
Details
2 participants
  • Afkhami, Navid
  • Ricardo Wurmus
Owner
unassigned
Submitted by
Afkhami, Navid
Severity
normal

Debbugs page

Afkhami, Navid wrote 7 months ago
(address . guix-patches@gnu.org)(name . Afkhami, Navid)(address . Navid.Afkhami@mdc-berlin.de)
0a3b40feff33c9e3e5804df87165984b45797964.1724080499.git.Navid.Afkhami@mdc-berlin.de
* gnu/packages/cran.scm (r-cca): New variable.

Change-Id: Icc3411c5b57e97d8fc9f6e749f280b62572c32b3
---
gnu/packages/cran.scm | 22 ++++++++++++++++++++++
1 file changed, 22 insertions(+)

Toggle diff (37 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 3f964857ff..a9298e90b7 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -41977,6 +41977,28 @@ (define-public r-mmwrweek
convert dates to MMWR day, week, and year and the reverse.")
(license license:gpl2+)))
+(define-public r-cca
+ (package
+ (name "r-cca")
+ (version "1.2.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "CCA" version))
+ (sha256
+ (base32 "0r1f7m64608hq6bpw36wsw6fr4s8bj26x4062brqgn5dbpqlgczk"))))
+ (properties `((upstream-name . "CCA")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-fda r-fields))
+ (home-page "https://cran.r-project.org/package=CCA")
+ (synopsis "Canonical correlation analysis")
+ (description
+ "This package contains a set of functions that extend the cancor function.
+These functions provide new numerical and graphical outputs. It also include a
+regularized extension of the canonical correlation analysis to deal with
+datasets with more variables than observations.")
+ (license license:gpl2+)))
+
(define-public r-cccd
(package
(name "r-cccd")

base-commit: d3832de763777759eb1f56e20731cb39da4c7b5b
--
2.34.1
Ricardo Wurmus wrote 4 months ago
(address . 72713-done@debbugs.gnu.org)
87ed3vkxj5.fsf@elephly.net
Applied, thanks!

--
Ricardo
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 72713@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 72713
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help