[PATCH] gnu: glfw: Fix a missing path to a dlopen call.

  • Done
  • quality assurance status badge
Details
2 participants
  • arnaud.lechevallier
  • Z572
Owner
unassigned
Submitted by
arnaud.lechevallier
Severity
normal
A
A
arnaud.lechevallier wrote on 19 Aug 2024 15:49
(address . guix-patches@gnu.org)
68942320.44677372.1724075387309.JavaMail.root@zimbra81-e14.priv.proxad.net
Hello,

Recent release of glfw introduced a new dlopen call to `libwayland-client.so.0'. I made a patch to add this new library into the list of libraries to be patched by the existing macro `patch-sonames'.
It will have no effect on previous glfw-3.3.10 but it will fix later version such as the new definition package provided for glfw-3.4.

Kind regards,

Arnaud.
From 2d146872772ec3aebe30d7b28be947a12f0ea6f5 Mon Sep 17 00:00:00 2001
Message-ID: <2d146872772ec3aebe30d7b28be947a12f0ea6f5.1724074469.git.arnaud.lechevallier@free.fr>
From: Arnaud Lechevallier <arnaud.lechevallier@free.fr>
Date: Mon, 19 Aug 2024 14:59:02 +0200
Subject: [PATCH] gnu: glfw: Fix a missing path to a dlopen call.
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit

Recent release of glfw introduced a new dlopen call to `libwayland-client.so.0´.
This small fix adds this library to the list of libraries to be patched. It
does not affect earlier versions.

* gnu/packages/gl.scm (glfw): Add `libwayland-client.so.0' to the list of
libraries to be patched.

Change-Id: I9436c63f49a9b2fed18e06d593e67a593e3c6cad
---
gnu/packages/gl.scm | 2 ++
1 file changed, 2 insertions(+)

Toggle diff (24 lines)
diff --git a/gnu/packages/gl.scm b/gnu/packages/gl.scm
index 8441f3ae65..72b8d190e7 100644
--- a/gnu/packages/gl.scm
+++ b/gnu/packages/gl.scm
@@ -21,6 +21,7 @@
;;; Copyright © 2023, 2024 Zheng Junjie <873216071@qq.com>
;;; Copyright © 2024 Liliana Marie Prikler <liliana.prikler@gmail.com>
;;; Copyright © 2024 Artyom V. Poptsov <poptsov.artyom@gmail.com>
+;;; Copyright © 2024 Arnaud Lechevallier <arnaud.lechevallier@free.fr>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -968,6 +969,7 @@ (define-public glfw
"libvulkan.so.1"
"libwayland-cursor.so.0"
"libwayland-egl.so.1"
+ "libwayland-client.so.0"
"libxkbcommon.so.0"
"libXxf86vm.so.1"
"libXi.so.6"

base-commit: 71f0676a295841e2cc662eec0d3e9b7e69726035
--
2.45.2
Z
(address . arnaud.lechevallier@free.fr)(address . 72712-done@debbugs.gnu.org)
878qvhay3q.fsf@iscas.ac.cn
arnaud.lechevallier@free.fr writes:

Toggle quote (11 lines)
> Hello,
>
> Recent release of glfw introduced a new dlopen call to `libwayland-client.so.0'. I made a patch to add this new library into the list of libraries to be patched by the existing macro `patch-sonames'.
> It will have no effect on previous glfw-3.3.10 but it will fix later version such as the new definition package provided for glfw-3.4.
>
> Kind regards,
>
> Arnaud.
>
> [2. text/x-patch; 0001-gnu-glfw-Fix-a-missing-path-to-a-dlopen-call.patch]...

thanks!

push and close.
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEfr6klGDOXiwIdX/bO1qpk+Gi3/AFAmby1dkACgkQO1qpk+Gi
3/AF3RAAnXHEmpRJa3UR2mTMgLzWsjLe3/hvFDc8jZ9QFK0LD8GUPa3hAyHTrpY5
lHrg8hJeQEg0Pg56USR3l5APe+Nvw5Hy7fa0QbSohXOYIMJIhEPcekxsO1fbUGLY
Ql+IwMn4z7P61R8sQ81nWDCfBMF0Uwornp97sQ6/Xx3pzYniAGW1kwSwFKlmVDaA
yWSCFLezLCS7wR3k4bS+QY2KbyRTOVNe+E/JJ7I8yCTP/ij4kgqbzmei3547mKWP
LqpRnyL2MFyMZmvWSBYTErpC5NyKLs9mbYLp3kBXVd4jhwKQYxJWsCTIwOOt2PaH
0kfJk+PkDKOuvx9rmIqUcvQpUq5Im4tsyqyaJX7J1/Tm4mUe0GVAup/Eblnpf+DR
rBvACNtx3IAPwfd/lmN7Hv3FBQIgEtjkiPKQNWsv1TJztEChdN8f9VaPi0SSW9GH
ayXV5zOVBSICdB+R6Qa/KdE91ybWflFAeB0RZXa4n8DgIL19qRsFoEbl4LsQ6BWW
g8GusckIG9ZdQxPYB/khTG3NzvAb0Zy1v39pxDuRlh0Z11GebeK146O4CkkmDljK
mdZkdMFxJuL/R9rS45yz300T6o22cfKurhmWMyJ+KAQV1Aq+mz4Pocg/nIyV209/
oiQ5dPGIcZTPhVYqhCLtOeWQWh8Mwtu7woRR2LRKgFZV5OnuXBA=
=/ovk
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 72712@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 72712
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch