[PATCH] gnu: gtk+-2: Disable UI tests.

  • Open
  • quality assurance status badge
Details
2 participants
  • Jonathan Frederickson
  • Liliana Marie Prikler
Owner
unassigned
Submitted by
Jonathan Frederickson
Severity
normal
J
J
Jonathan Frederickson wrote on 18 Aug 23:14 +0200
(address . guix-patches@gnu.org)(name . Jonathan Frederickson)(address . jonathan@terracrypt.net)
318e036d5cb654ab4f9d570a4cd077ba3c5d15fd.1724015688.git.jonathan@terracrypt.net
* gnu/packages/gtk.scm (gtk+-2): Disable ui-tests. They seem to be flaky on
aarch64, and I haven't been able to get the package to build without this
change.

Change-Id: I5aa5a89a2874ad1c737cba16c3aaeedced606de3
---
gnu/packages/gtk.scm | 3 +++
1 file changed, 3 insertions(+)

Toggle diff (18 lines)
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 04183fa806..a0da976fab 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -980,6 +980,9 @@ (define-public gtk+-2
(("g_test_add_func \\(\"/recent-manager.*;") ""))
(substitute* "gtk/tests/defaultvalue.c"
(("return g_test_run\\(\\);") ""))
+ ;; UI tests seem to be flaky on aarch64
+ (substitute* "gtk/tests/testing.c"
+ (("g_test_add_func \\(\"/ui-tests.*;") ""))
;; These require XPM support in Gdk-Pixbuf which is obsolete.
(substitute* "gtk/tests/textbuffer.c"
(("g_test_add_func.*test_fill_empty\\);")

base-commit: b20956651a53a8f23828fdeb6945e1a31e6997a8
--
2.45.2
L
L
Liliana Marie Prikler wrote on 18 Aug 23:38 +0200
e81c2fd27caa1d1c9ebcc04bcaadf0eb96b8055b.camel@gmail.com
Am Sonntag, dem 18.08.2024 um 17:14 -0400 schrieb Jonathan
Frederickson:
Toggle quote (6 lines)
> * gnu/packages/gtk.scm (gtk+-2): Disable ui-tests. They seem to be
> flaky on aarch64, and I haven't been able to get the package to build
> without this change.
>
> Change-Id: I5aa5a89a2874ad1c737cba16c3aaeedced606de3
> ---
Given that gtk+-2 is fairly lowlevel package, you might want to wrap
this snippet so that only applies to arches where it's known to be
flaky.

Cheers
J
J
Jonathan Frederickson wrote on 19 Aug 00:57 +0200
07843118-fac7-45e8-88a9-fc699088fea8@app.fastmail.com
On Sun, Aug 18, 2024, at 5:38 PM, Liliana Marie Prikler wrote:
Toggle quote (4 lines)
> Given that gtk+-2 is fairly lowlevel package, you might want to wrap
> this snippet so that only applies to arches where it's known to be
> flaky.

Ah, good point - I'll try and work out how to do this, and send an updated patch soon.
J
J
Jonathan Frederickson wrote on 20 Aug 01:44 +0200
[PATCH v2] gnu: gtk+-2: Disable UI tests on aarch64.
(address . 72703@debbugs.gnu.org)(name . Jonathan Frederickson)(address . jonathan@terracrypt.net)
101515ca7bd0194a35b642044322529f3eb3ddbd.1724111051.git.jonathan@terracrypt.net
* gnu/packages/gtk.scm (gtk+-2): Disable ui-tests on aarch64. They seem to be
flaky on aarch64, and I haven't been able to get the package to build without
this change.

Change-Id: I5aa5a89a2874ad1c737cba16c3aaeedced606de3
---
gnu/packages/gtk.scm | 6 ++++++
1 file changed, 6 insertions(+)

Toggle diff (21 lines)
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 04183fa806..667e0d4dbf 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -980,6 +980,12 @@ (define-public gtk+-2
(("g_test_add_func \\(\"/recent-manager.*;") ""))
(substitute* "gtk/tests/defaultvalue.c"
(("return g_test_run\\(\\);") ""))
+ ;; UI tests seem to be flaky on aarch64
+ #$@(if (string=? (%current-system) "aarch64-linux")
+ (list
+ #~(substitute* "gtk/tests/testing.c"
+ (("g_test_add_func \\(\"/ui-tests.*;") "")))
+ #~())
;; These require XPM support in Gdk-Pixbuf which is obsolete.
(substitute* "gtk/tests/textbuffer.c"
(("g_test_add_func.*test_fill_empty\\);")

base-commit: b20956651a53a8f23828fdeb6945e1a31e6997a8
--
2.45.2
J
J
Jonathan Frederickson wrote on 20 Aug 01:53 +0200
(address . 72703@debbugs.gnu.org)
5c5c155f-d9ba-4f40-ae1e-afa494565a4b@app.fastmail.com
Alright, I think I got it, though I'll admit to being a bit unfamiliar with g-expressions. My primary laptop is aarch64, but I have an x86_64 server set up for build offloads. I ran a 'guix build --system=x86_64-linux' on the commits before and after and it didn't seem to trigger a rebuild, which is good.
Attachment: file
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 72703@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 72703
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch