(address . guix-patches@gnu.org)(name . Jonathan Frederickson)(address . jonathan@terracrypt.net)
* gnu/packages/gtk.scm (gtk+-2): Disable ui-tests. They seem to be flaky on
aarch64, and I haven't been able to get the package to build without this
change.
Change-Id: I5aa5a89a2874ad1c737cba16c3aaeedced606de3
---
gnu/packages/gtk.scm | 3 +++
1 file changed, 3 insertions(+)
Toggle diff (18 lines)
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 04183fa806..a0da976fab 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -980,6 +980,9 @@ (define-public gtk+-2
(("g_test_add_func \\(\"/recent-manager.*;") ""))
(substitute* "gtk/tests/defaultvalue.c"
(("return g_test_run\\(\\);") ""))
+ ;; UI tests seem to be flaky on aarch64
+ (substitute* "gtk/tests/testing.c"
+ (("g_test_add_func \\(\"/ui-tests.*;") ""))
;; These require XPM support in Gdk-Pixbuf which is obsolete.
(substitute* "gtk/tests/textbuffer.c"
(("g_test_add_func.*test_fill_empty\\);")
base-commit: b20956651a53a8f23828fdeb6945e1a31e6997a8
--
2.45.2