[PATCH] gnu: Add guile-qr-code.

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Artyom V. Poptsov
Owner
unassigned
Submitted by
Artyom V. Poptsov
Severity
normal

Debbugs page

Artyom V. Poptsov wrote 7 months ago
(address . guix-patches@gnu.org)(name . Artyom V. Poptsov)(address . poptsov.artyom@gmail.com)
3e61aca04c050690eea07ff2e1603aa13cfae821.1723989557.git.poptsov.artyom@gmail.com
* gnu/packages/guile-xyz.scm (guile-qr-code): New variable.

Change-Id: I8891a1ee442040a4f04183fca7bc1eca6a4fc951
---
gnu/packages/guile-xyz.scm | 35 +++++++++++++++++++++++++++++++++++
1 file changed, 35 insertions(+)

Toggle diff (50 lines)
diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index 0759c399c3..d3cd094f82 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -5793,6 +5793,41 @@ (define-public guile-cbor
(home-page "https://inqlab.net/git/guile-cbor.git")
(license license:gpl3+)))
+(define-public guile-qr-code
+ (package
+ (name "guile-qr-code")
+ (version "0.1.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/artyom-poptsov/guile-qr-code")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1pbsnkz8pw1x8n9mjq8rm37wmalzbcz98gk8mcfycyd896qdmf4w"))))
+ (build-system gnu-build-system)
+ (arguments
+ (list
+ #:phases #~(modify-phases %standard-phases
+ (delete 'strip))))
+ (native-inputs (list autoconf
+ automake
+ pkg-config
+ texinfo
+ ;; needed when cross-compiling.
+ guile-3.0
+ guile-lib
+ guile-png))
+ (inputs (list bash-minimal guile-3.0 guile-lib guile-png))
+ (synopsis "Guile QR Code library")
+ (description
+ "GNU Guile QR code generator that can create QR codes from text and binary data.
+The resulting QR codes can be rendered to ASCII art strings or to PNG images (using
+@url{https://github.com/artyom-poptsov/guile-png, Guile-PNG} API.)")
+ (home-page "https://github.com/artyom-poptsov/guile-qr-code")
+ (license (list license:gpl3+ license:expat))))
+
(define-public guile-quickcheck
(package
(name "guile-quickcheck")

base-commit: 71f0676a295841e2cc662eec0d3e9b7e69726035
--
2.45.2
Ludovic Courtès wrote 7 months ago
(name . Artyom V. Poptsov)(address . poptsov.artyom@gmail.com)(address . 72698-done@debbugs.gnu.org)
874j7dstlv.fsf@gnu.org
"Artyom V. Poptsov" <poptsov.artyom@gmail.com> skribis:

Toggle quote (4 lines)
> * gnu/packages/guile-xyz.scm (guile-qr-code): New variable.
>
> Change-Id: I8891a1ee442040a4f04183fca7bc1eca6a4fc951

Applied, thanks! And congrats for this new library. :-)

Ludo’.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 72698@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 72698
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help