(address . guix-patches@gnu.org)(name . gemmaro)(address . gemmaro.dev@gmail.com)
* gnu/packages/check.scm (checkmake): New variable.
Change-Id: Ic60c5c6d6cb66ff3a5760e11df741c5a4d7e7a4d
---
gnu/packages/check.scm | 53 ++++++++++++++++++++++++++++++++++++++++++
1 file changed, 53 insertions(+)
Toggle diff (86 lines)
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index d76e6f8c95..096264a87a 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -51,6 +51,7 @@
;;; Copyright © 2024 Giacomo Leidi <goodoldpaul@autistici.org>
;;; Copyright © 2024 Zheng Junjie <873216071@qq.com>
;;; Copyright © 2024 Navid Afkhami <navid.afkhami@mdc-berlin.de>
+;;; Copyright © 2024 gemmaro <gemmaro.dev@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -83,10 +84,12 @@ (define-module (gnu packages check)
#:use-module (gnu packages gnome)
#:use-module (gnu packages golang)
#:use-module (gnu packages golang-build)
+ #:use-module (gnu packages golang-check)
#:use-module (gnu packages golang-xyz)
#:use-module (gnu packages gtk)
#:use-module (gnu packages guile)
#:use-module (gnu packages guile-xyz)
+ #:use-module (gnu packages haskell-xyz)
#:use-module (gnu packages maths)
#:use-module (gnu packages ncurses)
#:use-module (gnu packages perl)
@@ -277,6 +280,56 @@ (define-public check-0.12
(base32
"0d22h8xshmbpl9hba9ch3xj8vb9ybm5akpsbbh7yj07fic4h2hj6"))))))
+(define-public checkmake
+ (package
+ (name "checkmake")
+ (version "0.2.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/mrtazz/checkmake")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1ajrgnm5mg4b317brx53b8cpjvdw6vin1rk6yh9vrhrz014ifps2"))
+ (modules '((guix build utils)))
+ (snippet `(begin
+ (delete-file-recursively "vendor")
+ (substitute* "Makefile"
+ (("(VERSION := ).+" _ field)
+ (string-append field
+ ,version)))))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/mrtazz/checkmake"
+ #:phases #~(modify-phases %standard-phases
+ (add-after 'install 'install-man
+ (lambda _
+ (setenv "BUILDER_NAME" "Guix")
+ (setenv "BUILDER_EMAIL" "bug-guix@gnu.org")
+ (with-directory-excursion "src/github.com/mrtazz/checkmake"
+ (for-each (lambda (file)
+ (let ((target (basename file ".md")))
+ (invoke "make" target)
+ (install-file target
+ (string-append #$output
+ "/share/man/man1"))))
+ (find-files "man/man1"))))))))
+ (native-inputs (list pandoc))
+ (propagated-inputs (list go-github-com-stretchr-testify
+ go-github-com-olekukonko-tablewriter
+ go-github-com-go-ini-ini
+ go-github-com-docopt-docopt-go))
+ (home-page "https://github.com/mrtazz/checkmake")
+ (synopsis "Linter and analyzer for @file{Makefile}")
+ (description
+ "@samp{checkmake} is an experimental tool for linting and checking
+Makefiles. It allows for a set of configurable rules being run
+against a @file{Makefile} or a set of @file{*.mk} files.")
+ (license license:expat)))
+
;;; XXX: This project is abandoned upstream, and included in modern catch2
;;; releases. It is still depended by the restinio test suite at this time,
;;; so keep it (see: https://github.com/Stiffstream/restinio/issues/181).
base-commit: 6c045f2c9eb7b8efe7c8a1002cda990abaa9be1a
--
2.45.2