[PATCH] gnu: Add checkmake.

  • Done
  • quality assurance status badge
Details
2 participants
  • gemmaro
  • Sharlatan Hellseher
Owner
unassigned
Submitted by
gemmaro
Severity
normal
G
G
gemmaro wrote on 18 Aug 08:35 +0200
(address . guix-patches@gnu.org)(name . gemmaro)(address . gemmaro.dev@gmail.com)
e84fe3298ec052f9b82684d8e402535efca0a479.1723962942.git.gemmaro.dev@gmail.com
* gnu/packages/check.scm (checkmake): New variable.

Change-Id: Ic60c5c6d6cb66ff3a5760e11df741c5a4d7e7a4d
---
gnu/packages/check.scm | 53 ++++++++++++++++++++++++++++++++++++++++++
1 file changed, 53 insertions(+)

Toggle diff (86 lines)
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index d76e6f8c95..096264a87a 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -51,6 +51,7 @@
;;; Copyright © 2024 Giacomo Leidi <goodoldpaul@autistici.org>
;;; Copyright © 2024 Zheng Junjie <873216071@qq.com>
;;; Copyright © 2024 Navid Afkhami <navid.afkhami@mdc-berlin.de>
+;;; Copyright © 2024 gemmaro <gemmaro.dev@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -83,10 +84,12 @@ (define-module (gnu packages check)
#:use-module (gnu packages gnome)
#:use-module (gnu packages golang)
#:use-module (gnu packages golang-build)
+ #:use-module (gnu packages golang-check)
#:use-module (gnu packages golang-xyz)
#:use-module (gnu packages gtk)
#:use-module (gnu packages guile)
#:use-module (gnu packages guile-xyz)
+ #:use-module (gnu packages haskell-xyz)
#:use-module (gnu packages maths)
#:use-module (gnu packages ncurses)
#:use-module (gnu packages perl)
@@ -277,6 +280,56 @@ (define-public check-0.12
(base32
"0d22h8xshmbpl9hba9ch3xj8vb9ybm5akpsbbh7yj07fic4h2hj6"))))))
+(define-public checkmake
+ (package
+ (name "checkmake")
+ (version "0.2.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/mrtazz/checkmake")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1ajrgnm5mg4b317brx53b8cpjvdw6vin1rk6yh9vrhrz014ifps2"))
+ (modules '((guix build utils)))
+ (snippet `(begin
+ (delete-file-recursively "vendor")
+ (substitute* "Makefile"
+ (("(VERSION := ).+" _ field)
+ (string-append field
+ ,version)))))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/mrtazz/checkmake"
+ #:phases #~(modify-phases %standard-phases
+ (add-after 'install 'install-man
+ (lambda _
+ (setenv "BUILDER_NAME" "Guix")
+ (setenv "BUILDER_EMAIL" "bug-guix@gnu.org")
+ (with-directory-excursion "src/github.com/mrtazz/checkmake"
+ (for-each (lambda (file)
+ (let ((target (basename file ".md")))
+ (invoke "make" target)
+ (install-file target
+ (string-append #$output
+ "/share/man/man1"))))
+ (find-files "man/man1"))))))))
+ (native-inputs (list pandoc))
+ (propagated-inputs (list go-github-com-stretchr-testify
+ go-github-com-olekukonko-tablewriter
+ go-github-com-go-ini-ini
+ go-github-com-docopt-docopt-go))
+ (home-page "https://github.com/mrtazz/checkmake")
+ (synopsis "Linter and analyzer for @file{Makefile}")
+ (description
+ "@samp{checkmake} is an experimental tool for linting and checking
+Makefiles. It allows for a set of configurable rules being run
+against a @file{Makefile} or a set of @file{*.mk} files.")
+ (license license:expat)))
+
;;; XXX: This project is abandoned upstream, and included in modern catch2
;;; releases. It is still depended by the restinio test suite at this time,
;;; so keep it (see: https://github.com/Stiffstream/restinio/issues/181).

base-commit: 6c045f2c9eb7b8efe7c8a1002cda990abaa9be1a
--
2.45.2
S
S
Sharlatan Hellseher wrote on 21 Aug 15:58 +0200
(address . 72690-done@debbugs.gnu.org)
874j7ec6zh.fsf@gmail.com
Hi,

Applied and pushed as 7a149c6003d25e8b2794b113d34062be134d7710 to master.

- modifications [4/4]
- [X] Swap pandoc to go-github-com-go-md2man to generate man pages from Markdown
- [X] Set all inputs as native
- [X] Do not install sources
- [X] Do not set version in snippet as it has no effect, we do not use provided Makefile

--
Oleg
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEmEeB3micIcJkGAhndtcnv/Ys0rUFAmbF8qIACgkQdtcnv/Ys
0rVWoBAAxeaURQoinqOJ2V39BnL/FHvKBMTS63BmE6p2C5pY9jh5/o6HdBWhHNIM
xojlDuIxyt8iciuF5milfG9PcJyKvX16DvVlbflcTPLdxbiww6dr6IG20qXB4zn9
K0cL9I7DLMSztp/L84m1WvipDnNQdVV9ILLm51cYG/DCl1fMJ7f0rFfUe2CJfkvN
HFYbfZ+QvVmMdS3hx+b1rfJuyilRb/m6NlMLLER1oAM8N/SodeDUAOAvfFFv/MFr
asP5/Qqh4quSKuTMhN7JlRzUVroyMvxPzUQmBbaf/Der+zoRGmaU4+ERgb6NjW94
Fp114ZyE3V/EeyXZc57TOP2wp99+TxTDIeNVz+JW3b0O3acOnW55XAHynZvhKhqB
IBwnfBxCWxhyR4feky4khWg8KApzCsKWD31jaz0vgf/SlSg3HzDHyZHFseRxiTcM
UHB6Pail9BK0lNaXlLV4k57JBnVxc5917f/22WY7PNEnxaNCx64dJPhBPWpY0xGh
sLOVzzEQaTeqOuCFqZwtGp7bqmUOLhN/yv1G0VlxcmLA/dbJJzlqz/KwH8AAS00f
deN0kxpEKGBV05vm2YgFKmLAir2M1imPvAtwXn9k+qZV2tmg9ebB4Dad6KfcDbfO
d8x6jK3gmJWiYUI7AGCPfLl+iYiwpGrEaZEtBIT2VCmDCymifJ4=
=qb5j
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 72690@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 72690
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch