Apoorv wrote 7 months ago
(name . Guix Patches)(address . guix-patches@gnu.org)
`home-pipewire-service-type` should provide the `pw-` and `wpctl` commands, so I modified the `home-pipewire-service-type` to add the `home-profile-service-type` extension for that.
I have to manually install both packages (pipewire and wireplumber) to get those commands, when this service-type could be doing all that for us.
--
Sent with Tuta; enjoy secure & ad-free emails:
From 6f71b946875479a071baa8e20bc8f05e72610122 Mon Sep 17 00:00:00 2001
From: apoorv569 <apoorvs569@gmail.com>
Date: Fri, 16 Aug 2024 22:40:22 +0530
Subject: [PATCH 14/14] Add home-pipewire-profile-service to
home-pipewire-service-type
---
gnu/home/services/sound.scm | 7 +++++++
1 file changed, 7 insertions(+)
Toggle diff (27 lines)
diff --git a/gnu/home/services/sound.scm b/gnu/home/services/sound.scm
index 313a57305b..8afdd84740 100644
--- a/gnu/home/services/sound.scm
+++ b/gnu/home/services/sound.scm
@@ -51,6 +51,11 @@ (define-configuration/no-serialization home-pipewire-configuration
"When true, enable PipeWire's PulseAudio emulation support, allowing
PulseAudio clients to use PipeWire transparently."))
+(define (home-pipewire-profile-service config)
+ (list
+ (home-pipewire-configuration-pipewire config)
+ (home-pipewire-configuration-wireplumber config)))
+
(define (home-pipewire-shepherd-service config)
(shepherd-service
(documentation "PipeWire media processing.")
@@ -121,6 +126,8 @@ (define home-pipewire-service-type
(extensions
(list (service-extension home-shepherd-service-type
home-pipewire-shepherd-services)
+ (service-extension home-profile-service-type
+ home-pipewire-profile-service)
(service-extension home-xdg-configuration-files-service-type
home-pipewire-xdg-configuration)))
(description
--
2.45.2