[PATCH] Add home-pipewire-profile-service to home-pipewire-service-type

  • Open
  • quality assurance status badge
Details
2 participants
  • Apoorv
  • Sergey Trofimov
Owner
unassigned
Submitted by
Apoorv
Severity
normal
Merged with

Debbugs page

Apoorv wrote 7 months ago
(name . Guix Patches)(address . guix-patches@gnu.org)
O4RAjXI--3-9@tuta.io
`home-pipewire-service-type` should provide the `pw-` and `wpctl` commands, so I modified the `home-pipewire-service-type` to add the `home-profile-service-type` extension for that.

I have to manually install both packages (pipewire and wireplumber) to get those commands, when this service-type could be doing all that for us.

--
Sent with Tuta; enjoy secure & ad-free emails:
Attachment: file
From 6f71b946875479a071baa8e20bc8f05e72610122 Mon Sep 17 00:00:00 2001
From: apoorv569 <apoorvs569@gmail.com>
Date: Fri, 16 Aug 2024 22:40:22 +0530
Subject: [PATCH 14/14] Add home-pipewire-profile-service to
home-pipewire-service-type

---
gnu/home/services/sound.scm | 7 +++++++
1 file changed, 7 insertions(+)

Toggle diff (27 lines)
diff --git a/gnu/home/services/sound.scm b/gnu/home/services/sound.scm
index 313a57305b..8afdd84740 100644
--- a/gnu/home/services/sound.scm
+++ b/gnu/home/services/sound.scm
@@ -51,6 +51,11 @@ (define-configuration/no-serialization home-pipewire-configuration
"When true, enable PipeWire's PulseAudio emulation support, allowing
PulseAudio clients to use PipeWire transparently."))
+(define (home-pipewire-profile-service config)
+ (list
+ (home-pipewire-configuration-pipewire config)
+ (home-pipewire-configuration-wireplumber config)))
+
(define (home-pipewire-shepherd-service config)
(shepherd-service
(documentation "PipeWire media processing.")
@@ -121,6 +126,8 @@ (define home-pipewire-service-type
(extensions
(list (service-extension home-shepherd-service-type
home-pipewire-shepherd-services)
+ (service-extension home-profile-service-type
+ home-pipewire-profile-service)
(service-extension home-xdg-configuration-files-service-type
home-pipewire-xdg-configuration)))
(description
--
2.45.2
Sergey Trofimov wrote 5 days ago
control message for bug #73282
(address . control@debbugs.gnu.org)
87r039jpsw.fsf@sarg.org.ru
merge 73282 72673
quit
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 72673@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 72673
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help