Apoorv wrote 7 months ago
(name . Guix Patches)(address . guix-patches@gnu.org)
This is a patch to add a new package, `bitrot-plugins` to `gnu/packages/music.scm`.
--
Sent with Tuta; enjoy secure & ad-free emails:
From c9ff439cb3fa982895e49f57408c1d41c5e63e86 Mon Sep 17 00:00:00 2001
From: apoorv569 <apoorvs569@gmail.com>
Date: Fri, 16 Aug 2024 15:36:25 +0530
Subject: [PATCH 12/13] Add bitrot-plugins package
---
gnu/packages/music.scm | 28 ++++++++++++++++++++++++++++
1 file changed, 28 insertions(+)
Toggle diff (41 lines)
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index d3e247bd10..5b89419b07 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -8549,6 +8549,34 @@ (define-public ykchorus
well-known Japanese vintage analog synthesizers (You Know which).")
(license license:gpl2))))
+(define-public bitrot-plugins
+ (let ((commit "06a72cd6cbe99b469e57a662cfb34e1cfe75e070")
+ (revision "0"))
+ (package
+ (name "bitrot-plugins")
+ (version (git-version "0.7" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/grejppi/bitrot")
+ (recursive? #t)
+ (commit commit)))
+ (sha256
+ (base32 "0gfhy6a1cc8czrw2bq922b87584fbzpvwdzrl0vv3acda03z1f85"))
+ (file-name (git-file-name name version))))
+ (build-system waf-build-system)
+ (arguments
+ `(#:configure-flags (list "--platform=linux64")
+ #:phases (modify-phases %standard-phases
+ ;; no check target
+ (delete 'check))))
+ (home-page "https://github.com/grejppi/bitrot")
+ (synopsis "Audio effect plugins (LV2, VST2, LADSPA) for glitch effects")
+ (description
+ "Audio effect plugins (LV2, VST2, LADSPA) for glitch effects")
+ (license license:asl2.0))))
+
;;;
;;; Avoid adding new packages to the end of this file. To reduce the chances
;;; of a merge conflict, place them above by existing packages with similar
--
2.45.2