[PATCH] Add ykchorus package

  • Open
  • quality assurance status badge
Details
One participant
  • Apoorv
Owner
unassigned
Submitted by
Apoorv
Severity
normal
A
A
Apoorv wrote on 16 Aug 12:42 +0200
(name . Guix Patches)(address . guix-patches@gnu.org)
O4Plwm6--3-9@tuta.io
This is a patch to add a new package, `ykchorus` to `gnu/packages/music.scm`.

--
Sent with Tuta; enjoy secure & ad-free emails:
Attachment: file
From d3128306aa570d4c4b7b535453324cfc252b8687 Mon Sep 17 00:00:00 2001
From: apoorv569 <apoorvs569@gmail.com>
Date: Fri, 16 Aug 2024 15:35:02 +0530
Subject: [PATCH 11/13] Add ykchorus package

---
gnu/packages/music.scm | 42 ++++++++++++++++++++++++++++++++++++++++++
1 file changed, 42 insertions(+)

Toggle diff (55 lines)
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index ad3ec3973e..d3e247bd10 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -8507,6 +8507,48 @@ (define-public drumgizmo
"An open source cross-platform drum plugin and stand-alone application (lv2)")
(license license:lgpl3))))
+(define-public ykchorus
+ (let ((commit "ee0e362f8ef30b55a440715e4da3bfb3dad6a30f")
+ (revision "1"))
+ (package
+ (name "ykchorus")
+ (version (git-version "0.2.4" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/SpotlightKid/ykchorus")
+ (recursive? #t)
+ (commit commit)))
+ (sha256
+ (base32 "0bz527l3wc0pzsfr384r9cy6x4ch2mxigyp4a3487sm74ylwwfqd"))
+ (file-name (git-file-name name version))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:make-flags
+ (list
+ (string-append "PREFIX=" (assoc-ref %outputs "out"))
+ (string-append "CC=" ,(cc-for-target)))
+ #:phases (modify-phases %standard-phases
+ ;; no configure target
+ (delete 'configure)
+ ;; check phase fails so deleting it for now
+ (delete 'check))))
+ (inputs (list lv2
+ libx11
+ libglvnd
+ liblo
+ dssi
+ jack-2))
+ (native-inputs (list lv2lint pkg-config))
+ (home-page "https://github.com/SpotlightKid/ykchorus")
+ (synopsis
+ "A chorus audio effect plugin based on DSP code by Togu Audio Line (TAL)")
+ (description
+ "A chorus effect inspired by the one found in certain
+well-known Japanese vintage analog synthesizers (You Know which).")
+ (license license:gpl2))))
+
;;;
;;; Avoid adding new packages to the end of this file. To reduce the chances
;;; of a merge conflict, place them above by existing packages with similar
--
2.45.2
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 72663@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 72663
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch