[PATCH] Add aida-x package

  • Open
  • quality assurance status badge
Details
One participant
  • Apoorv
Owner
unassigned
Submitted by
Apoorv
Severity
normal
A
A
Apoorv wrote on 16 Aug 2024 12:39
(name . Guix Patches)(address . guix-patches@gnu.org)
O4PlEcf--3-9@tuta.io
This is a patch to add a new package, `aida-x` to `gnu/packages/music.scm`.

--
Sent with Tuta; enjoy secure & ad-free emails:
Attachment: file
From 7c69443f9faa4f5baec1c4683e406ee88652d57c Mon Sep 17 00:00:00 2001
From: apoorv569 <apoorvs569@gmail.com>
Date: Fri, 16 Aug 2024 15:32:09 +0530
Subject: [PATCH 06/13] Add aida-x package

---
gnu/packages/music.scm | 58 ++++++++++++++++++++++++++++++++++++++++++
1 file changed, 58 insertions(+)

Toggle diff (71 lines)
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 36729506a3..b90d25cb6a 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -8222,6 +8222,64 @@ (define-public aether
"Aether is an algorithmic reverb LV2 plugin based on Cloudseed.")
(license license:expat))))
+(define-public aida-x
+ (let ((commit "1027cdd1756505fd2ab1a4adb91a394a3af9df57")
+ (revision "1"))
+ (package
+ (name "aida-x")
+ (version (git-version "1.1.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/AidaDSP/AIDA-X")
+ (recursive? #t)
+ (commit commit)))
+ (sha256
+ (base32 "04imgcv73b7n8cd00dsghihfxi45wssvsj5p6awvd9q36ji186m8"))
+ (file-name (git-file-name name version))))
+ (build-system cmake-build-system)
+ (arguments
+ (list
+ #:tests? #f ;no test target
+ #:build-type "Release"
+ #:phases
+ #~(modify-phases %standard-phases
+ (replace 'install
+ ;; no install target
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (lib (string-append out "/lib"))
+ (lv2 (string-append lib "/lv2"))
+ (vst3 (string-append lib "/vst3")))
+ (mkdir-p lv2)
+ (mkdir-p vst3)
+ ;; Install LV2 plugin.
+ (copy-recursively
+ "bin/AIDA-X.lv2"
+ (string-append lv2 "/AIDA-X.lv2"))
+ ;; Install VST3 plugin.
+ (copy-recursively
+ "bin/AIDA-X.vst3"
+ (string-append vst3 "/AIDA-X.vst3"))
+ #t))))))
+ (inputs (list libx11
+ libglvnd
+ libxcursor
+ libxrandr
+ alsa-lib
+ sdl2))
+ (native-inputs (list python pkg-config))
+ (home-page "https://github.com/AidaDSP/AIDA-X")
+ (synopsis "AIDA-X, an Amp Model Player leveraging AI")
+ (description
+ "AIDA-X is an Amp Model Player, allowing it to load models of AI trained music gear,
+which you can then play through! ?
+Its main intended use is to provide high fidelity simulations of amplifiers.
+However, it is also possible to run entire signal chains consisting of any combination of amp,
+cab, dist, drive, fuzz, boost and eq.")
+ (license license:gpl3))))
+
;;;
;;; Avoid adding new packages to the end of this file. To reduce the chances
;;; of a merge conflict, place them above by existing packages with similar
--
2.45.2
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 72662@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 72662
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch