[PATCH] Add cardinal package

  • Open
  • quality assurance status badge
Details
One participant
  • Apoorv
Owner
unassigned
Submitted by
Apoorv
Severity
normal
A
A
Apoorv wrote on 16 Aug 12:39 +0200
(name . Guix Patches)(address . guix-patches@gnu.org)
O4PlLkm--3-9@tuta.io
This is a patch to add a new package, `cardinal` to `gnu/packages/music.scm`.

--
Sent with Tuta; enjoy secure & ad-free emails:
Attachment: file
From 90ed2a0a87c878f1db18e2b7431e9e0b156d8a77 Mon Sep 17 00:00:00 2001
From: apoorv569 <apoorvs569@gmail.com>
Date: Fri, 16 Aug 2024 15:32:43 +0530
Subject: [PATCH 07/13] Add cardinal package

---
gnu/packages/music.scm | 51 ++++++++++++++++++++++++++++++++++++++++++
1 file changed, 51 insertions(+)

Toggle diff (64 lines)
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index b90d25cb6a..387901dc09 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -8280,6 +8280,57 @@ (define-public aida-x
cab, dist, drive, fuzz, boost and eq.")
(license license:gpl3))))
+(define-public cardinal
+ (let ((commit "6bb87fd55239878b0e0880e0b0aac18f2e35c845")
+ (revision "1"))
+ (package
+ (name "cardinal")
+ (version (git-version "24.05" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/DISTRHO/Cardinal")
+ (recursive? #t)
+ (commit commit)))
+ (sha256
+ (base32 "18b85zikq3qs266910wny0ljk8pwykzk3c9wbnzfy8dbzcq5x2av"))
+ (file-name (git-file-name name version))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:make-flags
+ (list "DESTDIR="
+ (string-append "PREFIX=" (assoc-ref %outputs "out"))
+ (string-append "CC=" ,(cc-for-target))
+ "SYSDEPS=true")
+ #:phases (modify-phases %standard-phases
+ ;; no configure target
+ (delete 'configure)
+ ;; no check target
+ (delete 'check))))
+ (inputs (list fftwf
+ libx11
+ libxext
+ libxcursor
+ libxrandr
+ libsndfile
+ liblo
+ mesa
+ libarchive
+ libsamplerate
+ jansson
+ speexdsp))
+ (native-inputs (list python cmake pkg-config))
+ (home-page "https://cardinal.kx.studio/")
+ (synopsis "Virtual modular synthesizer plugin")
+ (description
+ "Cardinal is a free and open-source virtual modular synthesizer plugin,
+available in AudioUnit/CLAP/LV2/VST2/VST3 plugin formats
+and as a standalone app for FreeBSD, Linux, macOS, Windows and the Web.
+It is based on the popular VCV Rack but with a focus on
+being a fully self-contained plugin version.")
+ (license license:gpl3))))
+
;;;
;;; Avoid adding new packages to the end of this file. To reduce the chances
;;; of a merge conflict, place them above by existing packages with similar
--
2.45.2
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 72661@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 72661
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch