[PATCH] Add drumgizmo package

  • Open
  • quality assurance status badge
Details
One participant
  • Apoorv
Owner
unassigned
Submitted by
Apoorv
Severity
normal
A
A
Apoorv wrote on 16 Aug 2024 12:41
(name . Guix Patches)(address . guix-patches@gnu.org)
O4PlpUG--B-9@tuta.io
This is a patch to add a new package, `drumgizmo` to `gnu/packages/music.scm`.

--
Sent with Tuta; enjoy secure & ad-free emails:
Attachment: file
From 09c95587b26012822d098775f3a94fbefbcd7c36 Mon Sep 17 00:00:00 2001
From: apoorv569 <apoorvs569@gmail.com>
Date: Fri, 16 Aug 2024 15:34:38 +0530
Subject: [PATCH 10/13] Add drumgizmo package

---
gnu/packages/music.scm | 46 ++++++++++++++++++++++++++++++++++++++++++
1 file changed, 46 insertions(+)

Toggle diff (59 lines)
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 9cf0f70951..ad3ec3973e 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -8461,6 +8461,52 @@ (define-public kapitonov-plugins-pack
Compatible with hosts such as Ardour, Qtractor, Carla, guitarix, jack-rack.")
(license license:gpl3))))
+(define-public drumgizmo
+ (let ((commit "20a6f8c44a1ffd3a0628bec6a65a71a2e4013acc")
+ (revision "0"))
+ (package
+ (name "drumgizmo")
+ (version (git-version "1.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "http://cgit.drumgizmo.org/drumgizmo.git")
+ (recursive? #t)
+ (commit commit)))
+ (sha256
+ (base32 "0mpappp9k9can94csc620ah79ywqpcrp045fvv3f7yx9dbsnmh4f"))
+ (file-name (git-file-name name version))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:make-flags (list "CC=gcc")
+ #:configure-flags (list "--enable-lv2") ;"--enable-vst" ;; vst needs vst sdk
+ #:phases (modify-phases %standard-phases
+ (replace 'bootstrap
+ (lambda _
+ (invoke "sh" "autogen.sh"))))))
+ (inputs (list libsmf
+ libxext
+ expat
+ jack-2
+ libsndfile
+ alsa-lib
+ zita-resampler))
+ (native-inputs (list autoconf
+ automake
+ libtool
+ gettext-minimal
+ lv2
+ libx11
+ glib
+ pkg-config))
+ (home-page "https://drumgizmo.org")
+ (synopsis
+ "An open source cross-platform drum plugin and stand-alone application (lv2)")
+ (description
+ "An open source cross-platform drum plugin and stand-alone application (lv2)")
+ (license license:lgpl3))))
+
;;;
;;; Avoid adding new packages to the end of this file. To reduce the chances
;;; of a merge conflict, place them above by existing packages with similar
--
2.45.2
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 72660@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 72660
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch