[PATCH] Add kapitonov-plugins-pack package

  • Open
  • quality assurance status badge
Details
One participant
  • Apoorv
Owner
unassigned
Submitted by
Apoorv
Severity
normal
A
A
Apoorv wrote on 16 Aug 12:41 +0200
(name . Guix Patches)(address . guix-patches@gnu.org)
O4Plhno--3-9@tuta.io
This is a patch to add a new package, `kapitonov-plugins-pack` to `gnu/packages/music.scm`.

--
Sent with Tuta; enjoy secure & ad-free emails:
Attachment: file
From fa027c6333a6817398d9476de31d9e01b9a74c30 Mon Sep 17 00:00:00 2001
From: apoorv569 <apoorvs569@gmail.com>
Date: Fri, 16 Aug 2024 15:33:56 +0530
Subject: [PATCH 09/13] Add kapitonov-plugins-pack package

---
gnu/packages/music.scm | 57 ++++++++++++++++++++++++++++++++++++++++++
1 file changed, 57 insertions(+)

Toggle diff (70 lines)
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index dedbb7b961..9cf0f70951 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -8404,6 +8404,63 @@ (define-public uhhyou-plugins
(description "Uhhyou Plugins VST3")
(license license:gpl3))))
+(define-public kapitonov-plugins-pack
+ (let ((commit "241899d07163156a70c4a722b83581da3434ca51")
+ (revision "0"))
+ (package
+ (name "kapitonov-plugins-pack")
+ (version (git-version "1.2.1" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url
+ "https://github.com/olegkapitonov/Kapitonov-Plugins-Pack.git")
+ (recursive? #t)
+ (commit commit)))
+ (sha256
+ (base32 "1q8nmsb9j4dl601005w001zbgsm55hp9g6w2j6mmlnygs8lksifq"))
+ (file-name (git-file-name name version))))
+ (build-system meson-build-system)
+ (arguments
+ (list
+ #:build-type "release"))
+ (inputs (list cairo
+ xcb-util-cursor
+ xcb-util-keysyms
+ xcb-util
+ xcb-util-wm
+ xcb-util-image
+ xcb-util-renderutil
+ libxrender
+ libx11
+ libxcb
+ libxau
+ libxdmcp
+ pixman
+ fontconfig
+ freetype
+ libpng
+ libxext
+ libbsd
+ expat
+ fftw
+ zlib))
+ (native-inputs (list lv2
+ ladspa
+ zita-resampler
+ zita-convolver
+ cmake
+ faust-2
+ boost
+ pkg-config))
+ (home-page "https://github.com/olegkapitonov/Kapitonov-Plugins-Pack")
+ (synopsis "Set of plugins for guitar sound processing.")
+ (description
+ "Set of plugins for guitar sound processing.
+Compatible with hosts such as Ardour, Qtractor, Carla, guitarix, jack-rack.")
+ (license license:gpl3))))
+
;;;
;;; Avoid adding new packages to the end of this file. To reduce the chances
;;; of a merge conflict, place them above by existing packages with similar
--
2.45.2
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 72659@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 72659
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch