[PATCH] Add aether package

  • Open
  • quality assurance status badge
Details
One participant
  • Apoorv
Owner
unassigned
Submitted by
Apoorv
Severity
normal
A
A
Apoorv wrote on 16 Aug 12:38 +0200
(name . Guix Patches)(address . guix-patches@gnu.org)
O4Pl3wh--3-9@tuta.io
This is a patch to add a new package, `aether` to `gnu/packages/music.scm`.

--
Sent with Tuta; enjoy secure & ad-free emails:
Attachment: file
From 72775223f9187ba58168e38858cc2cb266b5a098 Mon Sep 17 00:00:00 2001
From: apoorv569 <apoorvs569@gmail.com>
Date: Fri, 16 Aug 2024 15:31:38 +0530
Subject: [PATCH 05/13] Add aether package

---
gnu/packages/music.scm | 42 ++++++++++++++++++++++++++++++++++++++++++
1 file changed, 42 insertions(+)

Toggle diff (55 lines)
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index bb03f3d532..36729506a3 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -8180,6 +8180,48 @@ (define-public drops
(home-page "https://github.com/clearly-broken-software/drops")
(license license:gpl3+))))
+(define-public aether
+ (let ((commit "0beea433e2130473d934f5d46a138a0a148d84db")
+ (revision "0"))
+ (package
+ (name "aether")
+ (version (git-version "1.2.1" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/Dougal-s/Aether")
+ (recursive? #t)
+ (commit commit)))
+ (sha256
+ (base32 "163xyp1n077pilnx4acbqjy2npnsdsngwhihass315i00csh14dh"))
+ (file-name (git-file-name name version))))
+ (build-system cmake-build-system)
+ (arguments
+ (list
+ #:configure-flags #~(list "-DBUILD_GUI=ON")
+ #:tests? #f ;no test target
+ #:build-type "Release"
+ #:phases
+ #~(modify-phases %standard-phases
+ (replace 'install
+ ;; no install target
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (lv2 (string-append out "/lib/lv2")))
+ ;; Install LV2.
+ (mkdir-p lv2)
+ (copy-recursively
+ "aether.lv2"
+ (string-append lv2 "/aether.lv2"))))))))
+ (inputs (list libx11 glu mesa libglvnd))
+ (native-inputs (list pkg-config))
+ (home-page "https://dougal-s.github.io/Aether/")
+ (synopsis "An algorithmic reverb LV2 based on Cloudseed")
+ (description
+ "Aether is an algorithmic reverb LV2 plugin based on Cloudseed.")
+ (license license:expat))))
+
;;;
;;; Avoid adding new packages to the end of this file. To reduce the chances
;;; of a merge conflict, place them above by existing packages with similar
--
2.45.2
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 72658@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 72658
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch