[PATCH] Add bespokesynth package

  • Open
  • quality assurance status badge
Details
One participant
  • Apoorv
Owner
unassigned
Submitted by
Apoorv
Severity
normal
A
A
Apoorv wrote on 16 Aug 12:35 +0200
(name . Guix Patches)(address . guix-patches@gnu.org)
O4PkJAU--3-9@tuta.io
This is a patch to add a new package, `bespokesynth` to `gnu/packages/music.scm`.

--
Sent with Tuta; enjoy secure & ad-free emails:
Attachment: file
From ad747fefd837303a6c24a59125811853c30eb74e Mon Sep 17 00:00:00 2001
From: apoorv569 <apoorvs569@gmail.com>
Date: Fri, 16 Aug 2024 15:26:39 +0530
Subject: [PATCH 02/13] Add bespokesynth package

---
gnu/packages/music.scm | 53 ++++++++++++++++++++++++++++++++++++++++++
1 file changed, 53 insertions(+)

Toggle diff (66 lines)
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 0b418fa7a7..7a4b272013 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -8028,6 +8028,59 @@ (define-public airwindows-lv2
"This is an LV2 port of the Airwindows plugins originally created by Chris Johnson.")
(license license:expat))))
+(define-public bespokesynth
+ (let ((commit "faf42ee537195c114837ed2571e2c9ec5830aab0")
+ (revision "1"))
+ (package
+ (name "bespokesynth")
+ (version (git-version "1.2.1" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/BespokeSynth/BespokeSynth")
+ (recursive? #t)
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0np0762vzqbxx0srgyi2kimzd3h3lycmr83wi67df9x83dyck152"))))
+ (inputs (list xcb-util-cursor
+ xcb-util-keysyms
+ xcb-util
+ libxkbcommon
+ libxcb
+ gtk+
+ webkitgtk
+ curl
+ alsa-lib
+ alsa-utils
+ jack-2
+ freetype
+ libxinerama
+ libxrandr
+ mesa
+ libxcursor
+ libusb))
+ (native-inputs (list ninja patchelf pkg-config python))
+ (build-system cmake-build-system)
+ (arguments
+ (list
+ #:tests? #f ;No test target available
+ #:build-type "Release"
+ #:phases
+ #~(modify-phases
+ %standard-phases
+ (add-after 'unpack 'pre-configure
+ (lambda _
+ ;; Override default location of fonts.conf.
+ (substitute* "libs/JUCE/modules/juce_graphics/native/juce_Fonts_linux.cpp"
+ (("/usr/share/fonts/fonts.conf")
+ "/run/current-system/profile/etc/fonts/fonts.conf")))))))
+ (home-page "http://bespokesynth.com/")
+ (synopsis "Software modular synth")
+ (description "Software modular synth")
+ (license license:gpl3))))
+
;;;
;;; Avoid adding new packages to the end of this file. To reduce the chances
;;; of a merge conflict, place them above by existing packages with similar
--
2.45.2
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 72655@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 72655
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch