[PATCH] gnu: Add emacs-tinysegmenter.

  • Done
  • quality assurance status badge
Details
3 participants
  • Liliana Marie Prikler
  • Nicolas Goaziou
  • Spencer King
Owner
unassigned
Submitted by
Spencer King
Severity
normal

Debbugs page

Spencer King wrote 7 months ago
(address . guix-patches@gnu.org)(name . Spencer King)(address . spencer@nursiapress.com)
3bcc3051453c6c8391959e007ba3f42f6806fcce.1723691159.git.spencer@nursiapress.com
* gnu/packages/emacs-xyz.scm (emacs-tinysegmenter): New variable.

Change-Id: Ibad46e4db2a1d49b4f40c8ea6d2f6f19d271aa29
---
gnu/packages/emacs-xyz.scm | 22 ++++++++++++++++++++++
1 file changed, 22 insertions(+)

Toggle diff (44 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index df66aea507..0c6af181fa 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -143,6 +143,7 @@
;;; Copyright © 2024 Noé Lopez <noelopez@free.fr>
;;; Copyright © 2024 gemmaro <gemmaro.dev@gmail.com>
;;; Copyright © 2024 Daniel Szmulewicz <daniel.szmulewicz@gmail.com>
+;;; Copyright © 2024 Spencer King <spencer.king@nursiapress.com>
;;;
;;; This file is part of GNU Guix.
@@ -6301,6 +6302,27 @@ (define-public emacs-kanji
and limited version of the images provided by the KanjiVG project.")
(license license:gpl3+))))
+(define-public emacs-tinysegmenter
+ (package
+ (name "emacs-tinysegmenter")
+ (version "20141124.1013")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/myuhe/tinysegmenter.el")
+ (commit "872134704bd25c13a4c59552433da4c6881b5230")))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1n8cn6mr26hgmsm2mkbj5gs6dv61d0pap8ija4g0n1vsibfhzd8j"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/myuhe/tinysegmenter.el")
+ (synopsis "Super compact Japanese tokenizer in Emacs Lisp")
+ (description
+ "This package provides functions for tokenizing Japanese text in
+Emacs buffers.")
+ (license license:bsd-3)))
+
(define-public emacs-kbd
;; Package has no release. Version is extracted from "Version:" keyword in
;; main file.

base-commit: ca5ff8aa8b50ac317003d76cc4ea2a621d5a3819
--
2.41.0
Spencer King wrote 7 months ago
(no subject)
(address . 72632@debbugs.gnu.org)
2768198.mvXUDI8C0e@localhost.localdomain
If you are looking to confirm the license it is linked in a source code comment
in the file tinysegmenter.el.
Liliana Marie Prikler wrote 7 months ago
Re: [bug#72632] [PATCH] gnu: Add emacs-tinysegmenter.
(name . Spencer King)(address . spencer@nursiapress.com)(address . 72632@debbugs.gnu.org)(name . Katherine Cox-Buday)(address . cox.katherine.e+guix@gmail.com)(name . Andrew Tropin)(address . andrew@trop.in)
ec518e41e6698ff38ad5545d3d737287479638f9.camel@gmail.com
Am Mittwoch, dem 14.08.2024 um 22:05 -0500 schrieb Spencer King:
Toggle quote (27 lines)
> * gnu/packages/emacs-xyz.scm (emacs-tinysegmenter): New variable.
>
> Change-Id: Ibad46e4db2a1d49b4f40c8ea6d2f6f19d271aa29
> ---
>  gnu/packages/emacs-xyz.scm | 22 ++++++++++++++++++++++
>  1 file changed, 22 insertions(+)
>
> diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
> index df66aea507..0c6af181fa 100644
> --- a/gnu/packages/emacs-xyz.scm
> +++ b/gnu/packages/emacs-xyz.scm
> @@ -143,6 +143,7 @@
>  ;;; Copyright © 2024 Noé Lopez <noelopez@free.fr>
>  ;;; Copyright © 2024 gemmaro <gemmaro.dev@gmail.com>
>  ;;; Copyright © 2024 Daniel Szmulewicz <daniel.szmulewicz@gmail.com>
> +;;; Copyright © 2024 Spencer King <spencer.king@nursiapress.com>
>  
>  ;;;
>  ;;; This file is part of GNU Guix.
> @@ -6301,6 +6302,27 @@ (define-public emacs-kanji
>  and limited version of the images provided by the KanjiVG project.")
>        (license license:gpl3+))))
>  
> +(define-public emacs-tinysegmenter
> +  (package
> +    (name "emacs-tinysegmenter")
> +    (version "20141124.1013")
Note: we don't do MELPA versioning. Use git-version instead.
Toggle quote (6 lines)
> +    (source
> +     (origin
> +       (method git-fetch)
> +       (uri (git-reference
> +             (url "https://github.com/myuhe/tinysegmenter.el")
> +             (commit "872134704bd25c13a4c59552433da4c6881b5230")))
IMHO, commit tags should always be let-bound. There are a few odd
cases in which they aren't, but these are exceptions, not the rule.
Toggle quote (7 lines)
> +       (file-name (git-file-name name version))
> +       (sha256
> +        (base32
> "1n8cn6mr26hgmsm2mkbj5gs6dv61d0pap8ija4g0n1vsibfhzd8j"))))
> +    (build-system emacs-build-system)
> +    (home-page "https://github.com/myuhe/tinysegmenter.el")
> +    (synopsis "Super compact Japanese tokenizer in Emacs Lisp")
Avoid marketing terms like "super compact". "Compact" ought to suffice
if there's a distinction to make.
Toggle quote (6 lines)
> +    (description
> +     "This package provides functions for tokenizing Japanese text
> in
> +Emacs buffers.")
> +    (license license:bsd-3)))

Cheers
Nicolas Goaziou wrote 7 months ago
(name . Spencer King)(address . spencer@nursiapress.com)(address . 72632-done@debbugs.gnu.org)
87ttffob0d.fsf@nicolasgoaziou.fr
Hello,

Spencer King <spencer@nursiapress.com> writes:

Toggle quote (2 lines)
> * gnu/packages/emacs-xyz.scm (emacs-tinysegmenter): New variable.

I applied the patch with the changes suggested by Liliana. Thank you.

Regards,
--
Nicolas Goaziou
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 72632@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 72632
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help