Danny Milosavljevic wrote 7 months ago
(address . guix-patches@gnu.org)
From 2e1ddf5bc553ee2218489fd9ef2467bd1e5cf7c0 Mon Sep 17 00:00:00 2001
Message-ID: <2e1ddf5bc553ee2218489fd9ef2467bd1e5cf7c0.1723458264.git.dannym@scratchpost.org>
From: Danny Milosavljevic <dannym@scratchpost.org>
Date: Mon, 12 Aug 2024 12:16:12 +0200
Subject: [PATCH] js: Color failures where a dependency has failed already
light red.
* src/static/js/cuirass.js (color): Modify.
---
src/static/js/cuirass.js | 4 +++-
1 file changed, 3 insertions(+), 1 deletion(-)
Toggle diff (19 lines)
diff --git a/src/static/js/cuirass.js b/src/static/js/cuirass.js
index 42f28f1..b09fab2 100644
--- a/src/static/js/cuirass.js
+++ b/src/static/js/cuirass.js
@@ -150,7 +150,9 @@ ready(() => {
case 0:
return '#9f9'; /* high contrast with others */
case 1:
- case 2:
+ return 'red';
+ case 2: // failed-dependency
+ return 'lightcoral';
case 3:
case 4:
return 'red';
base-commit: 19c09d53395bf50810fce679e07187304b9f9a8c
--
2.45.2