cuirass: Color the failures that are because of a dependency light red (differently from red)

  • Done
  • quality assurance status badge
Details
2 participants
  • Danny Milosavljevic
  • Ludovic Courtès
Owner
unassigned
Submitted by
Danny Milosavljevic
Severity
normal

Debbugs page

Danny Milosavljevic wrote 7 months ago
(address . guix-patches@gnu.org)
20240813081836.7C08A1120E5C@dd30410.kasserver.com
Attachment: file
From 2e1ddf5bc553ee2218489fd9ef2467bd1e5cf7c0 Mon Sep 17 00:00:00 2001
Message-ID: <2e1ddf5bc553ee2218489fd9ef2467bd1e5cf7c0.1723458264.git.dannym@scratchpost.org>
From: Danny Milosavljevic <dannym@scratchpost.org>
Date: Mon, 12 Aug 2024 12:16:12 +0200
Subject: [PATCH] js: Color failures where a dependency has failed already
light red.

* src/static/js/cuirass.js (color): Modify.
---
src/static/js/cuirass.js | 4 +++-
1 file changed, 3 insertions(+), 1 deletion(-)

Toggle diff (19 lines)
diff --git a/src/static/js/cuirass.js b/src/static/js/cuirass.js
index 42f28f1..b09fab2 100644
--- a/src/static/js/cuirass.js
+++ b/src/static/js/cuirass.js
@@ -150,7 +150,9 @@ ready(() => {
case 0:
return '#9f9'; /* high contrast with others */
case 1:
- case 2:
+ return 'red';
+ case 2: // failed-dependency
+ return 'lightcoral';
case 3:
case 4:
return 'red';

base-commit: 19c09d53395bf50810fce679e07187304b9f9a8c
--
2.45.2
Ludovic Courtès wrote 7 months ago
(name . Danny Milosavljevic)(address . dannym@scratchpost.org)(address . 72601-done@debbugs.gnu.org)
87y14rs5g1.fsf@gnu.org
Hi Danny,

"Danny Milosavljevic" <dannym@scratchpost.org> skribis:

Toggle quote (9 lines)
>>From 2e1ddf5bc553ee2218489fd9ef2467bd1e5cf7c0 Mon Sep 17 00:00:00 2001
> Message-ID: <2e1ddf5bc553ee2218489fd9ef2467bd1e5cf7c0.1723458264.git.dannym@scratchpost.org>
> From: Danny Milosavljevic <dannym@scratchpost.org>
> Date: Mon, 12 Aug 2024 12:16:12 +0200
> Subject: [PATCH] js: Color failures where a dependency has failed already
> light red.
>
> * src/static/js/cuirass.js (color): Modify.

Good idea. Pushed, thanks!

Ludo’.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 72601@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 72601
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help