[PATCH] gnu: mrg: Fix the build.

  • Done
  • quality assurance status badge
Details
3 participants
  • Ludovic Courtès
  • Artyom V. Poptsov
  • Zheng Junjie
Owner
unassigned
Submitted by
Artyom V. Poptsov
Severity
normal

Debbugs page

Artyom V. Poptsov wrote 7 months ago
(address . guix-patches@gnu.org)(name . Artyom V. Poptsov)(address . poptsov.artyom@gmail.com)
796059497039c32f36d6202900cac0b33d643e25.1723499151.git.poptsov.artyom@gmail.com
* gnu/packages/graphics.scm (mrg): Fix the build.
[arguments]: Add "patch-meson-build" phase.
[home-page]: Fix the URL.

Change-Id: If6f1a255e864669a10c646ee0d991e6fabdcb6b9
---
gnu/packages/graphics.scm | 12 +++++++++++-
1 file changed, 11 insertions(+), 1 deletion(-)

Toggle diff (34 lines)
diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index 8eae1ed89d..1d5fc1e4da 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -162,6 +162,16 @@ (define-public mmm
(sha256
(base32 "1xmcv6rwinqsbr863rgl9005h2jlmd7k2qrwsc1h4fb8r61ykpjl"))))
(build-system meson-build-system)
+ (arguments
+ (list #:phases #~(modify-phases %standard-phases
+ ;; XXX: Meson build fails due to a misspelling of
+ ;; "description" keyword in the configuration. This phase
+ ;; fixes that.
+ (add-after 'unpack 'patch-meson-build
+ (lambda _
+ (substitute* "meson.build"
+ (("not stable, Description:")
+ "not stable, description:")))))))
(native-inputs
(list luajit pkg-config))
(inputs
@@ -169,7 +179,7 @@ (define-public mmm
(synopsis "Memory Mapped Machine")
(description "MMM is a shared memory protocol for virtualising access to
framebuffer graphics, audio output and input event.")
- (home-page "https://github.com/hodefoting/mrg")
+ (home-page "https://github.com/hodefoting/mmm")
(license license:isc)))
(define-public directfb

base-commit: 487dd0077fed2ef7a91bd71af0e23421ab715710
--
2.45.2
Zheng Junjie wrote 7 months ago
(name . Artyom V. Poptsov)(address . poptsov.artyom@gmail.com)(address . 72596@debbugs.gnu.org)
87mslb8z0i.fsf@iscas.ac.cn
"Artyom V. Poptsov" <poptsov.artyom@gmail.com> writes:

Toggle quote (28 lines)
> * gnu/packages/graphics.scm (mrg): Fix the build.
> [arguments]: Add "patch-meson-build" phase.
> [home-page]: Fix the URL.
>
> Change-Id: If6f1a255e864669a10c646ee0d991e6fabdcb6b9
> ---
> gnu/packages/graphics.scm | 12 +++++++++++-
> 1 file changed, 11 insertions(+), 1 deletion(-)
>
> diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
> index 8eae1ed89d..1d5fc1e4da 100644
> --- a/gnu/packages/graphics.scm
> +++ b/gnu/packages/graphics.scm
> @@ -162,6 +162,16 @@ (define-public mmm
> (sha256
> (base32 "1xmcv6rwinqsbr863rgl9005h2jlmd7k2qrwsc1h4fb8r61ykpjl"))))
> (build-system meson-build-system)
> + (arguments
> + (list #:phases #~(modify-phases %standard-phases
> + ;; XXX: Meson build fails due to a misspelling of
> + ;; "description" keyword in the configuration. This phase
> + ;; fixes that.
> + (add-after 'unpack 'patch-meson-build
> + (lambda _
> + (substitute* "meson.build"
> + (("not stable, Description:")
> + "not stable, description:")))))))

Microraptor gui is discontinued

maybe we should drop this package.


Toggle quote (10 lines)
> (native-inputs
> (list luajit pkg-config))
> (inputs
> @@ -169,7 +179,7 @@ (define-public mmm
> (synopsis "Memory Mapped Machine")
> (description "MMM is a shared memory protocol for virtualising access to
> framebuffer graphics, audio output and input event.")
> - (home-page "https://github.com/hodefoting/mrg")
> + (home-page "https://github.com/hodefoting/mmm")

should new patch.

Toggle quote (5 lines)
> (license license:isc)))
>
> (define-public directfb
>
> base-commit: 487dd0077fed2ef7a91bd71af0e23421ab715710
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEfr6klGDOXiwIdX/bO1qpk+Gi3/AFAmbAPb0ACgkQO1qpk+Gi
3/C11w//T7KXb58qGjnBAdyzc+3A3P0DSrReSAzw3yovC6j73QIR/ojlrkKoj/Zk
iRLSgnEHDvS5UzYDvvd8tyGee53rj5nj6vhC7EqkE9TYdsh/73uFa1QEp8aAFw3j
rXhCZfDJtgrb1Qnd2/aBM5wadzR9qt161+QR0dpZP+X5j4iudNutECndIyexhAKf
Ztgr+dWPjXTk8NlQouxrc3GZWEY0VRohR/zHRjilCm4N6JjPvT6JRU33Vw1ub3vk
ZXCcz/IsAXKaOtDVmDaYb5UGMI4I9tsk0hJ1yeRFDoARLhMWVkoPjfkY0SXcp3Re
rux7EE75p4T2kf8ByzIAlRz4pTGJQIWOhbG7iY6XweQ7FWrsO1H+pCb55M6Up03M
ZMQHpdCqb3mCukKK/1l1EzZA7ZV8qGiIdiaO00M7zzEjVKS3lp/uLWwr9i9b+oR+
NByZM/r7G+gt+M+r8adFvAa3hqrXiPi2BdCXOpLwdtB32xAHt7aSmGVeY+mQe7lY
ziMy+GwHXNg2CyhNPSIqRALIQRaEZG3a8uM/Iwafxm0GbKV0aT+sD7jpzJ/13lzC
lfeYfU7/FF1FHEHtCDBBWQwBckpWlDycktn+J8l1Te9f/uOxJHlp4k5h18L1MBKJ
jjgFLMZa6oGXZOpkuCJwD73xqYZWBtGoMn2TXI/SNnL0GXYczXo=
=4r3q
-----END PGP SIGNATURE-----

Ludovic Courtès wrote 6 months ago
(name . Artyom V. Poptsov)(address . poptsov.artyom@gmail.com)(address . 72596-done@debbugs.gnu.org)
87cyloiqzs.fsf@gnu.org
"Artyom V. Poptsov" <poptsov.artyom@gmail.com> skribis:

Toggle quote (6 lines)
> * gnu/packages/graphics.scm (mrg): Fix the build.
> [arguments]: Add "patch-meson-build" phase.
> [home-page]: Fix the URL.
>
> Change-Id: If6f1a255e864669a10c646ee0d991e6fabdcb6b9

Finally applied, thanks!
Closed
Ludovic Courtès wrote 6 months ago
(name . Zheng Junjie)(address . zhengjunjie@iscas.ac.cn)
878qwciqwd.fsf@gnu.org
Hi Zheng,

Zheng Junjie <zhengjunjie@iscas.ac.cn> skribis:

Toggle quote (8 lines)
> "Artyom V. Poptsov" <poptsov.artyom@gmail.com> writes:
>
>> * gnu/packages/graphics.scm (mrg): Fix the build.
>> [arguments]: Add "patch-meson-build" phase.
>> [home-page]: Fix the URL.
>>
>> Change-Id: If6f1a255e864669a10c646ee0d991e6fabdcb6b9

[...]

Toggle quote (9 lines)
>> + (substitute* "meson.build"
>> + (("not stable, Description:")
>> + "not stable, description:")))))))
>
> see https://github.com/hodefoting/mrg/blob/master/README.md
> Microraptor gui is discontinued
>
> maybe we should drop this package.

[...]

Toggle quote (4 lines)
>
> should new patch.

I applied the patch anyway because it fixes an immediate issue, and
moving the ‘home-page’ to a separate patch is not worth the trouble and
cognitive overhead. I hope that makes sense.

If you think there are good reasons to remove the package, maybe submit
a patch doing so?

Thanks,
Ludo’.
?
Your comment

This issue is archived.

To comment on this conversation send an email to 72596@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 72596
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help