Artyom V. Poptsov wrote 7 months ago
(address . guix-patches@gnu.org)(name . Artyom V. Poptsov)(address . poptsov.artyom@gmail.com)
* gnu/packages/graphics.scm (mrg): Fix the build.
[arguments]: Add "patch-meson-build" phase.
[home-page]: Fix the URL.
Change-Id: If6f1a255e864669a10c646ee0d991e6fabdcb6b9
---
gnu/packages/graphics.scm | 12 +++++++++++-
1 file changed, 11 insertions(+), 1 deletion(-)
Toggle diff (34 lines)
diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index 8eae1ed89d..1d5fc1e4da 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -162,6 +162,16 @@ (define-public mmm
(sha256
(base32 "1xmcv6rwinqsbr863rgl9005h2jlmd7k2qrwsc1h4fb8r61ykpjl"))))
(build-system meson-build-system)
+ (arguments
+ (list #:phases #~(modify-phases %standard-phases
+ ;; XXX: Meson build fails due to a misspelling of
+ ;; "description" keyword in the configuration. This phase
+ ;; fixes that.
+ (add-after 'unpack 'patch-meson-build
+ (lambda _
+ (substitute* "meson.build"
+ (("not stable, Description:")
+ "not stable, description:")))))))
(native-inputs
(list luajit pkg-config))
(inputs
@@ -169,7 +179,7 @@ (define-public mmm
(synopsis "Memory Mapped Machine")
(description "MMM is a shared memory protocol for virtualising access to
framebuffer graphics, audio output and input event.")
- (home-page "https://github.com/hodefoting/mrg")
+ (home-page "https://github.com/hodefoting/mmm")
(license license:isc)))
(define-public directfb
base-commit: 487dd0077fed2ef7a91bd71af0e23421ab715710
--
2.45.2