[PATCH 0/7] Add some of the Google gvisor dependencies.

  • Done
  • quality assurance status badge
Details
2 participants
  • Artyom V. Poptsov
  • Sharlatan Hellseher
Owner
unassigned
Submitted by
Artyom V. Poptsov
Severity
normal
A
A
Artyom V. Poptsov wrote on 12 Aug 19:24 +0200
(address . guix-patches@gnu.org)(name . Artyom V. Poptsov)(address . poptsov.artyom@gmail.com)
cover.1723483365.git.poptsov.artyom@gmail.com
This patchset adds some of the Google gvisor dependencies:

Artyom V. Poptsov (7):
gnu: Add go-github-com-gofrs-flock.
gnu: Add go-github-com-google-subcommands.
gnu: Add go-github-com-mattbaird-jsonpatch.
gnu: Add go-github-com-mohae-deepcopy.
gnu: Add go-github-com-containerd-fifo.
gnu: Add go-github-com-containerd-typeurl.
gnu: Add go-github-com-containerd-typeurl-v2.

gnu/packages/golang.scm | 176 ++++++++++++++++++++++++++++++++++++++++
1 file changed, 176 insertions(+)


base-commit: e928854a0f76cef3b11a06160a16130c59954b76
--
2.45.2
A
A
Artyom V. Poptsov wrote on 12 Aug 19:26 +0200
[PATCH 1/7] gnu: Add go-github-com-gofrs-flock.
(address . 72594@debbugs.gnu.org)(name . Artyom V. Poptsov)(address . poptsov.artyom@gmail.com)
4a9952c6c7486f38bd83fe9962ce43fa35699f5e.1723483365.git.poptsov.artyom@gmail.com
* gnu/packages/golang.scm (go-github-com-gofrs-flock): New variable.

Change-Id: If6856319258ec93f4119f4f7ec79d206d7e1087d
---
gnu/packages/golang.scm | 27 +++++++++++++++++++++++++++
1 file changed, 27 insertions(+)

Toggle diff (40 lines)
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 799a7d75ce..e74c50f2e7 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -2556,6 +2556,33 @@ (define-public go-github-com-gizak-termui
mouse, and terminal resizing events.")
(license license:expat)))
+(define-public go-github-com-gofrs-flock
+ (package
+ (name "go-github-com-gofrs-flock")
+ (version "0.12.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/gofrs/flock/")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0kfnbcahr9x61k40wsrqzxxr3ybix0jqsm4ibpjgnhfgrln7ag8v"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/gofrs/flock"))
+ (native-inputs (list go-github-com-stretchr-testify))
+ (propagated-inputs (list go-golang-org-x-sys))
+ (home-page "https://github.com/gofrs/flock/")
+ (synopsis "Thread-safe file locking library in Go")
+ (description
+ "@code{flock} implements a thread-safe file lock.
+
+It also includes a non-blocking @code{TryLock} function to allow locking without
+blocking execution.")
+ (license license:bsd-3)))
+
(define-public go-github-com-golangplus-fmt
(package
(name "go-github-com-golangplus-fmt")
--
2.45.2
A
A
Artyom V. Poptsov wrote on 12 Aug 19:26 +0200
[PATCH 2/7] gnu: Add go-github-com-google-subcommands.
(address . 72594@debbugs.gnu.org)(name . Artyom V. Poptsov)(address . poptsov.artyom@gmail.com)
ee0ac7f0a197240bf3f125ed68443b23627bc71c.1723483365.git.poptsov.artyom@gmail.com
* gnu/packages/golang.scm (go-github-com-google-subcommands): New variable.

Change-Id: Ifbd51d785435fa8abb9d233e2846e8cf9642ae3f
---
gnu/packages/golang.scm | 23 +++++++++++++++++++++++
1 file changed, 23 insertions(+)

Toggle diff (36 lines)
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index e74c50f2e7..2d5844669e 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -8235,6 +8235,29 @@ (define-public go-github-com-google-shlex
using shell-style rules for quoting and commenting.")
(license license:asl2.0)))
+(define-public go-github-com-google-subcommands
+ (package
+ (name "go-github-com-google-subcommands")
+ (version "1.2.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/google/subcommands")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "00w7fx92696z5p3isvpg71b4023g8f686xnhy56k08vc2q1r2hhw"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/google/subcommands"))
+ (home-page "https://github.com/google/subcommands")
+ (synopsis "Go subcommand library")
+ (description
+ "@code{subcommands} is a Go package that implements a simple way for a single
+command to have many subcommands, each of which takes arguments and so forth.")
+ (license license:asl2.0)))
+
(define-public go-github-com-google-btree
(package
(name "go-github-com-google-btree")
--
2.45.2
A
A
Artyom V. Poptsov wrote on 12 Aug 19:26 +0200
[PATCH 3/7] gnu: Add go-github-com-mattbaird-jsonpatch.
(address . 72594@debbugs.gnu.org)(name . Artyom V. Poptsov)(address . poptsov.artyom@gmail.com)
610f6bc2f624a997e49b77338970440b39e8b426.1723483365.git.poptsov.artyom@gmail.com
* gnu/packages/golang.scm (go-github-com-mattbaird-jsonpatch): New variable.

Change-Id: I571c51f2141dbba53067f4279003a4604f21b1a4
---
gnu/packages/golang.scm | 29 +++++++++++++++++++++++++++++
1 file changed, 29 insertions(+)

Toggle diff (42 lines)
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 2d5844669e..82d9616b71 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -3636,6 +3636,35 @@ (define-public go-github-com-magiconair-properties
(description "Java properties scanner for Go")
(license license:bsd-2)))
+(define-public go-github-com-mattbaird-jsonpatch
+ (package
+ (name "go-github-com-mattbaird-jsonpatch")
+ (version "0.0.0-20171005235357-81af80346b1a")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/mattbaird/jsonpatch")
+ (commit (go-version->git-ref version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0ll22kpf75m72r7i5ddg3r87gdlagbj2x24bppgbi8jp018pdq95"))))
+ (build-system go-build-system)
+ (arguments
+ `(#:import-path "github.com/mattbaird/jsonpatch"))
+ (native-inputs (list go-github-com-stretchr-testify))
+ (home-page "https://github.com/mattbaird/jsonpatch")
+ (synopsis "JSON Patch library for Go")
+ (description
+ "@url{http://jsonpatch.com/, JSON Patch} implementation for Go as
+specified in @url{https://datatracker.ietf.org/doc/html/rfc6902/, RFC 6902} from the
+IETF.
+
+JSON Patch allows you to generate JSON that describes changes you want to make to a
+document, so you don't have to send the whole doc. JSON Patch format is supported by
+HTTP PATCH method, allowing for standards based partial updates via REST APIs.")
+ (license license:asl2.0)))
+
(define-public go-github-com-pelletier-go-toml
(package
(name "go-github-com-pelletier-go-toml")
--
2.45.2
A
A
Artyom V. Poptsov wrote on 12 Aug 19:26 +0200
[PATCH 4/7] gnu: Add go-github-com-mohae-deepcopy.
(address . 72594@debbugs.gnu.org)(name . Artyom V. Poptsov)(address . poptsov.artyom@gmail.com)
922e939026f7ea09cd14f3d01aa7972cebfbcc42.1723483365.git.poptsov.artyom@gmail.com
* gnu/packages/golang.scm (go-github-com-mohae-deepcopy): New variable.

Change-Id: I29dd0f9c61197e2030bd720bf0ec71c86727f976
---
gnu/packages/golang.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)

Toggle diff (37 lines)
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 82d9616b71..8208c79675 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -4085,6 +4085,30 @@ (define-public go-github-com-matrix-org-gomatrix
(description "This package provides a Golang Matrix client.")
(license license:asl2.0)))
+(define-public go-github-com-mohae-deepcopy
+ (package
+ (name "go-github-com-mohae-deepcopy")
+ (version "0.0.0-20170308212314-bb9b5e7adda9")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/mohae/deepcopy")
+ (commit (go-version->git-ref version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "173j05wv4yy8jh9ccjw46xfy1knxwvv1ir6b8l6g9pc5j5damm1f"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/mohae/deepcopy"))
+ (home-page "https://github.com/mohae/deepcopy")
+ (synopsis "Deep copy things")
+ (description
+ "@code{deepcopy} makes deep copies of things: unexported field
+values are not copied.")
+ (license license:expat)))
+
(define-public go-github-com-aarzilli-golua
(let ((commit "03fc4642d792b1f2bc5e7343b403cf490f8c501d")
(revision "0"))
--
2.45.2
A
A
Artyom V. Poptsov wrote on 12 Aug 19:26 +0200
[PATCH 5/7] gnu: Add go-github-com-containerd-fifo.
(address . 72594@debbugs.gnu.org)(name . Artyom V. Poptsov)(address . poptsov.artyom@gmail.com)
cf83902565f88ab552ac19632da1a2af1201b2ee.1723483365.git.poptsov.artyom@gmail.com
* gnu/packages/golang.scm (go-github-com-containerd-fifo): New variable.

Change-Id: I782f792560bdbe59d31fac7762e07b378a9c29fb
---
gnu/packages/golang.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)

Toggle diff (37 lines)
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 8208c79675..354c1506d5 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -7901,6 +7901,30 @@ (define-public go-github-com-containerd-console
dependencies and a simple API.")
(license license:asl2.0)))
+(define-public go-github-com-containerd-fifo
+ (package
+ (name "go-github-com-containerd-fifo")
+ (version "1.1.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/containerd/fifo")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1ddb1spairbsjkvxqysa7pzb5za07dvv1aay3mqr160gh2za3kd4"))))
+ (build-system go-build-system)
+ (arguments
+ `(#:import-path "github.com/containerd/fifo"))
+ (native-inputs (list go-github-com-stretchr-testify))
+ (propagated-inputs (list go-golang-org-x-sys))
+ (home-page "https://github.com/containerd/fifo")
+ (synopsis "FIFO package for Go")
+ (description
+ "This is Golang package Go package for handling FIFOs in a sane way.")
+ (license license:asl2.0)))
+
(define-public go-github-com-arceliar-ironwood
(package
(name "go-github-com-arceliar-ironwood")
--
2.45.2
A
A
Artyom V. Poptsov wrote on 12 Aug 19:26 +0200
[PATCH 6/7] gnu: Add go-github-com-containerd-typeurl.
(address . 72594@debbugs.gnu.org)(name . Artyom V. Poptsov)(address . poptsov.artyom@gmail.com)
75c43d20defa405c7ce55899f7d5913fd3e284f8.1723483365.git.poptsov.artyom@gmail.com
* gnu/packages/golang.scm (go-github-com-containerd-typeurl): New variable.

Change-Id: I7e997d73fcc3ec04e17c0067b702c6eb86a29bd3
---
gnu/packages/golang.scm | 30 ++++++++++++++++++++++++++++++
1 file changed, 30 insertions(+)

Toggle diff (43 lines)
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 354c1506d5..dd16e374ff 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -7925,6 +7925,36 @@ (define-public go-github-com-containerd-fifo
"This is Golang package Go package for handling FIFOs in a sane way.")
(license license:asl2.0)))
+(define-public go-github-com-containerd-typeurl
+ (package
+ (name "go-github-com-containerd-typeurl")
+ (version "1.0.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/containerd/typeurl")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0wvfxlxgkln11d9s6rxay965c715bnpk203klbsq8m8qpjqrz620"))))
+ (build-system go-build-system)
+ (arguments
+ (list #:import-path "github.com/containerd/typeurl"))
+ (propagated-inputs (list go-github-com-gogo-protobuf
+ go-github-com-pkg-errors))
+ (home-page "https://github.com/containerd/typeurl")
+ (synopsis "Go package for managing marshaled types to @code{protobuf.Any}")
+ (description
+ "A Go package for managing the registration, marshaling, and unmarshaling of
+encoded types.
+
+This package helps when types are sent over a ttrpc/GRPC API and marshaled as a
+protobuf
+@url{https://pkg.go.dev/google.golang.org/protobuf@@v1.27.1/types/known/anypb#Any,
+Any}.")
+ (license license:asl2.0)))
+
(define-public go-github-com-arceliar-ironwood
(package
(name "go-github-com-arceliar-ironwood")
--
2.45.2
A
A
Artyom V. Poptsov wrote on 12 Aug 19:26 +0200
[PATCH 7/7] gnu: Add go-github-com-containerd-typeurl-v2.
(address . 72594@debbugs.gnu.org)(name . Artyom V. Poptsov)(address . poptsov.artyom@gmail.com)
f562ec4eeca20a1d44d31c407b1cc5d525c3788d.1723483365.git.poptsov.artyom@gmail.com
* gnu/packages/golang.scm (go-github-com-containerd-typeurl-v2): New variable.

Change-Id: I2468cff298ef8b73ddbf24cccb86a1a85ca67a15
---
gnu/packages/golang.scm | 19 +++++++++++++++++++
1 file changed, 19 insertions(+)

Toggle diff (32 lines)
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index dd16e374ff..8734e5f677 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -7955,6 +7955,25 @@ (define-public go-github-com-containerd-typeurl
Any}.")
(license license:asl2.0)))
+(define-public go-github-com-containerd-typeurl-v2
+ (package
+ (inherit go-github-com-containerd-typeurl)
+ (name "go-github-com-containerd-typeurl-v2")
+ (version "2.2.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/containerd/typeurl")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1n43s8zqwwrvpzb0pczm73xx4w8yb96ax31cripzxmfhj43z21b5"))))
+ (arguments
+ (list #:import-path "github.com/containerd/typeurl/v2"))
+ (propagated-inputs (list go-github-com-gogo-protobuf
+ go-google-golang-org-protobuf))))
+
(define-public go-github-com-arceliar-ironwood
(package
(name "go-github-com-arceliar-ironwood")
--
2.45.2
S
S
Sharlatan Hellseher wrote on 21 Aug 15:57 +0200
[PATCH 0/7] Add some of the Google gvisor dependencies.
(address . 72594-done@debbugs.gnu.org)
877ccac71l.fsf@gmail.com
Hi,

After QA is green I've applied patches and pushed as fe10af6375..5812c99b85 to master.

Please, avoid adding packages to golang.scm it's in a process of moving
packages out of it to logical sub modules.

- patches [6/6]
- [X] [PATCH 1/7] gnu: Add go-github-com-gofrs-flock.
- Place to golang-xyz
- [X] [PATCH 2/7] gnu: Add go-github-com-google-subcommands.
- Adjust description
- Place to golang-xy
- [X] [PATCH 3/7] gnu: Add go-github-com-mattbaird-jsonpatch.
- Update to 0.0.0-20240118010651-0ba75a80ca38
- Place to golang-web
- [X] [PATCH 4/7] gnu: Add go-github-com-mohae-deepcopy.
- Place to golang-xyz
- Adjust description
- [X] [PATCH 5/7] gnu: Add go-github-com-containerd-fifo.
- Place to golang-xyz
- [X] [PATCH 6/7] gnu: Add go-github-com-containerd-typeurl.
- Squash with [PATCH 7/7] gnu: Add go-github-com-containerd-typeurl-v2.
- Place to golang-web

Thanks.

--
Oleg
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEmEeB3micIcJkGAhndtcnv/Ys0rUFAmbF8lYACgkQdtcnv/Ys
0rXQ4A//YLWt00PHdpzcQlEm8z9LNZqeYxVqyw1uVvXJYzT1PLKzRLTEyf9tNgEi
itn9XCinCBMCOpjOiFut8g2t7NEmXqlMzKY/ZMOpjREIKEBhe05uVO9PwBSZg23v
zMsXhf2Z9vyAkmAkb5UQ6LNlTHqkrdAlfcHzFyFBJg8pi35FYxzdKAA4DUCQt0wj
hxzggwpk97PkqSFBYFvL4n9R4rtf4HnaprMvNf9goy0Y6io8lQLDT75aFKrXF1zj
M/cfssc4XVdk6AF86LZWylgtXkDXJlJzpCXBhfRn/PX40HF2eMU713CML+yvmBzj
ilKXhEpzeyCWxP8nKEwo/qCcQWWRDZw1scCTz7r4eck8iXojymu+VFw+JcTbIa0k
HaWKLa703eZRPY7SXKid1OT540bNO1soc9rnoGhyzRb1sFK7ytUw8AYmA+LU25BB
lG6kp14J7A3zAU5cLv0w/pj5wL8p0wECpNU4gwGdlmHA4cVfsP83wzfrRi2Vju/O
GvKLioaX0TvwJ42a2xfBdZaByh5EmiVFNgNlxatiGypLXRMF2MiO/bM4EWPqXGU3
5mlAxrlXDN4QhUWn08LjyXAItn/iLVJFBmiBCTgBN9yr0am4ymdMvd+Rpx8H000V
H5p0mgeu3R1hJzUaW1Wp5IOVc3qgJJG+2A9aE2y0H54L4p2a/Xk=
=2BYs
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 72594@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 72594
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch