(address . guix-patches@gnu.org)
From 7055c1c7e9b7458d5c905a21c8efd4818425faf2 Mon Sep 17 00:00:00 2001
Message-ID: <7055c1c7e9b7458d5c905a21c8efd4818425faf2.1723445985.git.adam.faiz@disroot.org>
From: AwesomeAdam54321 <adam.faiz@disroot.org>
Date: Mon, 12 Aug 2024 14:50:40 +0800
Subject: [PATCH] gnu: Add firebird-emu.
* gnu/packages/maths.scm (firebird-emu): New variable.
---
gnu/packages/maths.scm | 47 ++++++++++++++++++++++++++++++++++++++++++
1 file changed, 47 insertions(+)
Toggle diff (69 lines)
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index e3bb14a3c2..83015f5346 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -104,6 +104,7 @@ (define-module (gnu packages maths)
#:use-module (guix build-system perl)
#:use-module (guix build-system pyproject)
#:use-module (guix build-system python)
+ #:use-module (guix build-system qt)
#:use-module (guix build-system ruby)
#:use-module (gnu packages algebra)
#:use-module (gnu packages audio)
@@ -9439,6 +9440,52 @@ (define-public qalculate-gtk
interval arithmetic, plotting.")
(license license:gpl2+)))
+(define-public firebird-emu
+ (package
+ (name "firebird-emu")
+ (version "1.6")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/nspire-emus/firebird")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0q8j2prs7713drwdgxwi1dhzk4gp9d908bx6p15fh5x2ffb676v6"))
+ (modules '((guix build utils)))
+ (snippet
+ #~(begin
+ (substitute* "firebird.pro"
+ (("core/gif-h/gif\\.h")
+ "core/gif.h"))))))
+ (arguments
+ (list
+ #:tests? #f ; no tests
+ #:phases
+ #~(modify-phases %standard-phases
+ (delete 'configure)
+ (replace 'build
+ (lambda _
+ (mkdir-p "build")
+ (chdir "build")
+ (invoke "qmake" (string-append "PREFIX=" #$output) "..")
+ (invoke "make"))))))
+ (build-system qt-build-system)
+ (inputs
+ (list qtbase-5
+ zlib))
+ (propagated-inputs
+ (list qtdeclarative-5 qtquickcontrols-5))
+ (synopsis "TI Nspire calculator emulator")
+ (description
+ "Firebird Emu is an emulator for the TI Nspire calculator series.
+It supports the emulation of Nspire Touchpad (CAS), CX (CAS)
+and CX II (-T/CAS) calculators. Note that this package does @emph{not}
+provide the ROM images.")
+ (home-page "https://github.com/nspire-emus/firebird")
+ (license license:gpl3+)))
+
(define-public numdiff
(package
(name "numdiff")
base-commit: b20956651a53a8f23828fdeb6945e1a31e6997a8
--
2.41.0