[PATCH] gnu: Add elinks.

  • Open
  • quality assurance status badge
Details
4 participants
  • Adam Faiz
  • Ludovic Courtès
  • Nicolas Graves
  • Zheng Junjie
Owner
unassigned
Submitted by
Adam Faiz
Severity
normal
A
A
Adam Faiz wrote on 11 Aug 11:29 +0200
(address . guix-patches@gnu.org)
90ca0a57-30bf-2b10-5e27-6b6d3e709cbe@disroot.org
From e5f84076855745ba103053933beafbd75a4c68d2 Mon Sep 17 00:00:00 2001
Message-ID: <e5f84076855745ba103053933beafbd75a4c68d2.1723368423.git.adam.faiz@disroot.org>
From: AwesomeAdam54321 <adam.faiz@disroot.org>
Date: Sun, 11 Aug 2024 17:26:37 +0800
Subject: [PATCH] gnu: Add elinks.

* gnu/packages/web-browsers.scm (elinks): New variable.
---
gnu/packages/web-browsers.scm | 57 +++++++++++++++++++++++++++++++++++
1 file changed, 57 insertions(+)

Toggle diff (86 lines)
diff --git a/gnu/packages/web-browsers.scm b/gnu/packages/web-browsers.scm
index 4a2b28916d..adb9444dac 100644
--- a/gnu/packages/web-browsers.scm
+++ b/gnu/packages/web-browsers.scm
@@ -97,6 +97,7 @@ (define-module (gnu packages web-browsers)
#:use-module (gnu packages python-xyz)
#:use-module (gnu packages qt)
#:use-module (gnu packages readline)
+ #:use-module (gnu packages regex)
#:use-module (gnu packages sdl)
#:use-module (gnu packages sqlite)
#:use-module (gnu packages suckless)
@@ -105,6 +106,7 @@ (define-module (gnu packages web-browsers)
#:use-module (gnu packages tls)
#:use-module (gnu packages web)
#:use-module (gnu packages webkit)
+ #:use-module (gnu packages xml)
#:use-module (gnu packages xorg))
(define-public midori
@@ -218,6 +220,61 @@ (define-public links
;; linking of the program with openssl.
(license license:gpl1+)))
+(define-public elinks
+ (package
+ (name "elinks")
+ (version "0.17.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/rkd77/elinks")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0ij738y1ig2cdfdim85al9iyqz6cwrfac0zg0mqrqj9af0q25r95"))))
+ (build-system gnu-build-system)
+ (arguments
+ (list
+ #:configure-flags
+ #~(list "--enable-finger"
+ "--enable-html-highlight"
+ "--enable-gopher"
+ "--enable-gemini"
+ "--enable-cgi"
+ "--enable-bittorrent"
+ "--enable-nntp"
+ "--enable-256-colors"
+ "--enable-true-color"
+ "--with-brotli"
+ "--with-lzma"
+ "--with-libev")))
+ (native-inputs
+ (list autoconf
+ automake
+ gnu-gettext
+ pkg-config))
+ (inputs
+ (list brotli
+ bzip2
+ expat
+ gnutls
+ gpm
+ libev
+ libgcrypt
+ libidn
+ lua
+ tre
+ xz
+ zlib))
+ (synopsis "Advanced text mode web browser")
+ (description "ELinks is a feature-rich program for browsing the web
+in text mode. It can render both frames and tables, is highly customisable
+and can be extended via Lua scripts. It is like an enhanced Lynx and Links.")
+ (home-page "http://elinks.cz/")
+ (license license:gpl2+)))
+
(define-public luakit
(package
(name "luakit")

base-commit: b20956651a53a8f23828fdeb6945e1a31e6997a8
--
2.41.0
N
N
Nicolas Graves wrote on 15 Aug 18:57 +0200
QA review for 72572
(name . Adam Faiz)(address . adam.faiz@disroot.org)
87sev5d8qs.fsf@ngraves.fr
user guix
usertag 72572 + reviewed-looks-good
thanks

Guix QA review form submission:
Hi Adam,
Thanks for this package, it builds deterministically and no lints. I just have a doubt over the license given both the description that it&apos;s GPVv2 and not later (so license:gpl2 would seem more appropriate instead of license:gpl2+). Additionnally, other licenses are evocated in this file :
although I&apos;m not sure we should include all these licenses.

Items marked as checked: Lint warnings, Package builds, Commit messages, New package tests, New package synopsis and descriptions

--
Best regards,
Nicolas Graves
Z
Z
Zheng Junjie wrote on 17 Aug 05:28 +0200
Re: [bug#72572] [PATCH] gnu: Add elinks.
(name . Adam Faiz via Guix-patches via)(address . guix-patches@gnu.org)
874j7jakud.fsf@iscas.ac.cn
Adam Faiz via Guix-patches via <guix-patches@gnu.org> writes:

Toggle quote (51 lines)
> From e5f84076855745ba103053933beafbd75a4c68d2 Mon Sep 17 00:00:00 2001
> Message-ID: <e5f84076855745ba103053933beafbd75a4c68d2.1723368423.git.adam.faiz@disroot.org>
> From: AwesomeAdam54321 <adam.faiz@disroot.org>
> Date: Sun, 11 Aug 2024 17:26:37 +0800
> Subject: [PATCH] gnu: Add elinks.
>
> * gnu/packages/web-browsers.scm (elinks): New variable.
> ---
> gnu/packages/web-browsers.scm | 57 +++++++++++++++++++++++++++++++++++
> 1 file changed, 57 insertions(+)
>
> diff --git a/gnu/packages/web-browsers.scm b/gnu/packages/web-browsers.scm
> index 4a2b28916d..adb9444dac 100644
> --- a/gnu/packages/web-browsers.scm
> +++ b/gnu/packages/web-browsers.scm
> @@ -97,6 +97,7 @@ (define-module (gnu packages web-browsers)
> #:use-module (gnu packages python-xyz)
> #:use-module (gnu packages qt)
> #:use-module (gnu packages readline)
> + #:use-module (gnu packages regex)
> #:use-module (gnu packages sdl)
> #:use-module (gnu packages sqlite)
> #:use-module (gnu packages suckless)
> @@ -105,6 +106,7 @@ (define-module (gnu packages web-browsers)
> #:use-module (gnu packages tls)
> #:use-module (gnu packages web)
> #:use-module (gnu packages webkit)
> + #:use-module (gnu packages xml)
> #:use-module (gnu packages xorg))
>
> (define-public midori
> @@ -218,6 +220,61 @@ (define-public links
> ;; linking of the program with openssl.
> (license license:gpl1+)))
>
> +(define-public elinks
> + (package
> + (name "elinks")
> + (version "0.17.0")
> + (source
> + (origin
> + (method git-fetch)
> + (uri (git-reference
> + (url "https://github.com/rkd77/elinks")
> + (commit (string-append "v" version))))
> + (file-name (git-file-name name version))
> + (sha256
> + (base32
> + "0ij738y1ig2cdfdim85al9iyqz6cwrfac0zg0mqrqj9af0q25r95"))))
> + (build-system gnu-build-system)

can you switch to meson-build-system? I think it's better this way.

Toggle quote (45 lines)
> + (arguments
> + (list
> + #:configure-flags
> + #~(list "--enable-finger"
> + "--enable-html-highlight"
> + "--enable-gopher"
> + "--enable-gemini"
> + "--enable-cgi"
> + "--enable-bittorrent"
> + "--enable-nntp"
> + "--enable-256-colors"
> + "--enable-true-color"
> + "--with-brotli"
> + "--with-lzma"
> + "--with-libev")))
> + (native-inputs
> + (list autoconf
> + automake
> + gnu-gettext
> + pkg-config))
> + (inputs
> + (list brotli
> + bzip2
> + expat
> + gnutls
> + gpm
> + libev
> + libgcrypt
> + libidn
> + lua
> + tre
> + xz
> + zlib))
> + (synopsis "Advanced text mode web browser")
> + (description "ELinks is a feature-rich program for browsing the web
> +in text mode. It can render both frames and tables, is highly customisable
> +and can be extended via Lua scripts. It is like an enhanced Lynx and Links.")
> + (home-page "http://elinks.cz/")
> + (license license:gpl2+)))
> +
> (define-public luakit
> (package
> (name "luakit")
>
> base-commit: b20956651a53a8f23828fdeb6945e1a31e6997a8
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEfr6klGDOXiwIdX/bO1qpk+Gi3/AFAmbAGPoACgkQO1qpk+Gi
3/B4Ng/+I4TaI/pvwWYXyMupVjCxC/HgfjKzAkwo2pC+wT50oSy8J6EtdyB2+qHT
iGUk9m/0JfkCMwZQSDXYdOmulvGo30hgEQZl/Qwz3hxnQhoqVMyw4lG9fGEJKGwo
Opfm1S0psDFhmfgFXCsOxiLb/dGaCkyPGz91mULMzaDrta37sKKKO8ijM61Bi3/R
8IHZTnSuwI1w+d/qSM85c9bXs7m06TU81ZSYoy27wNu+vpQi9M0I+dMYSjh00t91
OguBhRPUk6fFoXz80Eu8x5/we81hb4tXpavqbIsMAzARUF1dfxUF9d/AGvIp+/g5
P6UwZHGIRpQDqpgdF2jvSOX8wgjhpr9vr5hfOEa2XfWM97gUECqYD+WFtkAS0CY6
jq0sItKvYf/OF7yrCKYr1q7DxWbXAiGNLHF75inmFchH3LZJv1PV3Uv1iDwzSihS
OsxBcdA70kS2iaWKfLvvKgaEqhpa1euBaGgdYa/ICpvamSNLbH5xU6CHx0phjHbd
HZvZDY7a4HPMhG7o50NAlIl0rL96hnxuNLeLyTtlTqLw5pRZMhz7QEPqfVY9m8+P
co34ARVzBOHLQQFo9Q1TcJw/5D6lEsRvGIyGwBN3efvOph0dOlJ2iDVkXGHjZHHJ
OSPYJlzexIDwepo9oKVjVIyutG3eJjghBz7Pc03xFSyequoVb4E=
=wDrJ
-----END PGP SIGNATURE-----

L
L
Ludovic Courtès wrote on 28 Aug 16:28 +0200
control message for bug #72572
(address . control@debbugs.gnu.org)
875xrklo19.fsf@gnu.org
tags 72572 + moreinfo
quit
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 72572@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 72572
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch